Results 1 to 4 of 4

Thread: Audio choppy beyond anything

  1. #1

    Exclamation Audio choppy beyond anything

    To start off, I'll post the specs of the machine:

    Dell Inspiron E1505
    3.2 GB Ram
    1.86 GHZ Intel Core Duo
    ATI X1400 GFX
    OpenSuse 11.4 KDE 32 bit.

    Okay, here are the details:

    Can't play any audio with Amarok when Desktop Effects are enabled because the minute a window is moved, it will distort the audio. Even when disabling Desktop Effects, some applications still cause this.

    Can't play YouTube videos even with Desktop Effects disabled because of the same reason.

    I just switched from Ubuntu and when I ran version 11.04, I had to disable KMS to do anything. I tried on OpenSuse 11.4 and the audio was flawless but the GFX went all to hell.

    All packages are up to date. Any suggestions?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Audio choppy beyond anything

    Quote Originally Posted by daswebmastri View Post
    Can't play any audio with Amarok when Desktop Effects are enabled because the minute a window is moved, it will distort the audio. Even when disabling Desktop Effects, some applications still cause this.

    Can't play YouTube videos even with Desktop Effects disabled because of the same reason.

    I just switched from Ubuntu and when I ran version 11.04, I had to disable KMS to do anything. I tried on OpenSuse 11.4 and the audio was flawless but the GFX went all to hell.

    All packages are up to date. Any suggestions?
    Suggestions. Yes. But NO guaranteed solutions. Just ideas you can try. (ergo don't shoot the messenger ! ... ).

    Note your X1400 is not the fastest card on the block. It will be relatively challenged to provide smooth Desktop Effects without impacting other processing (such as audio playback).

    Now (desktop dependent (ie KDE or GNOME)) you could try to increase the audio buffer size. I know this is rather obvious, but I thought I should mention it.

    You could also try to change the audio mode that amarok is using and also your browser is using when playing You Tube videos. First wrt You Tube videos, note they can be incredibly jerky due to simple You Tube streaming problems. MANY You Tube videos stream poorly.

    But to tune the audio mode, note that Amarok will typically use the desktop's chosen audio engine. I don't know about Gnome, but in the case of KDE that audio engine is selectable. One can select the xine engine, or gstreamer, or even vlc (without the appropriate phonon module installed). In the case of both vlc and xine, one can then tune the audio output mode to use pulse, or oss, or alsa api, or other options.

    You could try some of those settings.

    If you try those and you have no success, rather than say you tried x and it does not work, try to provide sufficient details so we can confirm you actually attempted it in a accurate manner. That will save a lot of iteration.

    Again, only suggestions, and no guarantees.

    Don't forget also in openSUSE-11.4 one can install 'pavucontrol' (pulse audio volume control) which also provides one a level of control over their device audio configuration that was not available without pulse. The downside is pulse can add an extra layer of overhead.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Audio choppy beyond anything

    I should also mention, take a look at the choppy-sound section in step-7 of this guide: SDB:Audio troubleshooting - openSUSE (I just updated it a few minutes ago).

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Audio choppy beyond anything

    And to be complete, there is a rather complex Linux Mint way to try to improve the efficiency of one's Pulse Audio. I have not tried it myself, but a quick skim through the instructions suggests that it 'might' also be applicable to openSUSE: Linux Mint Forums • View topic - PulseAudio - Tune your setting and prevent glitching (however no guarantees).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •