Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: install problem

  1. #1

    Default install problem

    after i have installed suse 11.4 on my acer m1300 my computer (desktop) won't auto boot.
    if i boot it manually my computer freezes.
    only if i boot it in revovery mode it continues with automatic confiration and it installs suse.
    but even than it won't reboot and i have to shutdown the hard way.
    when i restart the computer freezes and won't open opensuse.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: install problem

    Quote Originally Posted by hebra View Post
    after i have installed suse 11.4 on my acer m1300 my computer (desktop)
    Please, tell us what graphic card hardware your Acer m1300 has. I did a brief google search and found nothing helpful. But surely you must know.

    Did you try following the advice in the openSUSE-11.4 release notes ? ...ie install and boot with the boot code:
    Code:
    nomodeset

  3. #3

    Default Re: install problem

    yes, after nomodeset suse will start.
    but after i have shutdown the computer and i will restart i have the same problem.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: install problem

    Quote Originally Posted by hebra View Post
    yes, after nomodeset suse will start.
    but after i have shutdown the computer and i will restart i have the same problem.
    Just use nomodeset each time you start the computer. We can show you how to make this more permanent.

    But before we do that, please, can you boot your PC (with the nomodeset boot code) and type in a terminal:
    Code:
    /sbin/lspci -nnk | grep VGA -A2
    and post here the output. That will tell us what graphics your PC has. Please note that Linux is case sensitive.

  5. #5

    Default Re: install problem

    henk@linux-xnl3:~> /sbin/lspci -nnk | grep VGA -A2
    01:05.0 VGA compatible controller [0300]: ATI Technologies Inc 760G [Radeon 3000] [1002:9616]
    Subsystem: Acer Incorporated [ALI] Device [1025:024f]
    02:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f]
    Subsystem: PC Partner Limited Device [174b:e990]
    02:00.1 Audio device [0403]: ATI Technologies Inc RV710/730 [1002:aa38]
    henk@linux-xnl3:~>

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: install problem

    You have 2 video cards???? Are you setup to do crossfire? You may need to install the ATI/AMD propritary driver to make that work.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: install problem

    Quote Originally Posted by hebra View Post
    henk@linux-xnl3:~> /sbin/lspci -nnk | grep VGA -A2
    Code:
    01:05.0 VGA compatible controller [0300]: ATI Technologies Inc 760G [Radeon 3000] [1002:9616]
        Subsystem: Acer Incorporated [ALI] Device [1025:024f]
    02:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f]
        Subsystem: PC Partner Limited Device [174b:e990]
    Two graphic devices ... thats not so common. It MAKES a difference. Perhaps next time you could mention this in your first post ?

    I agree with gogalthorp, that you may need to install the proprietary AMD Catalyst (fglrx) driver to get the best performance.

    Which of those two devices do you have connected to your monitor ? The Radeon 3000 or the HD 4350 ? (I suspect the HD 4350).

    There is a bug in openSUSE-11.4 that with the 'as packaged' configuration the 'radeon' graphic driver does not boot properly to all radeon hardware (bug crept in around openSUSE-11.4 RC1 or so).

    Note with AMD hardware and openSUSE-11.4, when using the boot code 'nomodeset', the PC nominally (with no other configurations in place) boots to the older open source 'radeonhd' driver.

    Before you try the catalyst (fglrx) proprietary AMD video driver, you could also edit the /etc/X11/xorg.conf.d/50-device.conf file, and uncomment the line with 'radeon' in it (by removing the ' # ' ) so that that file reads:
    Code:
    Section "Device"
      Identifier "Default Device"
    
      Driver "radeon"
    
      ## Required magic for radeon/radeonhd drivers; output name
      ## (here: "DVI-0") can be figured out via 'xrandr -q'
      #Option "monitor-DVI-0" "Default Monitor"
    
    EndSection
    Then save the change and REBOOT with the boot code 'nomodeset' again, but this time the 'radeon' driver should load instead of the 'radeonhd' driver. That may give better performance.

  8. #8

    Default Re: install problem

    i'm sorry, but i don know what to do now.
    can you explain i to me in simple englisch.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: install problem

    Quote Originally Posted by hebra View Post
    i'm sorry, but i don know what to do now.
    What would you like to do now?

    You told us openSUSE-11.4 works ok if you enter the boot code 'nomodeset' each time you start your PC. Are you happy to do that each time you start your PC ? Did you want that 'nomodeset' made permanent so you do not have to type that each time you start your PC ? Please advise.

    Your PC is likely using the 'radeonhd' graphic driver? Would you like BETTER performance than the 'radeonhd' graphic driver ? If so you have 2 ways to do this:
    1. one way to get better performance is to use the open source 'radeon' graphic driver. You can do that by editing the /etc/X11/xorg.conf.d/50-device.conf file so that it looks like:
      Code:
      Section "Device"
        Identifier "Default Device"
      
        Driver "radeon"
      
        ## Required magic for radeon/radeonhd drivers; output name
        ## (here: "DVI-0") can be figured out via 'xrandr -q'
        #Option "monitor-DVI-0" "Default Monitor"
      
      EndSection
      Note the " # " in front of the following line was removed: 'Driver "radeon" . Make that change and save, and when starting your computer still use the boot code 'nomodeset'.
      .
    2. another different way to get even better performance is to use the proprietary AMD graphic driver. You can do that by following the guidance here: SDB:ATI drivers - openSUSE


    You can not use both ways at the same time because they use different video drivers.

  10. #10

    Default Re: install problem

    can you tell me how i can make nomodeset permanent.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •