Results 1 to 6 of 6

Thread: Mysql error on openSUSE 11.4 x64

  1. #1
    Join Date
    Jun 2011
    Posts
    9

    Default Mysql error on openSUSE 11.4 x64

    Hi,

    I started to play with mysql this week. installed the community database repository to have the more recent version. After see that is already installed, I run mysql_install_db the output is:

    Code:
    mysql_install_db
    Installing MySQL system tables...
    OK
    Filling help tables...
    OK
    
    PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
    To do so, start the server, then issue the following commands:
    
    /usr/bin/mysqladmin -u root password 'new-password'
    /usr/bin/mysqladmin -u root -h linux-tbn6 password 'new-password'
    
    Alternatively you can run:
    /usr/bin/mysql_secure_installation
    
    which will also give you the option of removing the test
    databases and anonymous user created by default.  This is
    strongly recommended for production servers.
    
    See the manual for more instructions.
    
    You can start the MySQL daemon with:
    rcmysql start
    
    You can test the MySQL daemon with mysql-test package
    
    Please report any problems with the /usr/bin/mysqlbug script!
    Running "rcmysql start" return:

    Code:
    Starting service MySQL warning: /var/run/mysql/mysql.sock didn't appear within 30 seconds
    chmod: cannot access `/var/run/mysql/mysqld.pid': No such file or directory
                                                                                                                                               failed
    In Yast > System > System Services, I tried start the my sql service and it return:

    Code:
    /etc/init.d/mysql start returned 1 (unspecified error):
    Running "/usr/bin/mysql_secure_installation" return:

    Code:
    NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MySQL
          SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!
    
    
    In order to log into MySQL to secure it, we'll need the current
    password for the root user.  If you've just installed MySQL, and
    you haven't set the root password yet, the password will be blank,
    so you should just press enter here.
    
    Enter current password for root (enter for none): 
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)
    I did some google-fu, but not find a solution.

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Mysql error on openSUSE 11.4 x64

    If you are just a MySQL beginner, you shouldn't tempt fate and just stick to the one that comes with the distro version before you jump into adventures like trying a community version.

  3. #3
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: Mysql error on openSUSE 11.4 x64

    Starting service MySQL warning: /var/run/mysql/mysql.sock didn't appear within 30 seconds
    chmod: cannot access `/var/run/mysql/mysqld.pid': No such file or directory
    There should be a log file in the directory /var/lib/mysql/ (the name of the logfile depends on your configuration). Have a look to see what it says.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  4. #4
    Join Date
    Jun 2011
    Posts
    9

    Default Re: Mysql error on openSUSE 11.4 x64

    Just resolved the problem today.

    First, I did what Ken_yap said, and downgraded to the default version.

    And worked ok, even with some errors executing "rcmysql start":

    Code:
    rcmysql start
    Will update MySQL now, if you encounter any problems, please read following file:
            /usr/share/doc/packages/mysql-community-server/README.SuSE
    Running protected MySQL... 
    Upgrading MySQL... 
    Looking for 'mysql' as: /usr/bin/mysql
    Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck
    Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysql/mysql.sock' '--socket=/var/tmp/mysql-protected.iuDxK9/mysql.sock' 
    Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysql/mysql.sock' '--socket=/var/tmp/mysql-protected.iuDxK9/mysql.sock' 
    mysql.columns_priv                                 OK
    mysql.db                                           OK
    mysql.event                                        OK
    mysql.func                                         OK
    mysql.general_log
    Error    : You can't use locks with log tables.
    status   : OK
    mysql.help_category                                OK
    mysql.help_keyword                                 OK
    mysql.help_relation                                OK
    mysql.help_topic                                   OK
    mysql.host                                         OK
    mysql.ndb_binlog_index                             OK
    mysql.plugin                                       OK
    mysql.proc                                         OK
    mysql.procs_priv                                   OK
    mysql.proxies_priv                                 OK
    mysql.servers                                      OK
    mysql.slow_log
    Error    : You can't use locks with log tables.
    status   : OK
    mysql.tables_priv                                  OK
    mysql.time_zone                                    OK
    mysql.time_zone_leap_second                        OK
    mysql.time_zone_name                               OK
    mysql.time_zone_transition                         OK
    mysql.time_zone_transition_type                    OK
    mysql.user                                         OK
    performance_schema.cond_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_current
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_history
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_history_long
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_by_instance
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_by_thread_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_global_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_summary_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_summary_by_instance
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.mutex_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.performance_timers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.rwlock_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_consumers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_instruments
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_timers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.threads
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    
    Repairing tables
    performance_schema.cond_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_current
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_history
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_history_long
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_by_instance
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_by_thread_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_global_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_summary_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_summary_by_instance
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.mutex_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.performance_timers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.rwlock_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_consumers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_instruments
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_timers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.threads
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    Running 'mysql_fix_privilege_tables'...
    OK
    Starting service MySQL                                                                                                                     done

    So, knowing that the problem is in the update, tried again, but now first I uninstalled the version 5.1 (checking the "Clean up When deleting packages" option) before installing the 5.5 from the community repositories. Yast asked for install mariadb to resolve some conflicts.

    After I installed the 5.5 one, Yast asked to Uninstall mariadb and worked flawlessly:

    the "rcmysql" start returned:

    Code:
    rcmysql start
    Will update MySQL now, if you encounter any problems, please read following file:
            /usr/share/doc/packages/mysql-community-server/README.SuSE
    Running protected MySQL... 
    Upgrading MySQL... 
    Looking for 'mysql' as: /usr/bin/mysql
    Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck
    Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysql/mysql.sock' '--socket=/var/tmp/mysql-protected.rkkJfV/mysql.sock' 
    Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysql/mysql.sock' '--socket=/var/tmp/mysql-protected.rkkJfV/mysql.sock' 
    mysql.columns_priv                                 OK
    mysql.db                                           OK
    mysql.event                                        OK
    mysql.func                                         OK
    mysql.general_log                                  OK
    mysql.help_category                                OK
    mysql.help_keyword                                 OK
    mysql.help_relation                                OK
    mysql.help_topic                                   OK
    mysql.host                                         OK
    mysql.ndb_binlog_index                             OK
    mysql.plugin                                       OK
    mysql.proc                                         OK
    mysql.procs_priv                                   OK
    mysql.proxies_priv                                 OK
    mysql.servers                                      OK
    mysql.slow_log                                     OK
    mysql.tables_priv                                  OK
    mysql.time_zone                                    OK
    mysql.time_zone_leap_second                        OK
    mysql.time_zone_name                               OK
    mysql.time_zone_transition                         OK
    mysql.time_zone_transition_type                    OK
    mysql.user                                         OK
    Running 'mysql_fix_privilege_tables'...
    OK
    Starting service MySQL                                                                                                                     done

    Working OK.

    Thank you all for the help!

  5. #5

    Default Re: Mysql error on openSUSE 11.4 x64

    Quote Originally Posted by s23 View Post
    Just resolved the problem today.

    First, I did what Ken_yap said, and downgraded to the default version.

    And worked ok, even with some errors executing "rcmysql start":

    Code:
    rcmysql start
    Will update MySQL now, if you encounter any problems, please read following file:
            /usr/share/doc/packages/mysql-community-server/README.SuSE
    Running protected MySQL... 
    Upgrading MySQL... 
    Looking for 'mysql' as: /usr/bin/mysql
    Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck
    Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysql/mysql.sock' '--socket=/var/tmp/mysql-protected.iuDxK9/mysql.sock' 
    Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysql/mysql.sock' '--socket=/var/tmp/mysql-protected.iuDxK9/mysql.sock' 
    mysql.columns_priv                                 OK
    mysql.db                                           OK
    mysql.event                                        OK
    mysql.func                                         OK
    mysql.general_log
    Error    : You can't use locks with log tables.
    status   : OK
    mysql.help_category                                OK
    mysql.help_keyword                                 OK
    mysql.help_relation                                OK
    mysql.help_topic                                   OK
    mysql.host                                         OK
    mysql.ndb_binlog_index                             OK
    mysql.plugin                                       OK
    mysql.proc                                         OK
    mysql.procs_priv                                   OK
    mysql.proxies_priv                                 OK
    mysql.servers                                      OK
    mysql.slow_log
    Error    : You can't use locks with log tables.
    status   : OK
    mysql.tables_priv                                  OK
    mysql.time_zone                                    OK
    mysql.time_zone_leap_second                        OK
    mysql.time_zone_name                               OK
    mysql.time_zone_transition                         OK
    mysql.time_zone_transition_type                    OK
    mysql.user                                         OK
    performance_schema.cond_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_current
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_history
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_history_long
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_by_instance
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_by_thread_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_global_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_summary_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_summary_by_instance
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.mutex_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.performance_timers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.rwlock_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_consumers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_instruments
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_timers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.threads
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    
    Repairing tables
    performance_schema.cond_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_current
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_history
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_history_long
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_by_instance
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_by_thread_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.events_waits_summary_global_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_summary_by_event_name
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.file_summary_by_instance
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.mutex_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.performance_timers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.rwlock_instances
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_consumers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_instruments
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.setup_timers
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    performance_schema.threads
    Error    : Unknown table engine 'PERFORMANCE_SCHEMA'
    error    : Corrupt
    Running 'mysql_fix_privilege_tables'...
    OK
    Starting service MySQL                                                                                                                     done

    So, knowing that the problem is in the update, tried again, but now first I uninstalled the version 5.1 (checking the "Clean up When deleting packages" option) before installing the 5.5 from the community repositories. Yast asked for install mariadb to resolve some conflicts.

    After I installed the 5.5 one, Yast asked to Uninstall mariadb and worked flawlessly:

    the "rcmysql" start returned:

    Code:
    rcmysql start
    Will update MySQL now, if you encounter any problems, please read following file:
            /usr/share/doc/packages/mysql-community-server/README.SuSE
    Running protected MySQL... 
    Upgrading MySQL... 
    Looking for 'mysql' as: /usr/bin/mysql
    Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck
    Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysql/mysql.sock' '--socket=/var/tmp/mysql-protected.rkkJfV/mysql.sock' 
    Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysql/mysql.sock' '--socket=/var/tmp/mysql-protected.rkkJfV/mysql.sock' 
    mysql.columns_priv                                 OK
    mysql.db                                           OK
    mysql.event                                        OK
    mysql.func                                         OK
    mysql.general_log                                  OK
    mysql.help_category                                OK
    mysql.help_keyword                                 OK
    mysql.help_relation                                OK
    mysql.help_topic                                   OK
    mysql.host                                         OK
    mysql.ndb_binlog_index                             OK
    mysql.plugin                                       OK
    mysql.proc                                         OK
    mysql.procs_priv                                   OK
    mysql.proxies_priv                                 OK
    mysql.servers                                      OK
    mysql.slow_log                                     OK
    mysql.tables_priv                                  OK
    mysql.time_zone                                    OK
    mysql.time_zone_leap_second                        OK
    mysql.time_zone_name                               OK
    mysql.time_zone_transition                         OK
    mysql.time_zone_transition_type                    OK
    mysql.user                                         OK
    Running 'mysql_fix_privilege_tables'...
    OK
    Starting service MySQL                                                                                                                     done

    Working OK.

    Thank you all for the help!

    Also uninstalling MySQL 5.5 and installing again MySQL 5.5 was by solution, thank you very much for your help.

  6. #6
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: Mysql error on openSUSE 11.4 x64

    FYI if you get the same error message again, YaST>System Services; scroll down to mysqld and select Enable, then OK.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •