Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Konqueror file associations

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Konqueror file associations

    I added the avi format to my konqueror video file associations. Then I tried to set kaffeine/KDE3 as the primary application instead of "enqueue in smplayer". It would not set. It would not remove. Even if I did it as root.

    Any suggestions?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Konqueror file associations

    Do you mean right click an .avi
    properties
    then the config/spanner icon
    then move up and down apps in the list?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: Konqueror file associations

    Quote Originally Posted by caf4926 View Post
    Do you mean right click an .avi
    properties
    then the config/spanner icon
    then move up and down apps in the list?
    That was quick!

    I mean konqueror > Settings > Configure konqueror > File management > File associations > Video > Avi (added by me) > Filename patterns (*.avi) > Application preference order...

    which lists...

    Enqueue in Smplayer
    Kaffeine/KDE3
    Vlc media player

    when I try to move Kaffeine/KDE3 up the list it doesn't, and when I try to delete Enqueue in Smplayer, it doesn't.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,163

    Default Re: Konqueror file associations

    Quote Originally Posted by ionmich View Post
    Even if I did it as root.

    Any suggestions?
    You can not do this as root. It is a setting of that particular user you are loged in as (and you will not be loged in as root).
    Henk van Velden

  5. #5
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: Konqueror file associations

    Quote Originally Posted by hcvv View Post
    You can not do this as root. It is a setting of that particular user you are loged in as (and you will not be loged in as root).
    Well I tried it both as user, and as root. I logged out as user and logged in as root. Neither worked.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,163

    Default Re: Konqueror file associations

    What I try to explain is:

    1) it is useless because it is a per user setting (in the users home directory somewhere in $HOME/.kde4); Thus as it works for root, it does not work for ionmich (or what username you use on your system) or for any other user you might have on the system; and if you manage (as we hope) to let it work as you want for ionmich, nothing changed for any other user on the system.

    2) of course that you NEVER SHOULD LOG IN AS ROOT.
    Henk van Velden

  7. #7
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: Konqueror file associations

    Quote Originally Posted by hcvv View Post
    What I try to explain is:

    1) it is useless because it is a per user setting (in the users home directory somewhere in $HOME/.kde4); Thus as it works for root, it does not work for ionmich (or what username you use on your system) or for any other user you might have on the system; and if you manage (as we hope) to let it work as you want for ionmich, nothing changed for any other user on the system.

    2) of course that you NEVER SHOULD LOG IN AS ROOT.
    Either I am misunderstanding you, or you are misunderstanding me, or possibly both.

    1. I logged in as ionmich and tried to change the Konqueror file association application for avi from "Enqueue in Smplayer" to "Kaffeine/KDE3" (as a matter of fact I tried to change it to "vlc" as well). It would not change and reverted to "Enqueue in Smplayer". I then logged out.

    2. I logged in as root and tried it again. Same result. I do understand that if it had changed when logged in as root, it would only apply when logged in as root. I was merely confirming that it was not a permission issue.

    3. I understand the danger involved when logged in as root HOWEVER there are situations when I want to test a script needing root privileges.

    The search to resolve this problem continues.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Konqueror file associations

    Either I am misunderstanding you, or you are misunderstanding me, or possibly both.
    It's a simple as this.
    @hcvv
    2) of course that you NEVER SHOULD LOG IN AS ROOT.
    You just said:
    2. I logged in as root and tried it again.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,163

    Default Re: Konqueror file associations

    In such cases (when you suspect it being some broken configuration of the user), one simply creates a new user (which is easy to delete after the test, leaving no traces).

    One NEVER LOGS IN AS ROOT. How would you undo everything that is done to your system (mainly in /root) doing this? It is near to impossible to revert to the status before you did log in as root into the GUI. That is apart from all the obvious, and for many people less obvious, dangers when being loged in as root.

    In any case, from my point of view I have stressed the stupidness of logging in as root in the GUI enough. Either you got the message or not.

    We better turn back to your original problem. Did you try caf4926's suggestion in post#2? And what about the Configuration item from the main menu and then the Advanced tab en then File Associations (as I have a non english KDE before me, the real english term might differ, but I hope you will find what I mean).
    Henk van Velden

  10. #10
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: Konqueror file associations

    Quote Originally Posted by hcvv View Post
    In such cases (when you suspect it being some broken configuration of the user), one simply creates a new user (which is easy to delete after the test, leaving no traces).

    We better turn back to your original problem. Did you try caf4926's suggestion in post#2? And what about the Configuration item from the main menu and then the Advanced tab en then File Associations (as I have a non english KDE before me, the real english term might differ, but I hope you will find what I mean).
    I will use your suggestion of creating a new user in future. It sounds quite logical.

    Yes I did try the other method. I went to Application Launcher Menu > Personal Settings (Configure Desktop) > Advanced > File Associations > Video > Avi and tried to change the application order. It did not change.

    Going back to the original problem is now going to be difficult. In the process of trying to resolve a different problem (that of "sparklies" in some video players) I ended up re-installing the O.S. This time I only installed kaffeine, so it is the only application in the file associations. That solves my problem for the time being. I will check again later and report my progress.

    Thanks for the ongoing help.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •