Results 1 to 10 of 10

Thread: USB headphones max volume too low

  1. #1

    Default USB headphones max volume too low

    I'm trying to use Logitech USB headphones with KDE4 OpenSUSE 11.4 on my laptop computer. They work perfectly on Windows 7 and on my friend's Ubuntu with Gnome. After plugging in the headphones, I went to YaST sound module and configured them with automatic configuration.

    Next, I switched the primary output to headphones in KMix and muted the internal audio just in case. The output is correctly directed to the headphones but the volume is too low. It is at maximum in KMix but it is still too low to listen to anything.

    Using the buttons on the headphones displays the volume gauge on the screen but it doesn't do anything. I've taken a look at the Phonon configuration GUI and it doesn't offer any useful options except that playing the test sounds on headphones confirms that the volume is too low.

    Please help. I'm not eager to use command line tools for sound in OpenSUSE, but I'll try if it's the only way. I'm not even sure how exactly the whole driver/OSS/ALSA/PulseAudio/Phonon/KMix hierarchy works. I once ran alsaconfig on my desktop OpenSUSE 11.x and it absolutely destroyed my sound settings.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: USB headphones max volume too low

    Did you try installing the pulse audio volume control 'pavucontrol' and then run 'pavucontrol' when using your USB headphones (run it at least once) to tune your volume levels?

    Alternatively you could learn some command line, and with your USB headphones plugged in and configured as best you can, provide output of running the diagnostic script in a terminal window (with pc connected to internet and select SHARE/UPLOAD option):
    Code:
    /usr/sbin/alsa-info.sh
    and post here the web-address/URL it provides so we can get a more detailed look at your PC's audio configuration. DO NOT clutter this thread with all its output. Just the address.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: USB headphones max volume too low

    Quote Originally Posted by Nameless_One View Post
    I once ran alsaconfig on my desktop OpenSUSE 11.x and it absolutely destroyed my sound settings.
    I'm not surprised. Alsaconf has been depreciated for some time and no longer works on openSUSE since a number of versions. Running it is a very bad idea.

  4. #4

    Default Re: USB headphones max volume too low

    Quote Originally Posted by oldcpu View Post
    I'm not surprised. Alsaconf has been depreciated for some time and no longer works on openSUSE since a number of versions. Running it is a very bad idea.
    Yeah, I guessed as much...but only after I ran alsaconf

  5. #5

    Default Re: USB headphones max volume too low

    I have installed pavucontrol. The problem is that the system simply refused to direct the output to the headphones today. I do the same thing as yesterday: Right-click KMix in the systray and select Select Master Channel. Then I change the master channel to the headphones but the output is still directed to the internal sound card. Phonon configuration still manages to play test sounds in low volume on the headphones, but system sounds and all other sounds from applications such as Amarok and VLC are sent to the internal card.

    When first running pavucontrol, it crashed when I tried to change the volume of headphones. I didn't see the error message so I ran it again. This time, changing the volume of headphones worked and the output is correctly directed to headphones. The volume, however, is still too low, even though I set it to 100% in pavucontrol.

    Here's my alsa-info output: http://www.alsa-project.org/db/?f=86...cdd74ae34d1916

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: USB headphones max volume too low

    Quote Originally Posted by Nameless_One View Post
    According to that script, the volume for your USB headphones is only set at 45% (and not 100%). ???

    Code:
    !!Amixer output
    !!-------------
    
    !!-------Mixer controls for card 0 [Headset]
    
    Card hw:0 'Headset'/'Logitech Logitech USB Headset at usb-0000:00:12.0-2, full speed'
      Mixer name	: 'USB Mixer'
    Simple mixer control 'Speaker',0
      Front Left: Playback 20 [45%] [-21.00dB] [on]
      Front Right: Playback 20 [45%] [-21.00dB] [on]
    Simple mixer control 'Mic',0
      Mono: Playback 0 [0%] [-41.00dB] [on] Capture 13 [100%] [29.00dB] [on]

  7. #7

    Default Re: USB headphones max volume too low

    Thanks for looking at my problem. It seems KMix is not working well. Selecting a sound device as primary in it either doesn't do anything or other applications don't respect the changes KMix makes. One nice thing I found out is that I have all applications with audio output listed in pavucontrol's Playback tab so I can control which sound device they send the output to as well as their volume. It still doesn't help with 45% volume, though. While VLC is running, I set its volume to 100% and direct it to the headset but the volume is still quite low. When I run alsa-info script it still reports 45% volume.

    The sound becomes inaudible at around 40% volume in pavucontrol. The problem with alsa-info script is that it shows 45% whatever volume I set in pavucontrol, KMix or VLC. My conclusion is that alsa-info is either reporting a setting value that is ignored by PulseAudio or, more likely, that it is a volume setting that is applied to audio output before the PulseAudio setting is applied. If the latter is the problem, how do I change this setting?

  8. #8

    Default Re: USB headphones max volume too low

    I've played with alsa some more. Played with amixer directly. When I run it on my own for the headset, it reports 100% volume. I also discovered alsamixer. amixer correctly reports the volume setting I set in alsamixer, but for alsa-info it always reports 45% volume. I'd call this quite chaotic.

  9. #9

    Default Re: USB headphones max volume too low

    I went on a rampage and started all the volume controls while playing a video in VLC. I set VLC to the max first, then alsamixer, then KMix. Finally, when I opened pavucontrol, it was reporting 41% volume. I quickly grasped the opportunity to set it to 100% like a hungry child grasping a cookie and I finally managed to get a loud, ear-piercing sound that is audible even while not wearing the headset.

    Thanks for all the help. I would even have tried pavucontrol and alsamixer without your suggestions. I still don't know what is happening and I hope I can get the audio to work as intended at all times, but this is definitely a great progress.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: USB headphones max volume too low

    Quote Originally Posted by Nameless_One View Post
    ... finally managed to get a loud, ear-piercing sound that is audible even while not wearing the headset.
    Congratulations on getting this far.

    Maybe make a screen print of your settings in the various applications/mixers, so that things can be restored again if settings lost.

    And then hopefully figure out the cause and effect of this.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •