Results 1 to 9 of 9

Thread: Sonderzeichen-Darstellung im Forum fehlerhaft ...

  1. #1

    Default Sonderzeichen-Darstellung im Forum fehlerhaft ...

    Was macht es in diesem Forum - denke jetzt in erster Linie an das deutsche Teilforum - so schwer die Sonderzeichen (ÄÖÜäöüß) ordentlich darzustellen?

    Es erschwert in vielen Beiträgen die Lesbarkeit und man muss ständig im Browser die Zeichenkodierung wechseln (bei mir standardmäßig Unicode [UTF-8]).

    Gruß
    Feuerdrache
    Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.
    Clifford Stoll

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Sonderzeichen-Darstellung im Forum fehlerhaft ...

    * Feuerdrache,

    Benutzerkontrollzentrum, links auf "Mein Benutzerkonto", "Einstellungen ändern", gaaaanz unten kannst Du die Sprache auswählen. Nimm mal was mit UTF8. Besser?

    Gruß
    Uwe

  3. #3
    Join Date
    Nov 2009
    Location
    Sulzbach/Ts., Germany
    Posts
    399

    Default AW: Re: Sonderzeichen-Darstellung im Forum fehlerhaft ...

    Das Blöde ist aber, dass je nach Einstellung die Umlaute falsch sind. Habe ich Deutsch [UTF-8] eingestellt, sehe ich Feuerdrachens Umlaute falsch, Uwe's aber richtig.

  4. #4
    Join Date
    Nov 2009
    Location
    Sulzbach/Ts., Germany
    Posts
    399

    Default AW: Re: Sonderzeichen-Darstellung im Forum fehlerhaft ...

    Jetzt, bei Deutsch (old encoding) sehe ich das genau andersrum.
    Das zieht sich durch's ganze Forum. Je nachdem wer welchen Zeichensatz eingestellt hat, wird dessen Formatierung gespeichert und nur dann richtig dargestellt, wenn man selbst die entsprechende Einstellung hat.
    Sprich: User mit UTF-8 sehen old-encoding falsch und andersrum (also sollte jeder einen meiner beiden Beiträge mit falschen Umlauten sehen).
    Nixgut!

  5. #5

    Default AW: Re: Sonderzeichen-Darstellung im Forum fehlerhaft ...

    Kann lOtz1009 nur bestätigen. Und hinzu kommt:

    Hat beispielsweise das Betreff eine Zeile mit Umlauten oder Sonderzeichen und der Text ebenfalls, dann kann es passieren, dass ich bei Wechsel des Zeichensatzes im Betreff die Sonderzeichen danach lesbar sind und dann aber im Text durch irgendwelche andere Zeichenkombinationen mit Kauderwelsch ersetzt werden.

    Deutsches Teilforum "Forum: Ankündigungen und Neues" [Aussehen bei Westlich (ISO-8859-1)]. Dort in den Faden "Thema: Deutschsprachiges Forum ist jetzt auch über NNTP erreichbar". Wechsle ich jetzt auf UTF-8, dann wird der Fadentitel korrekt als "Thema: Deutschsprachiges Forum ist jetzt auch über NNTP erreichbar" dargestellt, aber das Wort "Beiträge:" in den Fadenbeiträgen jetzt so "Beitr�ge:".

    Also in der Fadenüberschrift ein Zeichensatz, auf der Beitragsebene ein weiterer Zeichensatz. Man jongliert also permanent zwischen UTF-8, Westlich (ISO-8859-1) und gegebenenfalls Westlich (ISO-8859-1).

    Dies lässt sich auch auf der Hauptebene des Forums feststellen. Betrachtet zum Beispiel mal das Teilforum Griechisch oder Russisch:

    Mit Westlich (ISO-8859-1) irgendein Kauderwelsch mit UTF-8 in Ordnung.

    Sorry! Alles in allem: das ist "Mist"!

    Gruß
    Feuerdrache
    Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.
    Clifford Stoll

  6. #6

    Default AW: Re: Sonderzeichen-Darstellung im Forum fehlerhaft ...

    Ich fasse da noch einmal nach:

    Besteht eine Chance, dass diese Darstellungsfehler auch mal behoben werden oder müssen wir weiterhin mit diesem Zustand leben?

    Gruß
    Feuerdrache
    Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.
    Clifford Stoll

  7. #7
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    507

    Default AW: Re: Sonderzeichen-Darstellung im Forum fehlerhaft ...

    Nein, der Zustand wird nicht behoben, aber er wird sich mit der Zeit bessern.

    Das Problem entstand, wie gesagt, durch den Umstieg von ISO-8859-1 auf UTF-8. Alte Beiträge werden zwar nicht nach UTF-8 kodiert, aber alle neuen sollten in UTF-8 verfasst werden. Da alte Beiträge später kaum noch interessieren, werden hoffentlich bald alle aktiven Themen in UTF-8 sein und ISO-8859-1 wird aussterben.

    Soweit ich sehe, hast du noch ISO-8859-1 eingestellt. Also am besten auf UTF-8 umstellen und in den alten Beiträge die Umlaute raten.
    - openSuse 12.1 3.1.0-1.2-desktop x86_64 KDE: 4.7.4 (4.7.4) "release 11"

    Murphy's Law is recursive. Washing your car to make it rain doesn't work.

  8. #8

    Default AW: Re: Sonderzeichen-Darstellung im Forum fehlerhaft ...

    Quote Originally Posted by Fruchtratte View Post
    Nein, der Zustand wird nicht behoben, aber er wird sich mit der Zeit bessern.

    Das Problem entstand, wie gesagt, durch den Umstieg von ISO-8859-1 auf UTF-8. Alte Beiträge werden zwar nicht nach UTF-8 kodiert, aber alle neuen sollten in UTF-8 verfasst werden. Da alte Beiträge später kaum noch interessieren, werden hoffentlich bald alle aktiven Themen in UTF-8 sein und ISO-8859-1 wird aussterben.

    Soweit ich sehe, hast du noch ISO-8859-1 eingestellt. Also am besten auf UTF-8 umstellen und in den alten Beiträge die Umlaute raten.
    Umgeschaltet auf UTF-8 - Achte einmal auf Deine Userbezeichnung rechts:

    Wechsle ich jetzt auf UTF-8, dann wird das Wort "Beiträge:" jetzt "Beitr�ge:".

    Wird das wenigstens verbessert? Oder ist auch dieses Phänomen nur auf die "alten Beiträge" beschränkt?

    Gruß
    Feuerdrache
    Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.
    Clifford Stoll

  9. #9
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    507

    Default Re: Sonderzeichen-Darstellung im Forum fehlerhaft ...

    Das Problem ist auf alle alten Beiträge und die neuen, die noch mit "old
    encoding" geschrieben werden, beschränkt. Deswegen werde alle gebeten, die
    neue Einstellung zu verwenden.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •