Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Unable to Capture Audio from Mic

  1. #1
    Join Date
    Feb 2010
    Location
    Cloud Nine
    Posts
    14

    Default Unable to Capture Audio from Mic

    I recently installed openSUSE 11.4-64bit on my Gateway desktop, and I can't seem to get my mic work at all. The mic is built into my Microsoft LifeCam Cinema webcam and works fine when I boot into Windows. The mic will not record sound in krecord or lame and doesn't work during Skype sessions.

    According to the literature for the device driver my the mic should be supported, and that is evidenced by the fact that the mic shows up as a capture device in in kmix. I have made this mic the master channel under capture devices and I have given it highest preference amongst my capture devices in both the Communications and Accessibility categories of kmix's Settings/Audio Setup.

    There was a very similar case solved in January:

    How I got my Sound Input working (Thanks to Oldcpu)!

    I've done my best to implement these fixes, but half of it looks like gibberish to me. All I was really able to do was update my alsa software and generate this comprehensive alsa.conf (its long, so I'll wait to post it until asked).

    This is the first problem I've had since updating to 11.4, and I gotta say: I've been really impressed so far. Any help here would be much appreciated.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Unable to Capture Audio from Mic

    Quote Originally Posted by drucifer View Post
    I recently installed openSUSE 11.4-64bit on my Gateway desktop, and I can't seem to get my mic work at all. The mic is built into my Microsoft LifeCam Cinema webcam and works fine when I boot into Windows. The mic will not record sound in krecord or lame and doesn't work during Skype sessions.
    I recommend when testing for basic mic functionality that one does NOT use krecord nor lame nor Skype, but instead use 'arecord'. A simple 'arecord' command is:
    Code:
    arecord -vv -f cd test.wav
    and dependent on the EXACT mic one tends to use there are more complex implementations of the command.

    Quote Originally Posted by drucifer View Post
    I've done my best to implement these fixes, but half of it looks like gibberish to me.
    Gibberish ? Gibberish? Have you been seeing my wife and are just restating her views ? You MUST have been spending time with my wife !! ... lol .... ... On a more serious note, could you explain where this turns to gibberish ?

    Quote Originally Posted by drucifer View Post
    All I was really able to do was update my alsa software and generate this comprehensive alsa.conf (its long, so I'll wait to post it until asked).
    My 2nd advice (after recommending you use 'arecord' for testing) is never never never never, in openSUSE, edit your PC's alsa.conf. Please RESTORE it back to its original default settings. I likely can NOT help if your alsa.conf is anything but nominal.

    Having typed the above, I really need more information from you (and alsa.conf is NOT what I need - it MUST go back to default). Our multimedia stickie has a quote that provides EXACTLY what I need: Welcome to multimedia sub-area and I'll quote the salient section from that stickie for you :



    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script
      Code:
      /usr/sbin/alsa-info.sh
      and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
      .
      Note if for some reason that gives you no website/url/address then run it with the no-upload option:
      Code:
      /usr/sbin/alsa-info.sh --no-upload
      and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.


    .
    ... some clarification on running the script "alsa-info.sh" ... when you run:
    Code:
    /usr/sbin/alsa-info.sh
    you should get something like this (if it asks for an update, select NO):


    followed by this (select the SHARE/UPLOAD option):


    followed by this (its quickest if you simply select 'NO' to seeing the output - you will see it on the web page) :


    followed by this (where in RED is the URL).


    Just post the URL you get (similar to the RED URL in my example, but yours will be different).

    Again, if you can not get that, then run this with the no upload option:
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    which will create the file /tmp/alsa-info.txt. Copy that file and paste it on Pastebin.com and press submit. That will give you a URL address. Please post that URL here.


    Also provide the following:

    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
    • ....
    • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here


  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Unable to Capture Audio from Mic

    I should add that many of us find in openSUSE-11.4 that installing the application 'pavucontrol' and then running 'pavucontrol' when trying to record, gives us excellent control over our record devices and their interfacing to different record applications. For example in this thread http://forums.opensuse.org/forums/en...lse-audio.html (see post#4 and #5) I tried something a bit more complex than what you are attempting to do. Still, I think the illustration of the 'pavucontrol' tabs might be enlightening.

  4. #4
    Join Date
    Feb 2010
    Location
    Cloud Nine
    Posts
    14

    Default Re: Unable to Capture Audio from Mic

    I recommend when testing for basic mic functionality that one does NOT use krecord nor lame nor Skype, but instead use 'arecord'.
    So, tried arecord and experienced more of the same--if only it'd had been that easy

    Gibberish ? Gibberish? Have you been seeing my wife and are just restating her views ?...On a more serious note, could you explain where this turns to gibberish ?
    I can't say we've met, but she sounds like an insightful lady . As for the exact point that I stop understanding whats really going on, its when he starts manipulating .conf files -- I really have no clue what goes on in those files (see the line where he says "I was asked to post the /etc/modprobe.d/50-sound.conf " and everything below it).

    never never never never, in openSUSE, edit your PC's alsa.conf
    Worry not--I didn't edit it; I just opened it using /usr/sbin/alsa-info.sh and then closed it...very carefully.

    As for all of the information asked in the sticky, here it goes:

    -The result of my foray into /usr/sbin/alsa-info.sh: http://www.alsa-project.org/db/?f=9c...2e9e794f5869ac

    -rpm -qa '*alsa*':

    Code:
    drucifer@Iggy:~/Desktop> rpm -qa '*alsa*'
    alsa-plugins-pulse-32bit-1.0.24-39.2.x86_64
    alsa-plugins-1.0.24-39.2.x86_64
    alsa-plugins-32bit-1.0.24-39.2.x86_64
    alsa-oss-1.0.17-59.1.x86_64
    alsa-oss-32bit-1.0.17-59.1.x86_64
    alsa-utils-1.0.24.2-37.1.x86_64
    alsa-driver-kmp-desktop-1.0.24.20110604_k2.6.37.6_0.5-1.1.x86_64
    alsa-1.0.24.1-90.1.x86_64
    alsa-plugins-pulse-1.0.24-39.2.x86_64
    -rpm -qa '*pulse*':

    Code:
    drucifer@Iggy:~/Desktop> rpm -qa '*pulse*'
    pulseaudio-module-jack-0.9.22-6.11.1.x86_64
    alsa-plugins-pulse-32bit-1.0.24-39.2.x86_64
    pulseaudio-esound-compat-0.9.22-6.11.1.x86_64
    pulseaudio-utils-0.9.22-6.11.1.x86_64
    libpulse-mainloop-glib0-0.9.22-6.11.1.x86_64
    libpulse0-0.9.22-6.11.1.x86_64
    pulseaudio-0.9.22-6.11.1.x86_64
    pulseaudio-module-lirc-0.9.22-6.11.1.x86_64
    libxine1-pulse-1.1.19-4.4.x86_64
    libpulse0-32bit-0.9.22-6.11.1.x86_64
    libpulse-browse0-0.9.22-6.11.1.x86_64
    pulseaudio-module-zeroconf-0.9.22-6.11.1.x86_64
    pulseaudio-module-x11-0.9.22-6.11.1.x86_64
    pulseaudio-module-bluetooth-0.9.22-6.11.1.x86_64
    alsa-plugins-pulse-1.0.24-39.2.x86_64
    -rpm -q libasound2:

    Code:
    drucifer@Iggy:~/Desktop> rpm -q libasound2
    libasound2-1.0.24.1-90.1.x86_64
    -uname -a:uname -a

    Code:
    drucifer@Iggy:~/Desktop> uname -a
    Linux Iggy 2.6.37.6-0.5-desktop #1 SMP PREEMPT 2011-04-25 21:48:33 +0200 x86_64 x86_64 x86_64 GNU/Linux
    -cat /etc/modprobe.d/50-sound.conf:

    Code:
    drucifer@Iggy:~/Desktop> cat /etc/modprobe.d/50-sound.conf
    
    options snd slots=snd-hda-intel,snd-hda-intel
    # 5Dex.k0B2MK7tdx7:SBx00 Azalia (Intel HDA)
    alias snd-card-0 snd-hda-intel
    # l4dC.5wGb4atkBr4:RS780 Azalia controller
    alias snd-card-1 snd-hda-intel
    I also went and installed pavucontrol. I'm looking through that right now.

  5. #5
    Join Date
    Feb 2010
    Location
    Cloud Nine
    Posts
    14

    Default Re: Unable to Capture Audio from Mic

    Quick update: in pavucontrol, under the Input Devices tab, the microphone responds to sounds in the room (e.g. me snapping my fingers), so it looks like somewhere in the computer the mic is feeding in sound.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Unable to Capture Audio from Mic

    Quote Originally Posted by drucifer View Post
    -The result of my foray into /usr/sbin/alsa-info.sh: http://www.alsa-project.org/db/?f=9c...2e9e794f5869ac
    Ok , thanks.

    I note a 64-bit openSUSE-11.4 with the 2.6.37.6-0.5-desktop kernel running on your Gateway DX4300 (P01-A1) which has an ALC1200 hardware audio codec. I see you have updated your alsa driver version to the latest version on the openSUSE multimedia site (packaged by the SuSE-GmbH sound packager, who is also an alsa sound driver developer).

    I note this from your script:
    Code:
    ARECORD
    
    **** List of CAPTURE Hardware Devices ****
    card 0: SB [HDA ATI SB], device 0: ALC1200 Analog [ALC1200 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 2: ALC1200 Analog [ALC1200 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 2: CinemaTM [Microsoft® LifeCam Cinema(TM)], device 0: USB Audio [USB Audio]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    which shows two mic controls: Card-0 on your motherboard: (hw:0,0) and one (card-2) appears to be a Microsoft webcam (hw:2,0).

    Your webcam mic appears setup to record:
    Code:
    Card hw:2 'CinemaTM'/'Microsoft Microsoft® LifeCam Cinema(TM) at usb-0000:00:12.2-3, high speed'
      Mixer name    : 'USB Mixer'
    Simple mixer control 'Mic',0
      Mono: Capture 49 [88%] [on]
    Your Front Mic main capture however is muted such there can be no recording (capture OFF at 0% capture with 0% boost). You have source 0 (capture 0) assigned to that muted Front mic.

    Source-1 (capture-1) is assigned to Rear Mic and it is also muted.
    Code:
    !!Amixer output
    !!-------------
    
    !!-------Mixer controls for card 0 [SB]
    
    Card hw:0 'SB'/'HDA ATI SB at 0xfe7f4000 irq 16'
      Mixer name    : 'Realtek ALC1200'
    Simple mixer control 'Front Mic',0
      Front Left: Playback 0 [0%] [-34.50dB] [off]
      Front Right: Playback 0 [0%] [-34.50dB] [off]
    Simple mixer control 'Front Mic Boost',0
      Front Left: 0 [0%] [0.00dB]
      Front Right: 0 [0%] [0.00dB]
    Simple mixer control 'Capture',0
      Front Left: Capture 17 [55%] [9.00dB] [on]
      Front Right: Capture 17 [55%] [9.00dB] [on]
    Simple mixer control 'Capture',1
      Front Left: Capture 0 [0%] [-16.50dB] [on]
      Front Right: Capture 0 [0%] [-16.50dB] [on]
    Simple mixer control 'Input Source',0
      Items: 'Rear Mic' 'Front Mic' 'Line'
      Item0: 'Front Mic'
    Simple mixer control 'Input Source',1
      Items: 'Rear Mic' 'Front Mic' 'Line'
      Item0: 'Rear Mic'
    Simple mixer control 'Rear Mic',0
      Front Left: Playback 0 [0%] [-34.50dB] [off]
      Front Right: Playback 0 [0%] [-34.50dB] [off]
    Simple mixer control 'Rear Mic Boost',0
      Front Left: 0 [0%] [0.00dB]
      Front Right: 0 [0%] [0.00dB]
    Now if you were only to move up your boost and move up your capture levels and change OFF to ON, you should be able to record from front (or rear) mic with:
    Code:
    arecord -D hw:0,0 -vv -f cd test.wav
    or
    Code:
    arecord -D hw:0,1 -vv -f cd test.wav
    and with your webcam mic with
    Code:
    arecord -D hw:2,0 -vv -f cd test.wav
    Using pavucontrol while running the more generic arecord command
    Code:
    arecord -vv -f cd test.wav
    is a good idea. Ensure in "input device" and also "recording" that you do NOT inappropriate filter the display but SHOW as much information as possible so as to see the sound being captured. The 'arecord' should show up as an alsa application.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Unable to Capture Audio from Mic

    Quote Originally Posted by drucifer View Post
    Quick update: in pavucontrol, under the Input Devices tab, the microphone responds to sounds in the room (e.g. me snapping my fingers), so it looks like somewhere in the computer the mic is feeding in sound.
    Excellent. Now just direct the mic stream to the record application with pavucontrol !

    I have some rather complex examples here: Looking (maybe) for audio mixer for use with Pulse Audio (see posts #4 and #5). Of course I'm adding a bunch of things you don't need to do.

  8. #8
    Join Date
    Feb 2010
    Location
    Cloud Nine
    Posts
    14

    Default Re: Unable to Capture Audio from Mic

    So, I think at least one of the problems here is that i don't have a record application under the Recording tab in pavucontrol...







    From what I can tell, those applications were already sitting there in your examples above.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Unable to Capture Audio from Mic

    Quote Originally Posted by drucifer View Post
    So, I think at least one of the problems here is that i don't have a record application under the Recording tab in pavucontrol...
    No that is typical when no recording application is running.

    When you run the arecord command, then the stream will show up as an alsa streaming application. Did you try that ?
    Code:
    arecord -vv -f cd test.wav
    and if that fails try:
    Code:
    arecord -D hw:0,0 -vv -f cd test.wav
    or if that fails try:
    Code:
    arecord -D hw:0,1 -vv -f cd test.wav
    or if that fails try with your webcam mic with
    Code:
    arecord -D hw:2,0 -vv -f cd test.wav
    Its also possible "analog stereo duplex" (under configuration) is not the correct setting.

  10. #10
    Join Date
    Feb 2010
    Location
    Cloud Nine
    Posts
    14

    Default Re: Unable to Capture Audio from Mic

    Success! I've now made the mic stream my default recording stream by recording while adjusting the settings in pavurecord, and everything--recording sound with arecord, lame and krecord as well as my skype audio--seems to be working. Thanks for your patience and your awesome know-how, oldcpu!

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •