Results 1 to 6 of 6

Thread: Hard disk permissions issue

  1. #1

    Default Hard disk permissions issue

    I've got two hard drives in my computer, one is an older drive which has windows XP on it, and the other new WD 1TB drive which is split into a few partitions, one of which is NTFS and has all my files on it, and then the remaining partitions are for suse 11.4

    My problem is, when I login to suse as anything other than root, I don't have write priveliges on the NTFS partition on the WD. I have read access to the partition, and don't have issues opening files, but I don't have write access for some reason. When I login as root, I can write to the partition just fine. When I'm logged in as root and try to change the permissions, either by changing the group permissions to include write, or changing the owner to the "users" group, nothing happens. The computer acts like it's making the changes, but when I go back and look at it, the permissions haven't changed.

    Any help would be greatly appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: Hard disk permissions issue

    First, trying to change permissions on an NTFS file system is useless. There aren't such permissions on it. They are faked by the software that makes it possible to use these type of file sytems.

    Second, do not log in as root. I understand that you want to try to write to this file system as root, but do not log in as root. Become root for the test with sudo or su - or one of the other ways described in SDB:Login as root - openSUSE.

    Third, what is the entry for that file system in /etc/fstab? The the file system type there should be ntfs-3g and the options field there should be defaults. Change it when not and try again (after umount/mount or reboot).
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Hard disk permissions issue

    FSTAB - Editing Manually

    It may be there is an entry in fstab for windows already and you just need to edit it
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Hard disk permissions issue

    On 06/05/2011 08:06 AM, naskie18 wrote:
    >
    > My problem is, when I login to suse as anything other than root


    sorry, i do not know much about ntfs so i'll let someone with more
    Windows experience help you there...

    but, please do not log into Gnome or KDE as root....yes, i know that is
    the way it is done on Windows, but this is not that..

    you should never log into KDE/Gnome/XFCE or any other *nix-like system's
    graphical user interface desktop environment as root..

    doing so 1) opens you up to several different security problems if you
    (for example) browse the net, 2) too many too easy ways to damage your
    system no matter how careful your actions (for example: well documented
    cases of unintended change of ownership of ~/.ICEauthority and
    ~/.Xauthority from user to root sometimes occurs), 3) anyway logging
    into KDE/etc as root is *never* required to do any and all
    administrative duties, 4) and, not even logging in as root just to see
    if it works as root is useful, because the "yes" or "no" learned is
    almost always totally useless in finding the problem giving the
    symptoms. however, logging in as root to learn the yes/no could the
    cause of the next adverse symptom encountered.

    so, always log in as yourself, and "become root" by using a root powered
    application (like YaST, File Manager Superuser Mode) or using "su -",
    sudo, kdesu, or gnomesu in a terminal to launch whatever tool is needed
    (like Kwrite to edit a config file)...read more on all that here:

    http://en.opensuse.org/SDB:Login_as_root
    http://tinyurl.com/ydbwssh
    http://forums.opensuse.org/showthread.php?t=446115
    http://tinyurl.com/4nsaqst
    http://tinyurl.com/6ry6yd
    http://tinyurl.com/DD-on-Root

    additionally: after logging into KDE/Gnome/etc as root, if you
    experience problems (for example, with uncommanded file ownership and
    permissions changes) and if you can provide us with details of what you
    were doing while you were logged in as root, that would help us identify
    if there's a bug that needs to be fixed...thanks for your help..


    > When I'm logged in as root and try to
    > change the permissions, either by changing the group permissions to
    > include write, or changing the owner to the "users" group, nothing
    > happens. The computer acts like it's making the changes, but when I go
    > back and look at it, the permissions haven't changed.


    the reason for that is (i think) that NTFS has no way to store the
    permissions information you are giving it from Linux...so, you tell to
    change and it FAILS to do so, without giving an error...it is like it
    never sees the command (i guess because it doesn't know what to do with
    a "change user group to ______" because it has NO user group in its file
    system..

    my policy is to NOT write to Windows from Linux, nor from Windows to
    Linux....well, the latter is impossible as Windows refuses to even see
    linux file systems--thank you Mr. Bill!!

    --
    dd CAVEAT: http://is.gd/bpoMD
    via NNTP openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10
    Acer Aspire One D255, 1.66 GHz Atom, 1 GB RAM, Intel Pineview graphics
    * When your gecko is broken you have a reptile dysfunction! *

  5. #5

    Default Re: Hard disk permissions issue

    Thanks guys, changing the options field in fstab got it sorted out

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: Hard disk permissions issue

    You arre welcome. And thanks for reporting back.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •