Results 1 to 5 of 5

Thread: HP Printer not working

  1. #1

    Default HP Printer not working

    Suse 11.4 64bit
    amd6000
    gigabyte motherboard
    4 GB
    HP psc 1200 series printer


    I try to print a page and nothing happens(after 10 mins+). The HP tray icon->printer control says it's pending. Also, I have the hardware system info file. How do I fix it? Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: HP Printer not working

    How did you configure it? If via YaST or CUPS web interface, then delete the configuration and start over.

    From a terminal window, become root with
    Code:
    su -
    and enter your root password when prompted. Then type
    Code:
    hp-setup
    Follow the prompts given...

    Does this command now produce a test page ok?
    Code:
    hp-testpage

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: HP Printer not working

    This may happen after there has been a fault in the connection with the printer. CUPS stops the printer and you have to open CUPS, select printers and then, I think, Administration and Resume printer. You will be asked for a password - give your root password.

  4. #4

    Default Re: HP Printer not working

    Quote Originally Posted by john_hudson View Post
    This may happen after there has been a fault in the connection with the printer. CUPS stops the printer and you have to open CUPS, select printers and then, I think, Administration and Resume printer. You will be asked for a password - give your root password.
    I entered the terminal data. It printed the test page, but not from firefox. I went into yast->printer. I found three printer configs, one said disabled. I deleted all the printer configs. I did "add printer". That didn't work. Again, I deleted all printer configs from yast->printer. I entered the terminal data. Now, the printer is working fine from firefox. Thanks.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: HP Printer not working

    Again, I deleted all printer configs from yast->printer. I entered the terminal data. Now, the printer is working fine from firefox. Thanks.
    Yes, the 'hp-setup' utility is an essential part of the configuration. Glad you got it working.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •