Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: hp mini 110-3000 mic not working

  1. #1

    Default hp mini 110-3000 mic not working

    Ok, so I am complete newbie when it comes to linux. I've managed to install openSuse 11.4, and have also managed to get the sound working properly, but the mic doesn't seem to be working. Could any one help me with this ?

    My system is a hp mini 110 3000 netbook which came pre installed with windows 7. I'd install ubuntu on this before switching to openSuse, and in ubuntu the mic was working.

    Also, I can't get bluetooth and the sd card reader working. I've got the ath9k driver installed, and WLAN works perfectly on that, but bluetooth doesn't.

    I'd appreciated if some would help me solve these issues.

    Cheers
    hdtown
    Last edited by hdtown; 04-Jun-2011 at 14:14. Reason: sleepy :P

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: hp mini 110-3000 mic not working

    Quote Originally Posted by hdtown View Post
    Ok, so I am complete newbie when it comes to linux. I've managed to install openSuse 11.4, and have also managed to get the sound working properly, but the mic doesn't seem to be working. Could any one help me with this ?

    My system is a hp mini 110 3000 netbook which came pre installed with windows 7. I'd install ubuntu on this before switching to openSuse, and in ubuntu the mic was working.
    I recommend you install the application 'pavucontrol' and then run 'pavucontrol' and use it to configure your input audio device and your recording.

    When testing your mic, I recommend you run as a regular user from a terminal the following command:
    Code:
    arecord -vv -f cd test.wav
    and record for 30 seconds or so, check the pavucontrol controls for the recording (it should be known as 'alsa' application for recording), and abort the recording by pressing <CTRL><C> in the terminal and then play back test.wav in a media player to see if the recording was successful.

    If that does not work, then I need more information (per the multimedia stickie) to understand better the hardware and software configuration on your HP Mini 110 3000 netbook: Welcome to multimedia sub-area and I'll quote the relevant section from that:


    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script
      Code:
      /usr/sbin/alsa-info.sh
      and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
      .
      Note if for some reason that gives you no website/url/address then run it with the no-upload option:
      Code:
      /usr/sbin/alsa-info.sh --no-upload
      and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.


    .
    ... some clarification on running the script "alsa-info.sh" ... when you run:
    Code:
    /usr/sbin/alsa-info.sh
    you should get something like this (if it asks for an update, select NO):


    followed by this (select the SHARE/UPLOAD option):


    followed by this (its quickest if you simply select 'NO' to seeing the output - you will see it on the web page) :


    followed by this (where in RED is the URL).


    Just post the URL you get (similar to the RED URL in my example, but yours will be different).

    Again, if you can not get that, then run this with the no upload option:
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    which will create the file /tmp/alsa-info.txt. Copy that file and paste it on Pastebin.com and press submit. That will give you a URL address. Please post that URL here.


    Also provide the following:

    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
    • ...
    • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

    Quote Originally Posted by hdtown View Post
    Also, I can't get bluetooth and the sd card reader working. I've got the ath9k driver installed, and WLAN works perfectly on that, but bluetooth doesn't.
    Please start separate new threads for your bluetooth and sd card reader problems.

  3. #3

    Default Re: hp mini 110-3000 mic not working

    Ok, so I installed pavucontrol, but when I tried recording, the pavucontrol program wasn't able to pick up any sound, but when I play music, the pavucontrol input shows that it is receiving sound, but when I speak something (using the command you wrote down earlier), though pavucontrol lists the application that is recording sound as 'ALSA', it doesn't seem to pick up any sound at all. In the terminal too, the last line stays at 00 % .

    Here is my alsa log :

    http://www.alsa-project.org/db/?f=5f...d990c82b53ce60

    linux-nnhp:~> sudo rpm -qa '*alsa*'
    root's password:
    alsa-plugins-pulse-1.0.24-6.1.i586
    alsa-firmware-1.0.24.1-3.1.noarch
    alsa-1.0.24.1-3.1.i586
    alsa-plugins-1.0.24-6.1.i586
    alsa-oss-1.0.17-32.1.i586
    alsa-utils-1.0.24.2-3.1.i586
    linux-nnhp:~> sudo rpm -qa '*pulse*'
    libpulse-browse0-0.9.22-6.9.1.i586
    pulseaudio-module-zeroconf-0.9.22-6.9.1.i586
    pulseaudio-module-x11-0.9.22-6.9.1.i586
    alsa-plugins-pulse-1.0.24-6.1.i586
    pulseaudio-0.9.22-6.9.1.i586
    pulseaudio-module-jack-0.9.22-6.9.1.i586
    libpulse0-0.9.22-6.9.1.i586
    libpulse-mainloop-glib0-0.9.22-6.9.1.i586
    pulseaudio-utils-0.9.22-6.9.1.i586
    pulseaudio-module-bluetooth-0.9.22-6.9.1.i586
    libxine1-pulse-1.1.19-4.4.i586
    pulseaudio-esound-compat-0.9.22-6.9.1.i586
    pulseaudio-module-lirc-0.9.22-6.9.1.i586
    linux-nnhp:~> sudo rpm -q libasound2
    libasound2-1.0.24.1-3.1.i586
    linux-nnhp:~> sudo uname -a
    Linux linux-nnhp.site 2.6.37.1-1.2-default #1 SMP 2011-02-21 10:34:10 +0100 i686 i686 i386 GNU/Linux
    linux-nnhp:~> sudo cat /etc/modprobe.d/50-sound.conf

    options snd slots=snd-hda-intel
    # u1Nb.Kd3VUUVAEMF:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: hp mini 110-3000 mic not working

    Quote Originally Posted by hdtown View Post
    OK, thanks. I note a 32-bit openSUSE-11.4 running on your HP Mini 110-3000 with the old 2.6.37.1-1.2-default kernel. Is there any reason why you have not accepted the nominal kernel security update for 11.4 (as that also has sound device fixes incorporated) ?

    I note the alsa sound driver is version 1.0.23 (and its utilities version 1.0.24.2). The hardware audio codec of your HP Mini 110-3000 is identified as an IDT (Stac) 92HD88B1. Searching the alsa driver website suggests support for the 92HD88B1 was added as of alsa version 1.0.2.3.

    For recording devices I note:
    Code:
    ARECORD
    
    **** List of CAPTURE Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
      Subdevices: 1/2
      Subdevice #0: subdevice #0
      Subdevice #1: subdevice #1
    which suggests your hardware record device is hw:0,0 and hw:0,1.

    Quote Originally Posted by hdtown View Post
    Ok, so I installed pavucontrol, but when I tried recording, the pavucontrol program wasn't able to pick up any sound, but when I play music, the pavucontrol input shows that it is receiving sound, but when I speak something (using the command you wrote down earlier), though pavucontrol lists the application that is recording sound as 'ALSA', it doesn't seem to pick up any sound at all. In the terminal too, the last line stays at 00 % .
    It appears you "MAY" have capture muted in pavucontrol dependent on which input record method you are using ? Are using an internal integrated mic in your record attempts ? Or have you plugged in an external Mic and trying to use that in your record attempts How many input jacks for a Mic are there are your HP Mini ?

    ie 'internal' or 'external' ? Which are you trying to use ?

    When I look at the mixer settings I note:
    Code:
    !!Amixer output
    !!-------------
    
    !!-------Mixer controls for card 0 [Intel]
    
    Card hw:0 'Intel'/'HDA Intel at 0x54200000 irq 43'
      Mixer name	: 'IDT 92HD88B1'
    Simple mixer control 'Speaker',0
      Front Left: Playback 0 [0%] [-48.00dB] [on]
      Front Right: Playback 0 [0%] [-48.00dB] [on]
    Simple mixer control 'PCM',0
      Front Left: Playback 0 [0%] [-51.00dB]
      Front Right: Playback 0 [0%] [-51.00dB]
    Simple mixer control 'Front Mic Jack Mode',0
      Items: 'Mic In' 'Line In'
      Item0: 'Mic In'
    Simple mixer control 'Mic',0
      Front Left: Capture 1 [33%] [10.00dB]
      Front Right: Capture 1 [33%] [10.00dB]
    Simple mixer control 'Capture',0
      Front Left: Capture 15 [100%] [22.50dB] [on]
      Front Right: Capture 15 [100%] [22.50dB] [on]
    Simple mixer control 'Capture',1
      Front Left: Capture 0 [0%] [0.00dB] [off]
      Front Right: Capture 0 [0%] [0.00dB] [off]
    You need to figure out if the record hardware you are using (internal integrated mic or external mic) is capture 0 or capture 1. Clearly you have capture 1 muted (at 0% capture and OFF). In addition your mini's mixer has capture at 33% which IMHO is too low. Move it up to 66% or higher for testing.

    Dependant on your mic, you could also try testing with these 3 different arecord commands, where this is likely the best command (together with pavucontrol):
    Code:
    arecord -vv -f cd test.wav
    and where one has the following two commands direct to the alsa device to record:

    For device-0 :
    Code:
    arecord -D hw:0,0 -vv -f cd test0.wav
    and for device-1 :
    Code:
    arecord -D hw:1,0 -vv -f cd test1.wav
    and play back with a multimedia application to see if there is sound. Note you will hear NO SOUND with PCM at 0% and speaker at 0%.

    Please ensure your pulse audio Configuration tabs and Input tabs are setup correctly !

    A screen shot of those (when attempting to record) would be handy.

    AND a reminder, your volume controls make no sense. You have PCM volume at 0% and you have speaker volume at 0%. I don't know how you can get any audio output with those settings. So even if you record with the arecord command, you will hear nothing with those playback settings.

  5. #5

    Default Re: hp mini 110-3000 mic not working

    Quote Originally Posted by oldcpu View Post
    OK, thanks. I note a 32-bit openSUSE-11.4 running on your HP Mini 110-3000 with the old 2.6.37.1-1.2-default kernel. Is there any reason why you have not accepted the nominal kernel security update for 11.4 (as that also has sound device fixes incorporated) ?
    How do I update ?
    I note the alsa sound driver is version 1.0.23 (and its utilities version 1.0.24.2). The hardware audio codec of your HP Mini 110-3000 is identified as an IDT (Stac) 92HD88B1. Searching the alsa driver website suggests support for the 92HD88B1 was added as of alsa version 1.0.2.3.

    For recording devices I note:
    Code:
    ARECORD
    
    **** List of CAPTURE Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
      Subdevices: 1/2
      Subdevice #0: subdevice #0
      Subdevice #1: subdevice #1
    which suggests your hardware record device is hw:0,0 and hw:0,1.



    It appears you "MAY" have capture muted in pavucontrol dependent on which input record method you are using ? Are using an internal integrated mic in your record attempts ? Or have you plugged in an external Mic and trying to use that in your record attempts How many input jacks for a Mic are there are your HP Mini ?

    ie 'internal' or 'external' ? Which are you trying to use ?
    It is an internal mic, there is no input jack for an external mic

    When I look at the mixer settings I note:
    Code:
    !!Amixer output
    !!-------------
    
    !!-------Mixer controls for card 0 [Intel]
    
    Card hw:0 'Intel'/'HDA Intel at 0x54200000 irq 43'
      Mixer name	: 'IDT 92HD88B1'
    Simple mixer control 'Speaker',0
      Front Left: Playback 0 [0%] [-48.00dB] [on]
      Front Right: Playback 0 [0%] [-48.00dB] [on]
    Simple mixer control 'PCM',0
      Front Left: Playback 0 [0%] [-51.00dB]
      Front Right: Playback 0 [0%] [-51.00dB]
    Simple mixer control 'Front Mic Jack Mode',0
      Items: 'Mic In' 'Line In'
      Item0: 'Mic In'
    Simple mixer control 'Mic',0
      Front Left: Capture 1 [33%] [10.00dB]
      Front Right: Capture 1 [33%] [10.00dB]
    Simple mixer control 'Capture',0
      Front Left: Capture 15 [100%] [22.50dB] [on]
      Front Right: Capture 15 [100%] [22.50dB] [on]
    Simple mixer control 'Capture',1
      Front Left: Capture 0 [0%] [0.00dB] [off]
      Front Right: Capture 0 [0%] [0.00dB] [off]
    You need to figure out if the record hardware you are using (internal integrated mic or external mic) is capture 0 or capture 1. Clearly you have capture 1 muted (at 0% capture and OFF). In addition your mini's mixer has capture at 33% which IMHO is too low. Move it up to 66% or higher for ....
    How do I unmute it ?
    How do how I move up the capture % ?
    Dependant on your mic, you could also try testing with these 3 different arecord commands, where this is likely the best command (together with pavucontrol):
    Code:
    arecord -vv -f cd test.wav
    and where one has the following two commands direct to the alsa device to record:

    For device-0 :
    Code:
    arecord -D hw:0,0 -vv -f cd test0.wav
    and for device-1 :
    Code:
    arecord -D hw:1,0 -vv -f cd test1.wav
    and play back with a multimedia application to see if there is sound. Note you will hear NO SOUND with PCM at 0% and speaker at 0%.


    Please ensure your pulse audio Configuration tabs and Input tabs are setup correctly !

    A screen shot of those (when attempting to record) would be handy.

    AND a reminder, your volume controls make no sense. You have PCM volume at 0% and you have speaker volume at 0%. I don't know how you can get any audio output with those settings. So even if you record with the arecord command, you will hear nothing with those playback settings.
    I think I know whats happening, when I shout into the laptop, the slider moves a little and terminal shows 2 %, and when I play music at the highest possible volume it moves to 15 % . I do not know about the volume controls, I can hear music perfectly, and youtube videos too have perfect audio.

    When I tried capturing via capturing via :

    linux-nnhp:~> sudo arecord -D hw:1,0 -vv -f cd test1.wav
    ALSA lib pcm_hw.c:1401_snd_pcm_hw_open) Invalid value for card
    arecord: main:660: audio open error: No such file or directory
    Attached Images :



  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: hp mini 110-3000 mic not working

    Quote Originally Posted by hdtown View Post

    When I tried capturing via capturing via :
    Code:
    sudo arecord -D hw:1,0 -vv -f cd test1.wav
    Do NOT use sudo. Please! You do NOT need root permissions to do this. If you had needed root permissions, I would have done my best to advise you.

    PLEASE do this as a regular user.

    Now having typed that - I'm bad ! Try instead:
    Code:
    sudo arecord -D hw:0,1 -vv -f cd test1.wav

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: hp mini 110-3000 mic not working

    Quote Originally Posted by hdtown View Post
    It is an internal mic, there is no input jack for an external mic
    Are you certain ?? Quite often in netbooks it is a SHARED jack.

    I note this from the manual for the HP Mini 110:


    [click on image for larger view]

    and a closer view:

    [click on image for larger view]

    and also:

    [click on image for larger view]

    Now I do NOT normally take the time to look at someone else's user manual, but it is VERY RARE that there is NOT an input record jack, hence I wanted to be sure as best I could before I contracted what you noted.

    This IS IMPORTANT as to understand the script diagnostic output I need to understand your hardware. Its also important you understand the same.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: hp mini 110-3000 mic not working

    Quote Originally Posted by hdtown View Post
    How do I update ?
    One way is to update via YaST > Software > Software Maintenance.

    Quote Originally Posted by hdtown View Post
    How do I unmute it ?
    How do how I move up the capture % ?
    You need to look at the 'pavucontrol' configuration tab and input device tab. And then be VERY careful as to what you select in the drop down menu options.

    MOST important is to understand your hardware as you likely have MORE THAN ONE record device.

  9. #9

    Default Re: hp mini 110-3000 mic not working

    I am not able to see anything like Software Maintenance, though Software Management exists.

    All I see in the configuration tab is :



    I am sorry, yes that is a shared jack, I'd used it in the past with my iPod's headset. So, I plugged it in and this is what is got :



    Even if I speak softly, it goes upto 99 %

  10. #10

    Default Re: hp mini 110-3000 mic not working

    ~Double post removed~

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •