Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Need help with 3D acceleration

  1. #1
    Join Date
    Jan 2010
    Location
    Tbilisi, Georgia.
    Posts
    44

    Unhappy Need help with 3D acceleration

    Please help me with my video driver. I have IBM ThinkPad X40 laptop (I know it's an old one, but it still works great) and though most of the time, I'm using M$ operating systems (because of my work), I also want to become more familiar with Linux systems, so I have dual boot on my laptop. Last year I had installed OpenSUSE 11.2 x86 on this notebook and my graphics drivers worked perfectly (with full 3D acceleration). Now I decided to install newer version OpenSUSE 11.4 (i586) with KDE 4.6 and kernel version 2.6.37.6. I like to have always updated systems, so I have all the necessary repositories and all fixes installed. But I have problem with my graphics video adapter: Intel 855GM. The fact is that for 3D acceleration my operating system uses Unknown classic (7.10.2) driver.

    I know, there's a lot of already written about video drivers, but I've tried them all and nothing helped me, or maybe i was doing something wrong. I like thread about SDB:Configuring graphics cards and also very helpful thread: Essential openSUSE Practical Graphic Card Theory (thanks to oldspu), but I could not help myself. I tried to boot with 'nomodeset' command, I also tried to manually configure /etc/X11/xorg.conf.d/50-device.conf file, but as i understand, all of those suggestions are for people, who are either unable to boot GUI (I mean X Widow), or who gets wrong display resolution. But, in my case, I can boot in normal mode KDE Desktop and even play games, but when I'm trying to switch visual effects on, then my poor laptop goes crazy. Screen begins blinking and hanging.

    I just want to ask you, where can I find configuration file, where I could set for using 3D driver, also from intel. As I said above, when I had OpenSUSE 11.2, I also used intel driver for both 2D and 3D (it was installed automatically) and 3D acceleration worked great (I've Upgraded my operating memory, so i have 1.5GB installed and have no problem with that). So, I think, if I'll manage how to say to operating system, to use intel driver for 3D, this should solve all my problems.

    It's very strange that Intel is cooperating with FSF very actively, they have official free drivers, they develop their distribution for mobile platforms and why it's so difficult to get proper 3D acceleration on Linux distribution with an older graphics adapter.

    Please, maybe someone help me with that.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Need help with 3D acceleration

    This may offer advice
    Category40 - ThinkWiki

    Your driver sounds correct.
    Same as mine

    Though I have

    Vendor: Intel Corporation
    Model: Mobile Intel® GM45 Express Chipset
    2D driver: intel
    3D driver: Unknown classic (7.10.2)
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2010
    Location
    Bedfordshire, United Kingdom
    Posts
    116

    Default Re: Need help with 3D acceleration

    Hi,

    It is possible that the Intel Legacy driver might help you (as it did with my 915GM graphics).

    Add a line to /etc/X11/xorg.conf.d/50-device.conf (within the Section "Device" and EndSection block), as follows, and restart X:
    Code:
        Driver "intellegacy"
    Regards,
    Neil Darlow
    Registered Linux user #122512. Desktop Linux user for 17 years.
    Asus Eee 900: 900MHz Celeron, 1GB RAM, 12GB SSD, 915GM, openSUSE-current+Tumbleweed
    Home-built Desktop: Athlon II X2 3.3GHz, 4GB RAM, 1TB SATA, GeForce G210, openSUSE-12.1-x86_64, KDE-4.7.2

  4. #4
    Join Date
    Jan 2010
    Location
    Tbilisi, Georgia.
    Posts
    44

    Default Re: Need help with 3D acceleration

    Can you please tell me, what does this 'Unknown classic' mean? Is this some kind of 3D video driver, or it just means that the driver it uses for 3D is Unknown? I just want to find out, in which configuration file is written which driver to use for 3D? I know that one big advantage of linux distributions over the Windows is, that Microsoft has messy registry and linux on the other hand has clear configuration files, which can be read in a simple text editor. So, why we can't find where it gets the command what driver to use for 3D? As I mentioned above, I tried to configure Xorg file and put there manually device driver 'intel', but it didn't override the system's state. Anyway it said that for 2D driver uses intel, but for 3D ...

    By the way, I have one question regarding to malualy building the Xorg configuration file. When I'll create it under runlevel 3, after restarting, should i put 'nomodeset' anyway, or system will automatically load the legacy driver from xorg.conf? (though I tried both versions and neither helped me).

  5. #5
    Join Date
    Jan 2010
    Location
    Tbilisi, Georgia.
    Posts
    44

    Default Re: Need help with 3D acceleration

    Quote Originally Posted by neildarlow View Post
    Hi,

    It is possible that the Intel Legacy driver might help you (as it did with my 915GM graphics).

    Add a line to /etc/X11/xorg.conf.d/50-device.conf (within the Section "Device" and EndSection block), as follows, and restart X:
    Code:
        Driver "intellegacy"
    Regards,
    Neil Darlow
    Hi, thanks for suggestion, but when I'm trying to put in configuration files 'intellegacy', I get just a blank screen, though I have xorg-x11-driver-video-intel package installed on my system. Anyway the intellegacey is driver for an older graphics chipset (even for olders then mine), as according to official documentation, for my (855GM) chip, I should use driver with code name 'intel' (which my computer now uses just for the 2D acceleration).

  6. #6
    Join Date
    Jan 2010
    Location
    Tbilisi, Georgia.
    Posts
    44

    Default Re: Need help with 3D acceleration

    Quote Originally Posted by caf4926 View Post
    This may offer advice
    Category40 - ThinkWiki

    Your driver sounds correct.
    Same as mine

    Though I have
    Yes, it's very strange why it's so difficult to configure video chip, when we have free opensource official driver? Your graphics chip looks a brand new one (compared with mine) and you also have the same problem?!! ****, it seems we have no solution. But everything worked so great on 11.2

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Need help with 3D acceleration

    vojd wrote:

    >
    > Can you please tell me, what does this 'Unknown classic' mean? Is this
    > some kind of 3D video driver, or it just means that the driver it uses
    > for 3D is Unknown?

    I have to say that my knowledge about intel drivers is not good, but it may
    help if you post the output of the command glxinfo to susepaste.org and then
    post the link here, it gives a more detailed output for the opengl (3d)
    features of your driver in use.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Need help with 3D acceleration

    martin_helm wrote:

    > vojd wrote:
    >
    >>
    >> Can you please tell me, what does this 'Unknown classic' mean? Is this
    >> some kind of 3D video driver, or it just means that the driver it uses
    >> for 3D is Unknown?

    > I have to say that my knowledge about intel drivers is not good, but it
    > may help if you post the output of the command glxinfo to susepaste.org
    > and then post the link here, it gives a more detailed output for the
    > opengl (3d) features of your driver in use.
    >

    Before I forget the desktop effects rely to a large degree NOT on 3d
    features but the composite features of the graphic card and drivers, which
    is a bit a different beast.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Need help with 3D acceleration

    I do not know if that affects you, but I found an article (in german) which
    states that there is a kernel bug (no link there, sorry) for the 855GM which
    is solved in kernel 2.6.38.

    Maybe one of the intel graphic users more familiar with your card can
    comment on that if it makes sense to update your kernel or not, I have no
    idea.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  10. #10
    Join Date
    Jan 2010
    Location
    Tbilisi, Georgia.
    Posts
    44

    Default Re: Need help with 3D acceleration

    Quote Originally Posted by martin_helm View Post
    vojd wrote:

    >
    > Can you please tell me, what does this 'Unknown classic' mean? Is this
    > some kind of 3D video driver, or it just means that the driver it uses
    > for 3D is Unknown?

    I have to say that my knowledge about intel drivers is not good, but it may
    help if you post the output of the command glxinfo to susepaste.org and then
    post the link here, it gives a more detailed output for the opengl (3d)
    features of your driver in use.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram
    Thanks for your reply, because of time zones, I was sleeping and thats why I delayed with response. Now I'm at work and have not my laptop with me. When I go back, I'll try what you asked and post the command output here, hope you'll have some ideas about this. Thanks in advance.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •