Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Incorrect Resolution - Toshiba Portege 3505 - openSUSE 11.4

  1. #1

    Default Incorrect Resolution - Toshiba Portege 3505 - openSUSE 11.4

    Hello everyone,
    I'm new to Linux and just recently installed openSUSE 11.4 on my Toshiba Portege 3505 using a Trident Cyberblade XP graphics card. I'm receiving a 800x600 resolution and my machine is capable of 1024x768.
    After reading other threads, I did a level 3 boot and edited the 50-device.conf file via mcedit to load Driver "trident" - no change in resolution and 1024x768 is not an option.
    I also attempted Driver "vesa" - that loads the correct resolution however results in a refresh of "0.0" and boots slow and won't shut down properly.
    Please help.
    Thanks in advance,
    Nate

  2. #2

    Default Re: Incorrect Resolution - Toshiba Portege 3505 - openSUSE 11.4

    Update-
    After loading Driver "trident" I realized I lost stylus/tablet capabilities and removed Driver "trident" from 50-device.conf file reverting to the original Driver "radeon".
    Can I edit/add a modeline to the 50-monitor.conf file to accept the higher resolution?
    Thanks,
    Nate

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: Incorrect Resolution - Toshiba Portege 3505 - openSUSE 11.4

    The trident driver is probably the optimal one for your old graphics card (although the vesa driver will provide basic framebuffer graphics too).

    After loading Driver "trident" I realized I lost stylus/tablet capabilities and removed Driver "trident" from 50-device.conf file reverting to the original Driver "radeon".
    The radeon driver is not correct for your hardware, but 50-device.conf contains a commented line by default
    Code:
    #Driver "radeon"
    Starting over (without any config adjustments made by yourself), please confirm which driver is reported by

    Code:
    /usr/sbin//hwinfo --gfxcard
    and the available display modes via

    Code:
    xrandr
    If the 1024x768 resolution is available, the solution is simple, and further advice can be given when you post the requested information.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: Incorrect Resolution - Toshiba Portege 3505 - openSUSE 11.4

    Can I edit/add a modeline to the 50-monitor.conf file to accept the higher resolution?
    It may be as simple as uncommenting and adjusting the horizontal sync frequencies and vertical refresh rates in 50-monitor.conf

    Code:
    Section "Monitor"
      Identifier "Default Monitor"
    
      ## If your monitor doesn't support DDC you may override the
      ## defaults here
      HorizSync 35-50
      VertRefresh 50-65
    
      ## Add your mode lines here, use e.g the cvt tool
    
    EndSection
    You can also add a modeline if needed, but try the above first. Then restart the X-server with CTRL-ALT-Backspace (twice). I assume your comfortable with editing system files (with root write permissions)?

    The last post in this thread uses the same approach.

    Another potentially useful Ubuntu thread on the same topic.

  5. #5

    Default Re: Incorrect Resolution - Toshiba Portege 3505 - openSUSE 11.4

    IT could also be a driver issue aswell

  6. #6

    Default Re: Incorrect Resolution - Toshiba Portege 3505 - openSUSE 11.4

    Okay, here's what I have:

    Nathaniel@linux-lkpw:~> /usr/sbin//hwinfo --gfxcard
    21: PCI 100.0: 0300 VGA compatible controller (VGA)
    [Created at pci.318]
    Unique ID: VCu0.6cQOYSsnuTD
    Parent ID: vSkL.UhtfYY3x88D
    SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
    SysFS BusID: 0000:01:00.0
    Hardware Class: graphics card
    Model: "Trident Microsystems 8820"
    Vendor: pci 0x1023 "Trident Microsystems Inc."
    Device: pci 0x8820 "8820"
    SubVendor: pci 0x1179 "Toshiba America Info Systems"
    SubDevice: pci 0x0010
    Revision: 0x82
    Memory Range: 0xfc000000-0xfdffffff (rw,non-prefetchable)
    Memory Range: 0xfbc00000-0xfbffffff (rw,non-prefetchable)
    Memory Range: 0xf8000000-0xf9ffffff (rw,non-prefetchable)
    Memory Range: 0xf7ff8000-0xf7ffffff (rw,non-prefetchable)
    Memory Range: 0x38000000-0x3800ffff (ro,non-prefetchable,disabled)
    IRQ: 11 (1773 events)
    I/O Ports: 0x3c0-0x3df (rw)
    Module Alias: "pci:v00001023d00008820sv00001179sd00000010bc03sc00i00"
    Driver Info #0:
    XFree86 v4 Server Module: trident
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #8 (PCI bridge)

    Primary display adapter: #21
    Nathaniel@linux-lkpw:~> xrandr
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 320 x 240, current 800 x 600, maximum 800 x 600
    default connected 800x600+0+0 0mm x 0mm
    800x600 60.0* 56.0
    640x480 60.0
    400x300 60.0 56.0
    320x240 60.0

    I removed any configurations I entered with the exception of Driver "trident" I'm 100% comfortable editing system files, although I have too large a resolution in level 3 boot and have to watch my keystrokes because I'm literally typing commands blind. What I need to see in mcedit displays fine though. I'll wait to attempt further configurations on 50-device.conf and 50-monitor.conf until this post has been reviewed.

    Thanks for your help!
    Nate

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: Incorrect Resolution - Toshiba Portege 3505 - openSUSE 11.4

    Your xrandr output suggests that the X-server may be having a problem with your display's EDID, so it falls back to the 'safe' 800x600 display mode. As a first approach, try a minimal edit of /etc/X11/xorg.conf.d/50-monitor.conf, as outlined previously. (Editing of 50-device.conf should be necessary). If this does not help with getting 1024x768, then it may also be necessary to add a mode reference in 50-screen.conf like this

    Code:
    Section "Screen"
      Identifier "Default Screen"
    
      Device "Default Device"
    
      ## Doesn't help for radeon/radeonhd drivers; use magic in
      ## 50-device.conf instead
      Monitor "Default Monitor"
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1024x768"
    EndSubSection 
    EndSection
    An alternative, is to use the legacy /etc/X11/xorg.conf approach, which puts all the applicable sections in one file instead. You'll need to create it from scratch.

    Code:
    Section "Monitor"
    Identifier "Default Monitor"
    HorizSync 35-60
    VertRefresh 50-65
    EndSection
    
    Section "Device"
    Identifier "Default Device"
    Driver "trident"
    EndSection
    
    Section "Screen"
    Identifier "Default Screen"
    Device "Default Device"
    Monitor "Default Monitor"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1024x768"
    EndSubSection
    EndSection
    Last edited by deano_ferrari; 04-Jun-2011 at 13:53.

  8. #8

    Default Re: Incorrect Resolution - Toshiba Portege 3505 - openSUSE 11.4

    Hi,
    I edited the 50-monitor.conf and 50-screen.conf files as suggested and.....SUCCESS! I am now enjoying the correct resolution on my notebook plus restored tablet functions!

    Many thanks!
    Nate

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: Incorrect Resolution - Toshiba Portege 3505 - openSUSE 11.4

    Well done!

  10. #10
    Join Date
    Jun 2011
    Location
    UK
    Posts
    31

    Default Re: Incorrect Resolution - Toshiba Portege 3505 - openSUSE 11.4

    I have just installed Suse 11.4 on a Toshiba Portege R100 - same Trident Cyberblade adaptor as the Portege 3505
    After install - Failsafe was fine, but otherwise I had a black border round the screen and could only get 600x800 resolution with the same error regarding failing to get size of gamma for output device
    Just to say that editing the 50-monitor.conf and 50-screen.conf (after backing them up) as mentioned here worked perfectly!
    Thank you so much for a fantastic post.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •