Results 1 to 5 of 5

Thread: Problem with kde libraries after upgrade

  1. #1

    Default Problem with kde libraries after upgrade

    Dear all, yesterday
    I saw in my kde environment that there are some packages that I should reconsider updgrading/updating.

    Since then most kde applications return an error

    For example when I want to launch konqueror I get the message.

    The plugin konq_aboutpage uses an incompatible KDE library (4.6.3 (4.6.3) "release 4")

    Might be some problem with my repositories.
    How I can dump here my repositories to check?

    regards
    Alex

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Problem with kde libraries after upgrade

    On 06/03/2011 02:06 PM, alaios wrote:

    > How I can dump here my repositories to check?


    show us the output of entering the following into a terminal

    Code:
    zypper lr -d
    and copy/paste the output back to this thread using the instructions
    here: http://goo.gl/i3wnr

    you are, of course welcome to hang out and see if a fellow bleeding
    edger has some words of advice.....mine would be to fall back to 4.6.0

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  3. #3

    Default Re: Problem with kde libraries after upgrade

    Code:
    #  | Alias                                 | Name                                  | Enabled | Refresh | Priority | Type   | URI                                                                                    | Service
    ---+---------------------------------------+---------------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------------------+--------
     1 | 11.3_gnome_apps                       | 11.3 gnome apps                       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Apps/GNOME_STABLE_2.30_openSUSE_11.3/ |        
     2 | Editors                               | Editors                               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/editors/openSUSE_11.4/                       |        
     3 | KDS                                   | KDS                                   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Distro:/Stable/openSUSE_11.4/           |        
     4 | KR46                                  | KR46                                  | Yes     | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/46/openSUSE_11.4/              |        
     5 | KR46-extra                            | KR46-extra                            | Yes     | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.4/     |        
     6 | devel:languages:R:patched             | devel:languages:R:patched             | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/R:/patched/openSUSE_11.2/  |        
     7 | google-earth                          | google-earth                          | No      | No      |   99     | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64                                     |        
     8 | home:eugeneus                         | home:eugeneus                         | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/home:/eugeneus/openSUSE_11.2/                |        
     9 | http://packman.iu-bremen.de/suse/11.4 | http://packman.iu-bremen.de/suse/11.4 | Yes     | Yes     |   99     | rpm-md | http://packman.iu-bremen.de/suse/11.4                                                  |        
    10 | openSUSE-11.4-Debug                   | openSUSE-11.4-Debug                   | No      | No      |   99     | yast2  | http://download.opensuse.org/debug/distribution/11.4/repo/oss/                         |        
    11 | openSUSE-11.4-Source                  | openSUSE-11.4-Source                  | No      | No      |   99     | yast2  | http://download.opensuse.org/source/distribution/11.4/repo/oss/                        |        
    12 | openSUSE:11.4                         | openSUSE:11.4                         | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                               |        
    13 | openSUSE:11.4:Contrib                 | openSUSE:11.4:Contrib                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/11.4:/Contrib/standard/            |        
    14 | repo-11.4-non-oss                     | openSUSE-11.4 Non-OSS                 | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                           |        
    15 | repo-11.4-oss                         | openSUSE-11.4 OSS                     | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                               |        
    16 | repo-11.4-update                      | openSUSE-11.4 Updates                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/                                              |        
    17 | wine_11.4                             | wine 11.4                             | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators%3a/Wine/openSUSE_11.4/             |

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Problem with kde libraries after upgrade

    On 06/03/2011 05:06 PM, alaios wrote:

    > 1 | 11.3_gnome_apps | 11.3 gnome apps | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_11.3/ |
    > 2 | Editors | Editors | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_11.4/ |
    > 3 | KDS | KDS | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_11.4/ |
    > 4 | KR46 | KR46 | Yes | Yes | 98 | rpm-md | http://download.opensuse.org/reposit...openSUSE_11.4/ |
    > 5 | KR46-extra | KR46-extra | Yes | Yes | 98 | rpm-md | http://download.opensuse.org/reposit...openSUSE_11.4/ |


    yep, i am not surprised you are having trouble..

    i guess you never got around to reading the stuff laid for folks new to
    openSUSE...there are great documents in doc.openSUSE.org, and some good
    info in the wiki en.opensuse.org and especially well written is a
    paragraph in the new to openSUSE area of these fora, the one which
    begins with "IMPORTANT" in this post: http://tinyurl.com/33qc9vu

    so instead of just the four repos you should have until you are ready to
    solve the problems which can arise from having others, you currently
    have enabled repos for *11.3* (repo 1) as well as 11.4 editors (repo 2),
    three advanced KDE repos (3, 4, 5)..

    so my first advice would be to follow the 'IMPORTANT' paragraph, until
    you are prepared to solve the problems caused by not...

    but, doing that at this stage i'm sure what the impact would be...

    and, then second i'd note that the four safe, dependable and well tested
    repos of openSUSE 11.4 (oss, non-oss, update and packman) contain KDE
    4.6.0--but the version you are now having trouble with (4.6.3) has not
    yet been released with any version of openSUSE..

    sorry, since i've never even seen 4.6.3 run, i have to exit this thread
    and let another help you...i don't do bleeding edge, but there are a lot
    here do...i expect someone will step up and lend a hand..

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  5. #5
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Problem with kde libraries after upgrade

    On Fri, 03 Jun 2011 22:26:14 +0530, DenverD
    <DenverD@no-mx.forums.opensuse.org> wrote:

    > yep, i am not surprised you are having trouble..



    ....not surprised either. you're mixing repo.s from 11.2, 11.3, and 11.4
    openSUSE releases. and then also incompatible KDE repos.
    KDE:/Distro:/Stable and KDE:/Release:/46 are the same major, but different
    minor versions (4.6.0 & 4.6.3), and that doesn't go together.

    if i were in your situation, i'd follow DeverD's advice: first of all read
    up about the basics. then remove/disable all repos except those basic four
    (see DenverD's post), refresh them all, and do a 'distribution upgrade.'
    from the command line (as root): "zpper dup" -- and then hope that
    everything gets sorted out properly.

    i never had a situation as mixed up as your's, but i can imagine that,
    with so many different versions of libraries, dependencies, etc., around,
    zypper may have a hard time. it _should_ work...


    --
    phani.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •