Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Very unstable sound

  1. #1

    Default Very unstable sound

    Hi,

    This has been going on for a long long time now (probably since 2 years)...but very often my sound stops working. Before i was able to restart ALSA and that would solve the problem, just a bit of nuisance, but it did the trick. Recently however when i restart ALSA (using rcalsasound restart) my network stops working and my icons in the tray revert to very old ones.
    I have been trying my things over the past years, especially in the last weeks, but nothing seems to create a stable environment.

    This is what i have:
    Dell Precision M6300
    OpenSUSE 11.4
    KDE 4.6.3
    kernel:2.6.37.6-0.5-desktop

    head -n 1 /proc/asound/card0/codec* returns
    ==> /proc/asound/card0/codec#0 <==
    Codec: SigmaTel STAC9205

    ==> /proc/asound/card0/codec#1 <==
    Codec: Conexant ID 2c06

    Driver is Driver snd-hda-intel (82801H (ICH8 Family) HD Audio Controller)
    (i have only model set to dell-m43)

    I have disabled PulseAudio (thinking a while back that was perhaps the problem). However when i start alsamixer it complains that it cannot connect with PulseAudio

    My Phonon backend is gstreamer (installed gstreamer-0_10)

    Sometimes it works, and then it just drops (very often)

    Any help is very much appreciated

  2. #2
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Very unstable sound

    Hi,

    If you reactivate Pulse Audio, do have the same symptoms ?

  3. #3
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Very unstable sound

    Quote Originally Posted by rparree View Post
    ...I have disabled PulseAudio (thinking a while back that was perhaps the problem). However when i start alsamixer it complains that it cannot connect with PulseAudio
    How did you disable PulseAudio e.g with Yast or some other way? Did you do it before or after upgrading KDE from 4.6.0?

  4. #4

    Default Re: Very unstable sound

    Yes using Yast....a while back i found a command line way of removing PulseAudio, but can't seem to find it anymore. I have disabled it before 4.6.0 and in my struggle to get things to work again i have enabled it and then disabled it again during 4.6.0

  5. #5

    Default Re: Re : Very unstable sound

    yes, have tried that, but i get different problems (like i am only seeing Pulse as the audio option in phonon)

  6. #6
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Re : Very unstable sound

    Yes, that is normal and it is not a problem, it is a feature.

    What are those other problems ?

  7. #7
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Very unstable sound

    Quote Originally Posted by rparree View Post
    I have disabled it before 4.6.0 and in my struggle to get things to work again i have enabled it and then disabled it again during 4.6.0
    Not sure what you mean by the words in red? openSUSE 11.4 was released with KDE 4.6.0, so what do you mean by "before"?

    Was PulseAudio enabled or disabled when you performed the upgrade to KDE 4.3?

  8. #8
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Very unstable sound

    In fact, Pulse Audio is activated by default on a fresh install of the 11.4.

  9. #9

    Default Re: Very unstable sound

    I had the problem before 11.4.

    I don't know if it was enabled or disabled. I guess disabled, but am not sure

  10. #10

    Default Re: Re : Re: Re : Very unstable sound

    Kmix taking one whole CPU...i remember finding a post that suggested disabling PulseAudio. I did and the problem went away.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •