Results 1 to 10 of 10

Thread: Problem in stalling .rpm packages

  1. #1
    Join Date
    Jun 2011
    Location
    Delhi
    Posts
    11

    Default Problem in stalling .rpm packages

    Dear All,

    I am new to Open Suse 11.4 in fact to Linux. I was trying to install a statistical package "pspp-0.7.8-2.1.i586.rpm"

    An error pops up saying "[PK_TMP_DIR|dir:///var/tmp/TmpDir.eYc5jn] Repository already exists."
    "failed to install file: [PK_TMP_DIR|dir:///var/tmp/TmpDir.eYc5jn] Repository already exists."

    Since i am new to this i don't even know what it means please help me.

    Thanks in advance
    Reddy

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Problem in stalling .rpm packages

    On 06/03/2011 09:36 AM, rajasereddy wrote:
    >
    > Dear All,
    >
    > I am new to Open Suse 11.4 in fact to Linux. I was trying to install a
    > statistical package "pspp-0.7.8-2.1.i586.rpm"
    >
    > An error pops up saying "[PK_TMP_DIR|dir:///var/tmp/TmpDir.eYc5jn]
    > Repository already exists."
    > "failed to install file: [PK_TMP_DIR|dir:///var/tmp/TmpDir.eYc5jn]
    > Repository already exists."
    >
    > Since i am new to this i don't even know what it means please help me.
    >
    > Thanks in advance
    > Reddy
    >
    >

    usually it means that you have experienced an abort or crash of a
    previous attempt to install this or maybe a different RPM..

    as you are new i'll mention you should always, when asking a question
    here, tell what Desktop Environment you are using....because the answer
    will change according to what you are using....i don't know what you
    have so i'll give you what works on my KDE:

    do this CAREFULLY, go to the main menu, system, file manager and find
    and open File Manager Super User Mode, before it opens you will ave to
    enter your root password, then navigate up the tree until you can enter
    the /var directory (CAREFUL, there is also a /tmp), then nav on to
    /var/tmp and locate TmpDir.eYc5jn, single right click and select Move to
    Trash.....then close the File Manager--do NOT leave it open, it is so
    easy to kill your whole system accidentally in Super User Mode..

    now, how were you trying to install the rpm, and where did it come from?

    i ask because you should normally try to use YaST to install/remove
    software from your machine...i always make YaST my _first_ stop, and i
    always keep only four repos enabled (oss, non-oss, update and
    packman)...so if i search now i do not find pspp, so i go to my second
    stop: http://software.opensuse.org/search and spin the dial to match my
    11.4, type in pspp and enter...and up pops info showing pspp exists in
    the openSUSE-s 'education' repo...and, there is a 1-Click Install link,
    click it and cross your fingers...it will probably install pretty quick..

    doing it that way easy, but there are some pitfalls...during the process
    you will have the chance to select to keep the repo enabled, or not....i
    advise to always select not!

    remember that 1-Click is second choice..

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  3. #3
    Join Date
    Jun 2011
    Location
    Delhi
    Posts
    11

    Default Re: Problem in stalling .rpm packages

    Thanks Denver

    I am using Gnome environment. How could i open file manager in super user mode? I didn't find any option.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Problem in stalling .rpm packages

    Do this as su -

    Code:
    zypper rr PK_TMP_DIR
    Now click this
    http://software.opensuse.org/ymp/Edu...1.4&query=pspp
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Problem in stalling .rpm packages

    On 06/04/2011 08:06 AM, rajasereddy wrote:
    >
    > Thanks Denver
    >
    > I am using Gnome environment. How could i open file manager in super
    > user mode? I didn't find any option.
    >
    >


    if it is not in the menu, then try launching using the "run" command,
    thusly:

    1. hold down Alt
    2. momentarily press F2
    3. in the resulting popup blank type
    Code:
    gnomesu nautilus
    4. press Enter
    5. in the popup requesting it, type in & enter your root password
    6. shazam, a superuse powered Nautilus opens before your eyes..

    note, the same path can be followed to open other root powered apps
    (like say gedit if you find you need to edit a root owned configure
    file)...unlike some other operating systems you may have encountered
    there is never a need, and always a danger in logging directly into
    gnome as root--don't do that! always log in as yourself and "become
    root" when you must be by using a root powered app, like YaST and a file
    manager or editor as explained..

    never use gnomesu it to (say) open Firefox and go out on the web as
    root....very dangerous

    by the way, if you were using KDE the magic word is not gnomesu, but kdesu..

    more here:
    http://en.opensuse.org/SDB:Login_as_root
    http://tinyurl.com/DD-on-Root

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Problem in stalling .rpm packages

    On 06/04/2011 08:06 AM, caf4926 wrote:
    >
    > Do this as su -
    > zypper rr PK_TMP_DIR
    > Now click this
    > http://tinyurl.com/3rbxwhk


    heh, you sure make it easy! (fact is i'm gonna write that down)
    thanks for your great work..

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Problem in stalling .rpm packages

    DenverD wrote:
    > by the way, if you were using KDE the magic word is not gnomesu, but
    > kdesu..
    >

    Just to add the inf if someone wonders what to do if neither gnome nor kde
    is used:
    There is in addition a very generic command available "xdg-su". To give a
    real example
    Code:
    xdg-su -c "geany /etc/X11/xorg.conf"
    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  8. #8
    Join Date
    Jun 2011
    Location
    Delhi
    Posts
    11

    Default Re: Problem in stalling .rpm packages

    Thank you all that's really great response. I have new problem when i tried to install it it says HTTP response:502

    When software update prompted by the system and i tried to install them then also the below message comes:

    Download (curl) error for 'http://download.opensuse.org/update/11.4/rpm/i586/xorg-x11-xauth-7.6-42.3_43.44.1.i586.delta.rpm':
    Error code: HTTP response: 502
    Error message: The requested URL returned error: 502


    Please help me.

    Thanks in advance

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Problem in stalling .rpm packages

    On 06/08/2011 04:36 PM, rajasereddy wrote:
    >
    > Download (curl) error for
    > 'http://download.opensuse.org/update/11.4/rpm/i586/xorg-x11-xauth-7.6-42.3_43.44.1.i586.delta.rpm':
    > Error code: HTTP response: 502
    > Error message: The requested URL returned error: 502


    what were you trying to install when you got that error, and how were
    you trying? (with YaST, or what?)

    have you used the YaST Online Updater after your initial install, and
    have you booted since?

    if you have not, do those two things and try the above again..

    --
    dd CAVEAT: http://is.gd/bpoMD
    via NNTP openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10
    Acer Aspire One D255, 1.66 GHz Atom, 1 GB RAM, Intel Pineview graphics
    * When your gecko is broken you have a reptile dysfunction! *

  10. #10
    Join Date
    Jun 2011
    Location
    Delhi
    Posts
    11

    Default Re: Problem in stalling .rpm packages

    Thanks DenverD
    It seems there has been some network problem.

    thanks all

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •