Results 1 to 2 of 2

Thread: Some IPv6 problems

  1. #1

    Default Some IPv6 problems

    Hello,

    I have just installed Opensuse 11.4 and I have got two problems concerning my ipv6 oriented network. The network has a dual ipv4/ipv6 stack but some services are provided in ipv6 only (dns, cups, ldap), the ipv4 configuration is done by dhcp and the ipv6 configuration done by stateless auto-configuration (rfc4861).
    I have run into two problems, the first one, on reboot the main interface[1] is not setting its ipv6 according to the prefix given by the router (despite actually receiving one[2]) but an ifdown, ifup solves the problem. The second one is just a question of user experience, I have manually configured my /etc/cups/client.conf with the ipv6 of the server and everything work fine but when I'm going into the Printer configuration page of Yast, it keeps showing warning messages about the ipv6 address not being pingable (it tries in ipv4).

    How should change the boot configuration so the stateless configuration works correctly ?
    How should I disable the warnings in yast for the printer ?

    [1] ifcfg-eth0 :
    BOOTPROTO='dhcp'
    STARTMODE='nfsroot'
    NAME='Cate réseau Ethernet'
    [2] verified on the router with radvdump

  2. #2
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: Some IPv6 problems

    Maybe You'll find some hints here :
    Chapter

    Choose At Boot Time to start the device during the system boot. With On Cable Connection, the interface is watched for any existing physical connection. With On Hotplug, the interface is set as soon as available. It is similar to the At Boot Time option, and only differs in the fact that no error occurs if the interface is not present at boot time. Choose Manually to control the interface manually with ifup. Choose Never to not start the device at all. The On NFSroot is similar to At Boot Time, but the interface does not shut down with the rcnetwork stop command. Use this if you use an nfs or iscsi root file system.
    Also please check what You have configured in here :
    Code:
    /etc/sysctl.conf
    Best regards,
    Greg
    Best regards,
    Greg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •