Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Не работает микрофон после обновления с 11.3 на 11.4

  1. #1
    Join Date
    Oct 2010
    Location
    Russia, Moscow
    Posts
    74

    Default Не работает микрофон после обновления с 11.3 на 11.4

    Всем привет! Никак не могу решить проблему со звуковой картой, возникшей после обновления с 11.3 до 11.4. Самое простое - не работает микрофон. Самое сложное - периодически не работает звук (то работает, то не работает). При отключении PulseAudio в Yast и перезагрузке - работает (звук, не микрофон). После подключения PulseAudio - снова работает, потом может пропасть... Никак не получается решить проблему. А хочется пользоваться Скайпом

  2. #2
    Join Date
    Mar 2011
    Location
    Russia, Tula
    Posts
    12

    Default Re: Не работает микрофон после обновления с 11.3 на 11.4

    как вариант поставить pavucontrol и в нем включить микрофон. ибо имхо KMix + PulseAudio связка весьма извращенная

  3. #3
    Join Date
    Oct 2010
    Location
    Russia, Moscow
    Posts
    74

    Default Re: Не работает микрофон после обновления с 11.3 на 11.4

    Спасибо за ответ! Настраивал - не помогает. И еще такая проблема: при входе в KDE пишет сообщение "Устройство воспроизведения звука HDA Intel (STAC92xx Analog) не работает. Будет использоваться default." Может с драйверами что-то не так? Может какие конфиги поменять?

  4. #4
    Join Date
    Aug 2010
    Location
    Russia
    Posts
    995

    Default Re: Не работает микрофон после обновления с 11.3 на 11.4

    Quote Originally Posted by Tux-Tux View Post
    При отключении PulseAudio в Yast и перезагрузке - работает (звук, не микрофон). После подключения PulseAudio - снова работает, потом может пропасть...
    А зачем вы его обратно включаете?

  5. #5
    Join Date
    Oct 2010
    Location
    Russia, Moscow
    Posts
    74

    Default Re: Не работает микрофон после обновления с 11.3 на 11.4

    Включение / выключение звука в pulseAudio Yast, увы не помогает подключить микрофон. А снова подключаю, чтобы оставаться в рамках сборки. Проблему не нужно пытяться обходить, лучше ее решать.

  6. #6
    Join Date
    Aug 2010
    Location
    Russia
    Posts
    995

    Default Re: Не работает микрофон после обновления с 11.3 на 11.4

    Live CD 11.4 KDE пускали? Повторяется там проблема? Если нет, то дело в кривом обновлении и вероятно у вас - в единственном экземпляре.

  7. #7
    Join Date
    Oct 2010
    Location
    Russia, Moscow
    Posts
    74

    Default Re: Не работает микрофон после обновления с 11.3 на 11.4

    Спасибо за идею! Сегодня посмотрю

  8. #8
    Join Date
    Oct 2010
    Location
    Russia, Moscow
    Posts
    74

    Default Re: Не работает микрофон после обновления с 11.3 на 11.4

    После запуска LiveCD arecord записывает какие-то шумы (видимо, внутренние) но никаких звуков не записывает. Я пытался по всякому настраивать каналы Capture в alsamixer - не помогает. Забавно, что в моей Desktop версии (не LiveCD) даже тресков не слышно. Но и то и другое - не позволяет записывать звук

  9. #9

    Default Re: Не работает микрофон после обновления с 11.3 на 11.4

    Удалось сдвинуться с мертвой точки?
    По своему опыту могу сказать, что звук в Сусе очень капризная вещь. Я бы советовала обратить внимание на настройки фонона и выбрать все-таки xine-backend вместо gstremer. Это первое. Второе, в ясте все-таки выключить палс. Снести вам его корректно не удастся, вы только обрушите рабочую среду. Но если отключать палс, то нужно удалить pavucontrol. Надеюсь, что в раделе безопасность в ясте, в настройках пользователя, права доступа на звук и видео у вас есть. Затем, в терминале пишете init 3, заходите в root, и в командной строке alsaconf. После конфигурирования и перезагрузки открываете миксер, выбираете HDA SB и еще раз проверяете что там на capture. Ползунок должен быть почти на самой верхней отметке. Если есть mux и digital, то их уровень должен быть на нуле. Микрофон? Если встроенный, то mic1, если гарнитурный - line in. Обратите внимание, если вы пытаетесь их переключать, желательно релогиниться поле их переключения. Пробуйте. В принципе, врядли вы обновились уж совсем криво. Все должно работать. Если все же нельзя заставить микрофон работать, нужно пересоздать файл .asoundrc , опять перезагрузиться и проверить микрофон

  10. #10
    Join Date
    Oct 2010
    Location
    Russia, Moscow
    Posts
    74

    Default Re: Не работает микрофон после обновления с 11.3 на 11.4

    Спасибо большое! Немножко ситуация подправилась после обновления Alsa: Микрофон и звук работают. Только не нравится сообщение, выползающее в информационном окне трея: "Устройство воспроизведения звука HDA Intel (STAC92xx Analog) не работает. Будет использоваться default." Бяка какая-то

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •