Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Kernel headers not matching

  1. #1
    Join Date
    Aug 2010
    Location
    Toronto
    Posts
    24

    Default Kernel headers not matching

    Hi all,

    Just installed OpenSuse 11.4 on a laptop yesterday. Trying to compile VMware player, however my kernel headers are not matching with repo:

    Code:
    victor@linux-x5ee:~/images/backgounds/new> uname -r
    2.6.37.1-1.2-desktop
    
    victor@linux-x5ee:~/images/backgounds/new> sudo zypper update kernel-desktop-devel kernel-source kernel-syms
    Loading repository data...
    Reading installed packages...
    No update candidate for 'kernel-desktop-devel-2.6.37.6-0.5.1.i586'. The highest available version is already installed.
    No update candidate for 'kernel-source-2.6.37.6-0.5.1.noarch'. The highest available version is already installed.
    No update candidate for 'kernel-syms-2.6.37.6-0.5.1.i586'. The highest available version is already installed.
    Resolving package dependencies...
    
    Nothing to do.
    Code:
    victor@linux-x5ee:~/images/backgounds/new> ls -l /usr/src/
    total 16
    lrwxrwxrwx  1 root root   18 Jun  2 02:32 linux -> linux-2.6.37.6-0.5
    drwxr-xr-x 23 root root 4096 Jun  2 02:32 linux-2.6.37.6-0.5
    drwxr-xr-x  3 root root 4096 Jun  2 02:34 linux-2.6.37.6-0.5-obj
    drwxr-xr-x  3 root root 4096 Jun  2 02:34 linux-obj
    drwxr-xr-x  8 root root 4096 Mar  2 06:52 packages
    YaST shows 2.6.37.1.2.2 (noarch) as a possible version (screen-shot), but not 2.6.37.1-1.2. Any ideas?

    Thanks,

    Vic.
    Last edited by victorbrca; 02-Jun-2011 at 08:54. Reason: adding screen-shot

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Kernel headers not matching

    Hi
    What version of vmware player, there are multiple threads on the forum for different versions, you may also need to browse the vmware community forum and look for a patch.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Kernel headers not matching

    victorbrca wrote:
    > victor@linux-x5ee:~/images/backgounds/new> uname -r
    > 2.6.37.1-1.2-desktop

    This means you have not updated your kernel to the latest security patches
    but you installed the source for it.
    Install the security patches for your kernel and everything is in sync.
    Code:
    su -
    zypper patch
    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  4. #4
    Join Date
    Aug 2010
    Location
    Toronto
    Posts
    24

    Default Re: Kernel headers not matching

    I actually decided on changing from VMware Player to VirtualBox after some comparisson. Seems that VirtualBox has better features... But I think I'm still having issues with my kernel headers (source).

    So I ran zypper patch and rebooted. Now when trying compile another software I get the following error:

    Code:
    victor@linux-x5ee:~/Desktop/droidcam/webcam> sudo make -C /lib/modules/`uname -r`/build M=`pwd`
    make: Entering directory `/lib/modules/2.6.37.1-1.2-desktop/build'
    make: *** No targets specified and no makefile found.  Stop.
    make: Leaving directory `/lib/modules/2.6.37.1-1.2-desktop/build'
    
    victor@linux-x5ee:~/Desktop/droidcam/webcam> ltr
    total 24K
    -rw-r--r-- 1 victor users  24 Jan  8 19:12 Makefile
    -rw-r--r-- 1 victor users 17K Jan 29 13:53 droidcam_v4l.c
    Checked my modules and it seems that 2.6.37.6-0.5 desktop and default both point to my source folder, however 2.6.37.1-1.2-desktop is not there; but 2.6.37.1-1.2-desktop does exist in modules:

    Code:
    victor@linux-x5ee:/lib/modules> ls -l 2.6.37.6-0.5-desktop/
    total 0
    lrwxrwxrwx 1 root root 44 Jun  2 02:32 build -> /usr/src/linux-2.6.37.6-0.5-obj/i386/desktop
    lrwxrwxrwx 1 root root 27 Jun  2 02:32 source -> /usr/src/linux-2.6.37.6-0.5
    
    victor@linux-x5ee:/lib/modules> ls -l 2.6.37.6-0.5-default/
    total 0
    lrwxrwxrwx 1 root root 44 Jun  2 02:34 build -> /usr/src/linux-2.6.37.6-0.5-obj/i386/default
    lrwxrwxrwx 1 root root 27 Jun  2 02:34 source -> /usr/src/linux-2.6.37.6-0.5
    
    victor@linux-x5ee:/usr/src> ls -l
    total 16
    lrwxrwxrwx  1 root root   18 Jun  2 02:32 linux -> linux-2.6.37.6-0.5
    drwxr-xr-x 23 root root 4096 Jun  2 02:32 linux-2.6.37.6-0.5
    drwxr-xr-x  3 root root 4096 Jun  2 02:34 linux-2.6.37.6-0.5-obj
    drwxr-xr-x  3 root root 4096 Jun  2 02:34 linux-obj
    drwxr-xr-x  8 root root 4096 Mar  2 06:52 packages
    
    victor@linux-x5ee:/lib/modules> ls -l 2.6.37.1-1.2-desktop/
    total 2508
    drwxr-xr-x  2 root root   4096 Jun  7 18:19 build
    drwxr-xr-x 12 root root   4096 Jun  1 21:25 kernel
    -rw-r--r--  1 root root 602477 Jun  2 18:53 modules.alias
    -rw-r--r--  1 root root 580467 Jun  2 18:53 modules.alias.bin
    -rw-r--r--  1 root root   4872 Feb 22 18:49 modules.builtin
    -rw-r--r--  1 root root   6548 Jun  2 18:53 modules.builtin.bin
    -rw-r--r--  1 root root 262584 Jun  2 18:53 modules.dep
    -rw-r--r--  1 root root 392820 Jun  2 18:53 modules.dep.bin
    -rw-r--r--  1 root root    248 Jun  2 18:53 modules.devname
    -rw-r--r--  1 root root 106830 Feb 22 18:49 modules.order
    -rw-r--r--  1 root root    131 Jun  2 18:53 modules.softdep
    -rw-r--r--  1 root root 250663 Jun  2 18:53 modules.symbols
    -rw-r--r--  1 root root 310359 Jun  2 18:53 modules.symbols.bin
    drwxr-xr-x  2 root root   4096 Jun  1 21:27 systemtap
    drwxr-xr-x  2 root root   4096 Jun  2 18:53 updates
    drwxr-xr-x  2 root root   4096 Jun  1 21:25 vdso
    
    victor@linux-x5ee:/lib/modules> du -sh *
    98M	2.6.37.1-1.2-desktop
    4.0K	2.6.37.6-0.5-default
    4.0K	2.6.37.6-0.5-desktop
    4.0K	2.6.37.6-0.5-pae
    4.0K	2.6.37.6-0.5-xen
    Also confirmed that I'm indeed booting into 2.6.37.1-1.2-desktop:

    Code:
    => menu.lst
    title Desktop -- openSUSE 11.4 - 2.6.37.1-1.2
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.37.1-1.2-desktop
    Might be all over the place as I'm not very familiar with kernels... but I keep getting errors when building packages... I'm thinking there's still something wrong.

    Any feedback is more than welcome.

    Thanks!

    Vic.

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Kernel headers not matching

    victorbrca wrote:

    > Also confirmed that I'm indeed booting into 2.6.37.1-1.2-desktop:

    Why did you do that, you need to boot into the current kernel 2.6.37.6-0.5?

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  6. #6
    Join Date
    Aug 2010
    Location
    Toronto
    Posts
    24

    Default Re: Kernel headers not matching

    I didn't... I've been booting into this kernel since my first post:

    Code:
    victor@linux-x5ee:~/images/backgounds/new> uname -r
    2.6.37.1-1.2-desktop

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Kernel headers not matching

    Please post result of

    Code:
    zypper lr -d
    and
    Code:
    su -
    zypper lu
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Aug 2010
    Location
    Toronto
    Posts
    24

    Default Re: Kernel headers not matching

    Here it is:

    Code:
    victor@linux-x5ee:~> zypper lr -d
    #  | Alias                            | Name                             | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service
    ---+----------------------------------+----------------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
     1 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/                                           |        
     2 | X11:wxWidgets:debug              | X11:wxWidgets:debug              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/wxWidgets:/debug/openSUSE_11.4/      |        
     3 | google-chrome                    | google-chrome                    | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386                                   |        
     4 | openSUSE-11.4-11.4-0             | openSUSE-11.4-11.4-0             | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-SONY_CD-RW_DVD-ROM_CRX880A,/dev/sr0              |        
     5 | openSUSE:Factory:Contrib         | openSUSE:Factory:Contrib         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_11.4/ |        
     6 | packman                          | packman                          | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_11.4                                          |        
     7 | repo-debug                       | openSUSE-11.4-Debug              | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.4/repo/oss/                      |        
     8 | repo-debug-update                | openSUSE-11.4-Update-Debug       | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/11.4/                                     |        
     9 | repo-non-oss                     | openSUSE-11.4-Non-Oss            | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                        |        
    10 | repo-oss                         | openSUSE-11.4-Oss                | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                            |        
    11 | repo-source                      | openSUSE-11.4-Source             | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.4/repo/oss/                     |

    Code:
    victor@linux-x5ee:~> sudo zypper lu
    root's password:
    Loading repository data...
    Reading installed packages...
    No updates found.

    Thanks!

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Kernel headers not matching

    OK
    Now the following

    Code:
    rpm -qa | grep kernel
    Code:
    su -
    cat /boot/grub/menu.lst
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Aug 2010
    Location
    Toronto
    Posts
    24

    Default Re: Kernel headers not matching

    Got it:

    Code:
    victor@linux-x5ee:~> rpm -qa | grep kernel
    kernel-syms-2.6.37.6-0.5.1.i586
    kernel-pae-devel-2.6.37.6-0.5.1.i586
    kernel-xen-devel-2.6.37.6-0.5.1.i586
    kernel-desktop-devel-2.6.37.6-0.5.1.i586
    kernel-default-devel-2.6.37.6-0.5.1.i586
    kernel-devel-2.6.37.6-0.5.1.noarch
    kernel-desktop-2.6.37.6-0.5.1.i586
    kernel-source-2.6.37.6-0.5.1.noarch
    Now it seems that since the update I did yesterday I'm now using "2.6.37.6-0.5"...

    Code:
    victor@linux-x5ee:~> uname -r
    2.6.37.6-0.5-desktop
    Code:
    linux-x5ee:~ # cat /boot/grub/menu.lst
    # Modified by YaST2. Last modification on Tue Jun  7 20:09:59 EDT 2011
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader
    
    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,0)/boot/message
    ##YaST - activate
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 11.4 - 2.6.37.6-0.5
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.37.6-0.5-desktop root=/dev/disk/by-id/ata-WDC_WD5000BEVT-24A0RT0_WD-WXR1EB0ASVD6-part1 resume=/dev/disk/by-id/ata-WDC_WD5000BEVT-24A0RT0_WD-WXR1EB0ASVD6-part2 splash=silent quiet showopts vga=0x317
        initrd /boot/initrd-2.6.37.6-0.5-desktop
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.4 - 2.6.37.6-0.5
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.37.6-0.5-desktop root=/dev/disk/by-id/ata-WDC_WD5000BEVT-24A0RT0_WD-WXR1EB0ASVD6-part1 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317
        initrd /boot/initrd-2.6.37.6-0.5-desktop
    
    ###Don't change this comment - YaST2 identifier: Original name: floppy###
    title Floppy
        rootnoverify (fd0)
        chainloader +1

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •