Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Samba set up : nmb is not starting

  1. #1
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    576

    Question Samba set up : nmb is not starting

    Hi

    hi, i'm trying to set up samba but i can't start the nmb service in yast, neither from konsole .
    Do you know what can stop this service ?
    How can i start it ?
    Thanks

    # rcnmb status
    Checking for Samba NMB daemon unused
    linux-hrm6:~ # rcnmb start
    Starting Samba NMB daemon startproc: exit status of parent of /usr/sbin/nmbd: 1
    failed


    ** edit** :
    thanks to the irc chan i saw there's a bug in app armor so # rcapparmor stop is needed before starting nmb ( # rcnmb start )
    openSUSE Leap 15.3 , KDE Plasma

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Samba set up : nmb is not starting

    Message #8 here mentions a fix:

    Samba broken after update to 11.4 (64-bits)

    I might also add that I have found that upgrading the kernel to 2.6.38 or 39 also works without any other modifications.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Samba set up : nmb is not starting

    IMO better to do this (below), keeping AppArmor mostly enabled, except for Samba. You use the GUI with this workaround:

    Yast -> Novell AppArmor -> AppArmor Control Panel,

    Click on Set profile modes (Configure) button,

    Highlight the entries 'usr.sbin.nmbd' and 'usr.sbin.smbd' in turn and, for each, click the Toggle Mode button to set the mode from 'enforce' to 'complain'.

    Click Done, OK etc etc.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  4. #4
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    576

    Question Re: Samba set up : nmb is not starting

    hello
    what does it mean complain instead of enforce in app armor ?

    I had nmb and smb activated , but after reboot they are not anymore.
    How do i activate them at each boot ?

    Thanks
    openSUSE Leap 15.3 , KDE Plasma

  5. #5
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: Samba set up : nmb is not starting

    Quote Originally Posted by manchette_fr View Post
    hello
    what does it mean complain instead of enforce in app armor ?

    I had nmb and smb activated , but after reboot they are not anymore.
    How do i activate them at each boot ?

    Thanks
    Complain mode does not block anything but writes to log about operations that violate the profile. When enforce mode is on every attempt that was logged using complain mode would be blocked by AppArmor.

    Best regards,
    Greg
    Best regards,
    Greg

  6. #6
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    576

    Default Re: Samba set up : nmb is not starting

    ok, about app armor modes.


    Then after a reboot i have rcnmb still running but rcsmb is not anymore .

    How can i set up so that both are still running ?
    openSUSE Leap 15.3 , KDE Plasma

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Samba set up : nmb is not starting

    Quote Originally Posted by manchette_fr View Post
    ok, about app armor modes.


    Then after a reboot i have rcnmb still running but rcsmb is not anymore .

    How can i set up so that both are still running ?
    goto --> Yast --> system --> runlevels --> find nmb and smb (one at a time) and make sure they are both toggled to "on"
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  8. #8
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    576

    Default Re: Samba set up : nmb is not starting

    i did and it's on for both, but after reboot i now have :
    # rcnmb status
    Checking for Samba NMB daemon running
    linux-hrm6:~ # rcsmb status
    Checking for Samba SMB daemon unused
    openSUSE Leap 15.3 , KDE Plasma

  9. #9
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Samba set up : nmb is not starting

    Quote Originally Posted by manchette_fr View Post
    i did and it's on for both, but after reboot i now have :
    # rcnmb status
    Checking for Samba NMB daemon running
    linux-hrm6:~ # rcsmb status
    Checking for Samba SMB daemon unused
    It looks very much as if, when you went into Yast / AppArmor, you did not correctly toggle and save the setting of usr.sbin.smbd to be "complain". (and the other one nmbd I suppose, to be thorough, although smbd is the one that's important)
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  10. #10
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    576

    Default Re: Samba set up : nmb is not starting

    Right, i had thicked ntpd it seems, so i set it back to enforce and then smb and ntp to complain + on in runlevels.
    Now after reboot both stay in running state.
    How come app armor is now needed when it was not before ?


    Now i have other questions :

    - i can use konqueror but dolphin crashes and can't acces to the seven pc next by (when konqueror is able to). How come ? (just retried and now dolphin finally asks for id/pwd which gives and ok result and access to 7 ).

    - Also 7 sees my fujitsu suse machine but can't access it , how come ?
    openSUSE Leap 15.3 , KDE Plasma

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •