Results 1 to 3 of 3

Thread: Disable automatic configuration at bootup

  1. #1
    Join Date
    Jun 2011
    Location
    Broadway, UK
    Posts
    38

    Default Disable automatic configuration at bootup

    Isn't progress wonderful ... things we have been doing for years no longer work because you could not actually be doing that
    OK I'm probably a dinosaur in that I like real hardware, so all of the kit is sitting out in the workshop and the KVM switch allows me to switch over between Windows and Linux boxes configured for different jobs and running specific hardware configurations for testing things.
    I'm sure people an see the problem already ... the KVM switches ( dual screen on a few boxes! ) totally confuse things if I need to reboot. On 11.3 I was able to get around things with a little xrandr scripting which one runs manually after the initial boot-up, and 1920x1200 on both screens then works fine (nvidia graphics cards).
    I've got the box I'm currently upgrading to 11.4 sitting at the side here having stripped it out of the rack, an everything is up fine ... so I THOUGHT 'nomodeset' told things to use the saved settings? But what ever I do, moving the machine back to the rack I can't get THIS setup to return ... even with the 11.3 script trick. Being a hardware engineer I know what I want to do and this is working on 11.3 ...
    SO ... what is now needed with 11.4 to get it to allow one to manually configure the graphics? Apart from lugging a monitor out and hard wiring before a reboot ... which is which I am just about to try but am suspicious that SOMETHING will complain later once the KVM is plugged in instead.

  2. #2
    Will Honea NNTP User

    Default Re: Disable automatic configuration at bootup

    lsces wrote:

    >
    > Isn't progress wonderful ... things we have been doing for years no
    > longer work because you could not actually be doing that
    > OK I'm probably a dinosaur in that I like real hardware, so all of the
    > kit is sitting out in the workshop and the KVM switch allows me to
    > switch over between Windows and Linux boxes configured for different
    > jobs and running specific hardware configurations for testing things.
    > I'm sure people an see the problem already ... the KVM switches ( dual
    > screen on a few boxes! ) totally confuse things if I need to reboot. On
    > 11.3 I was able to get around things with a little xrandr scripting
    > which one runs manually after the initial boot-up, and 1920x1200 on both
    > screens then works fine (nvidia graphics cards).
    > I've got the box I'm currently upgrading to 11.4 sitting at the side
    > here having stripped it out of the rack, an everything is up fine ... so
    > I THOUGHT 'nomodeset' told things to use the saved settings? But what
    > ever I do, moving the machine back to the rack I can't get THIS setup to
    > return ... even with the 11.3 script trick. Being a hardware engineer I
    > know what I want to do and this is working on 11.3 ...
    > SO ... what is now needed with 11.4 to get it to allow one to manually
    > configure the graphics? Apart from lugging a monitor out and hard wiring
    > before a reboot ... which is which I am just about to try but am
    > suspicious that SOMETHING will complain later once the KVM is plugged in
    > instead.


    Do you also have NO_KMS_IN_INITRD set to "yes"? Not sure if it helps - if I
    boot up the test system blind (without switching the kvm to where it can see
    the hardware) I wind up with one FUBAR system - it still wants to see a
    mouse, keyboard, and video. I also had problems with the video cable
    between the kvm and system. Seems to be misssing a signal wire and a new
    cable fixed that.

    --
    Will Honea

  3. #3

    Default Re: Disable automatic configuration at bootup

    Not sure if it helps but did you look in /etc/X11/xorg.conf.d/ ? Maybe possible to overwrite it there ? or maybe a custom xorg.conf although not sure if they still accepted.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •