Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Suse 10.3 naar 11.4

  1. #1

    Post Suse 10.3 naar 11.4

    Ik heb een oude Pc:
    IBM, type: Netvista A22p
    CPU: P IV met een snelheid van 1.6 Ghz
    Geheugen 1.2 Gb
    Een GForce fx 5200 grafische kaart
    Daar heb ik een 80 Gb harde schijf in zitten

    Hier heeft jarenlang Suse 10.3 naar volle tevredenheid op gedraaid.
    Ik gebruik het systeem voornamelijk voor backups en voor het vastleggen van wachtwoorden en favorieten. Het systeem staat dus ook meestal uit maar bij probleemoplossingen verleent het mij nog goede diensten.

    Ik wil het systeem upgrade naar de nieuwste versie, Suse 11.4.
    Heb geen upgrade uitgevoerd maar gewoon een volledige nieuwe installatie!
    Met een Ubuntu live cd de partities van de schijf verwijderd. Daarna de installatie dvd van Suse er in!
    De installatie verliep normaal. Na een reboot kon ik me normaal aanmelden.
    De problemen begonnen nadat ik de volledige update heb gedraaid.

    Na het opstarten komt Grub-menu nog normaal tevoorschijn. Bij een normale start blijft het scherm direct hangen.
    Bij een start met failsafe loopt de opstartprocedure door en draait het systeem normaal.

    Wie kan mij een suggestie geven om de machine weer normaal te laten opstarten?
    Kan ik een opstart fout-log vinden?

  2. #2
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: Suse 10.3 naar 11.4

    Hoi,

    Welke opties heb je met het opstarten? Zijn er meerdere openSUSE opties beschikbaar als alleen openSUSE en openSUSE Failsafe?

    Je zou kunnen proberen om te kijken of het opstarten lukt met de acpi=off optie. Die voeg je toe door even met de pijltjes toetsen op en neer te gaan zodat je tijd stopt en vervolgens je normale openSUSE optie selecteert. Type dan het volgende in en druk dan op ENTER om het op te starten

    Code:
    acpi=off
    Dit verschijnt als het goed is in de optie balk tijdens het typen. Probeer dat eens.
    "To err is human... to really foul up requires the root password."

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: Suse 10.3 naar 11.4

    Ook proberen met de parameter nomodeset. in de bootregel (één test tegelijk doen svp). Als dat "helpt" kun je beter de NVIDIA driver installeren (en dan weer zonder nomodeset draaien).
    Henk van Velden

  4. #4

    Default Re: Suse 10.3 naar 11.4

    Dexter,

    Bedankt voor je snelle reactie.

    Opstartopties:


    Ik heb inderdaad maar twee opstartopties, te weten de:
    OpenSuse
    Failsafe OpenSuse

    De optie acpi=off toevoegen bij de opstartoptie werkt inderdaad.

    Heb deze optie direct via Yast->Systeem->Bootloader aan de "Optionele kernelparameter voor de comandoregel" toegevoegd.
    Nu start het systeem direct weer op.
    EUREKA

    Nieuw probleempje
    Helaas het systeem sluit zich niet helemaal meer af!
    Ik sluit het systeem af. Tijdens het afsluiten druk op de escape toets, zodoende worden de uitgevoerde commando's weergegeven. De laatste melding is " The systeem will be halted immediately". Maar het systeem blijft gewoon draaien. Met de uitknop kan ik het systeem dan gewoon uitzetten.
    Is hier ook een foefje voor?

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: Suse 10.3 naar 11.4

    Volgens mij is dat het gevolg van die aspi=off. Volgens mij is dat dan ook een by-pass en geen eindoplossing.

    Ook in dit geval raad ik je aan om de nVIDIA driver te installeren en daarna te kijken of het zonder die acpi=off werkt.

    YaST > Software > Softwarebronnen; dan linksonder Toevoegen; kies Installatiebronnen van de gemeenschap en Verder; zoek nVidia graphics drivers en slecteer hett hokje en Verder.

    NU YaST > Software > Softwarebeeheer; waarschijnlijk wordt nu al gelijk voorgesteld om de juiste nViIDIA driver te installeren. Doe dat en in dit geval belangrijk: reboot.

    Als die reboot goed gaat, probeer dan weer een reboot na verwijderen van de acpi=off.

    Meld svp even terug hoe het gegaan is. Dat vinden wij interessant.
    Henk van Velden

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Suse 10.3 naar 11.4

    Ik ga met Henk mee. Denk dat het niet uitgaan komt door de acpi=off, sterker nog, ik beheer PC's (exotische zelfbouwers van een jaar of 6 oud) die dit ook vertonen. Met 11.3 en acpi=off deden ze het juist niet goed zonder deze optie, dus bij installatie van 11.4 niet afgewacht maar meteen doorgevoerd. Ook deze PC's hebben FX5200 kaarten. Onder 11.4 hadden ze 'nomodeset' nodig, zonder geen X.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: Suse 10.3 naar 11.4

    Heeft een graphische kaart daar zoveel invloed op? Ik had verwacht dat je dan tenminste nog in Run Level 3 kon komen en niet meteen alles op zwart had.. weer wat geleerd!
    "To err is human... to really foul up requires the root password."

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: Suse 10.3 naar 11.4

    Ik heb hier hetzelfde gehad met een GeForce 7300 LE. Volgens mij niet zo oud. Na installatie 11.4 werkte het eerst (hoewel het beeld op het scherm wat verschoven was. Ik heb aan die verschuiving niets gedaan omdat ik over wilde stappen op de nVIDIA driver (zoals ik daarvoor ook altijd had). Na één of andere update was er alleen met nomodeset te booten. Scherm wordt inderdaad zwart voor dat je zelfs maar kunt denken aan het gebruik van Esc. En alles hangt dan.

    Ik heb toen de nVIDIA driver geïnstalleerd (dat was toch al de bedoeling) en alles is weer OK. Ook het beeld staat weer op zijn plek.

    Edit: @Dexter1979. Ik gok dat het bij het laden van de driver module in de kernel al fout gaat. De kernel komt dan zelfs niet eens echt tot leven. Het init proces start dus nog lang niet en het kiezen van het runlevel is nog ver weg.
    Henk van Velden

  9. #9

    Default Re: Suse 10.3 naar 11.4

    Quote Originally Posted by hcvv View Post
    YaST > Software > Softwarebronnen; dan linksonder Toevoegen; kies Installatiebronnen van de gemeenschap en Verder; zoek nVidia graphics drivers en slecteer hett hokje en Verder.
    Hier gaat het mis!
    Het opgegeven pad bestaat niet! De host of de map is niet aanwezig!
    Heb op het net naar nVidia-fx5xxx.ymp gezocht. Deze gedraaid en krijg dan weer de melding :
    Unknow error reading from" ftp//download.nvidia.com/opensuse/11.4"

    Volgens mij zijn de drivers op dit adres niet beschikbaar.
    Misschien gaat het hier tijdens de update ook wel mis.
    Kan ik de video drivers ergens anders vandaan halen?

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: Suse 10.3 naar 11.4

    Wacht even. "Het gaat mis" is geen goede probleemomschrijving. Wanneer "gaat het mis"? Bij het toeveogen van de repo?
    Geef de uitvoer van
    Code:
    zypper lr -d
    De rest van je verhaal is mij totaal onduidelijk.
    Henk van Velden

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •