Results 1 to 8 of 8

Thread: ifconfig eth0 RX dropped counters since 11.4

  1. #1

    Default ifconfig eth0 RX dropped counters since 11.4

    Hello.

    I have been noticing a trend on boxes running 11.4 getting RX dropped packets where prior to 11.4 they did not get them. Basically every box running 11.4 now logs dropped RX packets.

    Have tried changing cables, and in one case replaced the NIC with a different brand (and driver) nic. Also played with receive buffers and yet the counters still increment.

    In addition to OpenSUSE, I run several operating systems to include Centos, Scientific Linux, Debian, OpenIndiana, HP-UX, VMS and so forth. So far this anomaly has only shown up on machines running OpenSUSE 11.4.

    Any one else noticing this on your OS 11.4 machines? If so, were you able to resolve?

    Thanks.



    Standalone box;

    # uname -r
    2.6.37.6-0.5-default

    # ifconfig eth0
    eth0 Link encap:Ethernet HWaddr XXXXXXXXXXXX
    inet addr:10.1.1.95 Bcast:10.1.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:124410250 errors:0 dropped:18239 overruns:0 frame:0
    TX packets:84458669 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2621086251 (2499.6 Mb) TX bytes:2033060890 (1938.8 Mb)

    # ethtool eth0
    Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: umbg
    Wake-on: g
    Current message level: 0x00000007 (7)
    Link detected: yes


    Here are the adjusted settings in use, appears to have no affect.

    net.ipv4.icmp_echo_ignore_broadcasts = 1
    net.ipv4.conf.all.rp_filter = 1
    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv4.conf.default.promote_secondaries = 1
    net.ipv4.conf.all.promote_secondaries = 1
    net.core.netdev_max_backlog = 5000
    net.ipv4.tcp_mem= 8388608 8388608 8388608
    net.core.rmem_max=8388608
    net.core.wmem_max=8388608
    net.core.rmem_default=65536
    net.core.wmem_default=65536
    net.ipv4.tcp_rmem= 4096 87380 8388608
    net.ipv4.tcp_wmem= 4096 65536 8388608
    net.ipv4.tcp_mem= 8388608 8388608 8388608



    This is a VM with in an ESXi server;

    # uname -r
    2.6.37.6-0.5-default

    # ifconfig eth0
    eth0 Link encap:Ethernet HWaddr XXXXXXXXXXXX
    inet addr:10.1.1.101 Bcast:10.1.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:925192 errors:0 dropped:36243 overruns:0 frame:0
    TX packets:195050 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:246745224 (235.3 Mb) TX bytes:32814184 (31.2 Mb)



    # ethtool eth0
    Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: Unknown
    Supports Wake-on: d
    Wake-on: d
    Current message level: 0x00000007 (7)
    drv probe link
    Link detected: yes




    Here is a completely different standalone box (Proliant) at a remote site so a different network is in play.

    # uname -r
    2.6.37.6-0.5-default

    # ifconfig eth0
    eth0 Link encap:Ethernet HWaddr XXXXXXXXXXXX
    inet addr:192.168.1.59 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::20b:cdff:feee:3ca1/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:16061054 errors:0 dropped:3273597 overruns:0 frame:0
    TX packets:10103493 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:14859592310 (14171.2 Mb) TX bytes:6996795183 (6672.6 Mb)
    Interrupt:29

    # ethtool eth0
    Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Half 1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Half 1000baseT/Full
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: Unknown
    Supports Wake-on: g
    Wake-on: g
    Current message level: 0x000000ff (255)
    drv probe link timer ifdown ifup rx_err tx_err
    Link detected: yes

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: ifconfig eth0 RX dropped counters since 11.4

    I might suggest you consider upgrading the kernel to 2.6.38 or 39 and see if that might make any difference. I have loaded 2.6.39 and I have no RX issues. Here is a link for a bash compiler you can use:

    S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.00 - Page 7

    Check message #62 for more details.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: ifconfig eth0 RX dropped counters since 11.4

    I think I have the same problem :
    Very strange ifconfig statistics for eth0 with 2.6.37.2-1-desktop kernel

    The most funny thing is that I get those stats with cable disconected altoghether

    It was not present in openSUSE 11.3 but didn't have the time to report the bug yet against 11.4. As jdmcdaniel3 already sugested I think the problem lies in the kernel. I'm not bothered by this one because I almost exclusively use wireless which seems to be not affected by this bug.

    Best regards,
    Greg
    Best regards,
    Greg

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,671
    Blog Entries
    3

    Default Re: ifconfig eth0 RX dropped counters since 11.4

    Quote Originally Posted by glistwan View Post
    I think I have the same problem :
    That older post of yours looked like a counter that was not being properly initialized. I don't think that's the same problem as is being raised in this thread.

    In the meantime, just short of one day since I rebooted, my eth0 counts are still at 0
    Code:
              RX packets:178335 errors:0 dropped:0 overruns:0 frame:0
              TX packets:133673 errors:0 dropped:0 overruns:0 carrier:0
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: ifconfig eth0 RX dropped counters since 11.4

    On a host with an uptime of 18 days and openSUSE-11.4 i586 I can't see this.

    Code:
    eth0      Link encap:Ethernet  HWaddr 20:CF:30:A0:1A:34  
              inet addr:192.168.41.14  Bcast:192.168.41.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:38461913 errors:0 dropped:0 overruns:0 frame:0
              TX packets:15824095 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:271121572 (258.5 Mb)  TX bytes:1195657518 (1140.2 Mb)
              Interrupt:31 Base address:0x8000
    The kernel is: 2.6.34.8-0.2-desktop

    NIC:

    Code:
    02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
            Subsystem: ASUSTeK Computer Inc. M4A785TD Motherboard [1043:83a3]
            Kernel driver in use: r8169
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  6. #6
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: ifconfig eth0 RX dropped counters since 11.4

    Sorry about post #5, please disregard. That was actually 11.3 and not 11.4. I try again:

    Code:
    eth1      Link encap:Ethernet  Hardware Adresse 00:1C:C0:87:C9:DC  
              inet Adresse:192.168.100.80  Bcast:192.168.100.255  Maske:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:49765 errors:0 dropped:0 overruns:0 frame:0
              TX packets:32696 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 Sendewarteschlangenlänge:1000 
              RX bytes:57175751 (54.5 Mb)  TX bytes:3928497 (3.7 Mb)
              Interrupt:44 Basisadresse:0xe000
    Kernel 2.6.37.1-1.2-desktop
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  7. #7

    Default Re: ifconfig eth0 RX dropped counters since 11.4

    Went ahead and updated the kernel on one VM I could trash and rebooted;

    # uname -r
    2.6.39-2-default

    The dropped counter field is still incrementing.

    # ifconfig eth0 | grep RX | grep drop
    RX packets:1465 errors:0 dropped:23 overruns:0 frame:0

    It seems the counter is not incrementing for others at 11.4, so this might be something on these two networks that are not playing together well that only 11.4 is noticing. I'll do some more digging.

    Thank you for the information and ideas.

  8. #8

    Default Re: ifconfig eth0 RX dropped counters since 11.4

    Does anything relevant show up with a search of the logs?
    Software is like sex: it's better when it's free. --Linus Torvalds

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •