Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: partitions are not being auto mounted on start up

  1. #11
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: partitions are not being auto mounted on start up

    sorry guys i can't check your replies until 22.00(GMT +5.30)
    Quote Originally Posted by glistwan View Post
    Ok in order to have a partition auto mounted You need to have and fstab entry for each partition You want to mount at boot. Here's a quick tutorial on how to do that :
    FSTAB - Editing Manually

    After editing /etc/fstab You can test by issuing the following command as root :
    Code:
    mount -a
    If the partition You want to mount on boot will mount after the mount -a command it means your fstab entries are fine and from now on at each boot the partitions will be mounted.

    Best regards,
    Greg
    Glistwan first step fails

    see the following
    Code:
    linux-vd9i:/home/vicky # kdesu kwrite /etc/fstab
    kdesu(2972): Session bus not found 
    To circumvent this problem try the following command (with Linux and bash) 
    export $(dbus-launch) 
    
    KCrash: Application 'kdesu' crashing...
    KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
    sock_file=/root/.kde4/socket-linux-vd9i.site/kdeinit4__0
    Warning: connect() failed: : No such file or directory
    KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi directly
    drkonqi(2973): Session bus not found 
    To circumvent this problem try the following command (with Linux and bash) 
    export $(dbus-launch)

  2. #12
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: partitions are not being auto mounted on start up

    Quote Originally Posted by glistwan View Post

    After editing /etc/fstab You can test by issuing the following command as root :
    Code:
    mount -a
    If the partition You want to mount on boot will mount after the mount -a command it means your fstab entries are fine and from now on at each boot the partitions will be mounted.

    Best regards,
    Greg
    can i mount only one partition on boot?i have five partition i want to mount all(five) partitions on boot

  3. #13
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,748

    Default Re: partitions are not being auto mounted on start up

    You can enter as many file systems in your fstab as you need. Did you read the basic documentation a pointed to?

    Did you go to YaST > System > Partinioner and didn't you see al of your partitions there? It isn't that difficult.
    Henk van Velden

  4. #14
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: partitions are not being auto mounted on start up

    Quote Originally Posted by JohnVV View Post
    vike4 just off hand why all the fat partitions (exFAT)
    i have not seen that many since win 98 and have not seen a fat16 since ?? a long time
    John all the five partitions are ntfs.

    Quote Originally Posted by JohnVV View Post
    You might want to have the MS windows partitions need root access to write to
    It might be possible to install a MS virus through Linux if the NORMAL account has read/write to the NTFS drives
    I do not know of a virus or malware that dose this YET
    But, better safe than sorry .

    read -- everyone
    write -- root only
    what are you trying to say?i can't understand this.

  5. #15
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: partitions are not being auto mounted on start up

    Quote Originally Posted by hcvv View Post
    You can enter as many file systems in your fstab as you need. Did you read the basic documentation a pointed to?

    Did you go to YaST > System > Partinioner and didn't you see al of your partitions there? It isn't that difficult.
    Wait Henk now i am reading your guide.i can see all partitions but i don't know what to do next?

  6. #16
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,748

    Default Re: partitions are not being auto mounted on start up

    Are you in YaST > System > Partiioning? Right click on one of the partitions you want to be mounted and choose Edit. Then, when you have questions on what to do there come back.
    Henk van Velden

  7. #17
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: partitions are not being auto mounted on start up

    Quote Originally Posted by hcvv View Post
    Are you in YaST > System > Partiioning? Right click on one of the partitions you want to be mounted and choose Edit. Then, when you have questions on what to do there come back.
    Henk i got a pop up window i clicked at fstab options following image i got



    what to do next?

  8. #18
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,748

    Default Re: partitions are not being auto mounted on start up

    Simple enough.

    The upper part says "Do not format partition" and that is OK of course, formatting would overwrite all data and that is not what you want.

    The lower part suggest you a mount point. It is a suggestion. When you have read the "Basics about ..." you know that it is you who decides where to mount it. And you know what is on it and where you use it for. Thus e.g. when it contains your music, I would mount it on /home/vike4/mymusic (whenvike4 is your username on the system, else adapt). It is only you that can decide where all five file systems should go.
    After you changed the mount point text to your liking, click finish. Then you come back to th main Partitioner screen where you also click Finish.

    Then go to the mount point (e.g. with Dolphin and look if everything is there.

    You can of course do the other four without every time doing the last Finish, but we do now one only for the first time to get the feeling.

    After you have finished look in /etc/fstab to see what YaST did to it (you can post when you like). You could have done that by an editor also of course (this is suggested by others above), but using YaST as newcomer is also OK.
    Henk van Velden

  9. #19
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: partitions are not being auto mounted on start up

    all okay Henk i replaced the mount points of the partitions to /home/username/xxx(here xxx is the name of the label of my desired partition).but after a restart all falls back to default.i think i should select device path in the fstab options in the following image isn't it?


  10. #20
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,927

    Default Re: partitions are not being auto mounted on start up

    Quote Originally Posted by vike4 View Post
    sorry guys i can't check your replies until 22.00(GMT +5.30)


    Glistwan first step fails

    see the following
    Code:
    linux-vd9i:/home/vicky # kdesu kwrite /etc/fstab
    kdesu(2972): Session bus not found 
    To circumvent this problem try the following command (with Linux and bash) 
    export $(dbus-launch) 
    
    KCrash: Application 'kdesu' crashing...
    KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
    sock_file=/root/.kde4/socket-linux-vd9i.site/kdeinit4__0
    Warning: connect() failed: : No such file or directory
    KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi directly
    drkonqi(2973): Session bus not found 
    To circumvent this problem try the following command (with Linux and bash) 
    export $(dbus-launch)
    Are You using KDE or GNOME or some other desktop environment ?
    You can always become root "su -" and than use "vi /etc/fstab" but I'm not sure if You know how to operate vi (it can be tricky at first). Basicaly You can use any text editor with root privilages to edit /etc/fstab so choose your favourite one

    Best regards,
    Greg
    Best regards,
    Greg

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •