Results 1 to 7 of 7

Thread: HELP WANTED! Maintenance: Improving the updater

  1. #1

    Exclamation HELP WANTED! Maintenance: Improving the updater

    Hi everyone.

    PackageKit went out with some bugs in the code that connects with our underlying package manager and this has been creating trouble for some users.

    The main bug we want to solve is a crash when checking for updates. You may ask yourself how are we going to update this if the updater crashes, but the updater will show only the updater related patches first if they are present.

    • Bug #685831: zypp: occasional crashes of packagekitd


    The simplest way to see if you are affected by this bug is to run:

    Code:
    pkcon get-updates
    You should see a message that the daemon crashes.

    NOTE: this bug does not affect zypper. Only the desktop tools that access the updates via PackageKit.

    The code has a bunch of changes, therefore we are looking for advanced users and enthusiasts who can help us testing it

    How to help

    Add the update-test repository to your system:

    Code:
    zypper ar http://download.opensuse.org/update/11.4-test/ update-test
    killall packagekitd
    Now open your KDE or GNOME update tool (gpk-update-viewer or kpackagekit) and you should see only one patch. After installing this patch, the updater should not crash anymore.

    We are tracking also other bugs which may go or not in this update. The symptoms are:

    • Proxy problems (especially under KDE4)
    • A bug when installing local/remote rpms by clicking on them, when the filename has the form name.rpm (instead of name-x.y.arch.rpm). Crash may happen.


    Also we are interested in you comparing how running zypper in between changes. There were some changes in the code that allows zypper to shutdown packagekit if it is running, and this could improve the situation.

    Thanks a lot for your help.

    If you can translate this message to other forums that would be great. I can take care of the spanish one only.

  2. #2
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: HELP WANTED! Maintenance: Improving the updater

    Thanks for the information. I've just installed the patch and don't see any problems at the moment.

    Best regards,
    Greg
    Best regards,
    Greg

  3. #3
    Join Date
    Jun 2008
    Location
    Valladolid-Europe
    Posts
    5

    Talking Re: HELP WANTED! Maintenance: Improving the updater

    My system was not affected by this bug, but I updated to test the update package.

    After installing the patch, and performing system update (some packages), kpackagekit takes too much time to generate the package list (about 1hour right now)...

    I assume this behavior is not correct, as it has been performing such task for about an hour. I have 17 repos activated right now (including test one), and zypper/packagekit has never taken so long to do that operation (I haven't explored the repo, but I think it won't contain more packages than other community repos).

    Thanks, and I will stay tuned, just in case you need further information (logs, etc.). I use openSUSE 11.4, x86_64 version, with KDE 4.6

    Regards

  4. #4
    Join Date
    Apr 2011
    Location
    PA, USA
    Posts
    13

    Default Re: HELP WANTED! Maintenance: Improving the updater

    Hi,
    I tested and have the error. I was able to add the test repository. Ran the update but came up with two packages, your test package and a second package that has been failing on me. Package kit update 0.6.14 various bug fixes. The only way I can get an update to run is to uncheck this.
    I am not sure if it is the error you are looking for or not.
    I am running gnome 3.0 on OpenSUSE 11.4
    Hope this helped.

  5. #5

    Default Re: HELP WANTED! Maintenance: Improving the updater

    Quote Originally Posted by davmont View Post
    My system was not affected by this bug, but I updated to test the update package.

    After installing the patch, and performing system update (some packages), kpackagekit takes too much time to generate the package list (about 1hour right now)...

    I assume this behavior is not correct, as it has been performing such task for about an hour. I have 17 repos activated right now (including test one), and zypper/packagekit has never taken so long to do that operation (I haven't explored the repo, but I think it won't contain more packages than other community repos).

    Thanks, and I will stay tuned, just in case you need further information (logs, etc.). I use openSUSE 11.4, x86_64 version, with KDE 4.6

    Regards
    Yes, I would be interested in the activity in /var/log/pk_backend_zypp when kpackagekit is checking.

  6. #6

    Default Re: HELP WANTED! Maintenance: Improving the updater

    If you are running GNOME 3.0 then you have the update already.

  7. #7
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: HELP WANTED! Maintenance: Improving the updater

    One more observation. When I run kpackagekit from the terminal I get the following errors. Don't know if it's the intended behavior
    Code:
    ~> kpackagekit 
    ~> Application asked to unregister timer 0x77000008 which is not registered in this thread. Fix application.
    Application asked to unregister timer 0x7200000c which is not registered in this thread. Fix application.
    Nevertheless it seems to be working properly.

    Possibly useful piece of information :

    Code:
    ~> kpackagekit --version
    Qt: 4.7.3
    KDE: 4.6.3 (4.6.3) "release 4"
    KPackageKit: 0.6.3.3
    Best regards,
    Greg
    Best regards,
    Greg

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •