Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: PRoblem with Nexuiz

  1. #1
    Join Date
    May 2011
    Location
    Mt. Hood, OR
    Posts
    4

    Default PRoblem with Nexuiz

    Hello, I am new to Linux (and completely loving the challenge of figuring out a new OS, linux is rad). I switched over from Windows because, well, I got tired of it to be honest. I have found nothing but great support from the SUSE community, so a big thank you to the entire community.

    I am having some trouble with the Nexuiz game, I installed the game everything went fine with no errors but when I click on the program I get a black screen with a pointer and nothing else happens. I thought it to be a driver issue but after talking with some people in the IRC channel we figured everything was right, here is my hwinfo output:

    27: PCI 105.0: 0300 VGA compatible controller (VGA)
    [Created at pci.318]
    Unique ID: ul7N.TjRhdNXN4mD
    Parent ID: vSkL.Hs1ugs2O8z1
    SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.0
    SysFS BusID: 0000:01:05.0
    Hardware Class: graphics card
    Model: "ATI Mobility Radeon HD Graphics"
    Vendor: pci 0x1002 "ATI Technologies Inc"
    Device: pci 0x9712 "ATI Mobility Radeon HD Graphics"
    SubVendor: pci 0x1028 "Dell"
    SubDevice: pci 0x0487
    Driver: "radeon"
    Driver Modules: "drm"
    Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
    I/O Ports: 0xe000-0xefff (rw)
    Memory Range: 0xff400000-0xff40ffff (rw,non-prefetchable)
    Memory Range: 0xff300000-0xff3fffff (rw,non-prefetchable)
    IRQ: 11 (no events)
    I/O Ports: 0x3c0-0x3df (rw)
    Module Alias: "pci:v00001002d00009712sv00001028sd00000487bc03sc00i00"
    Driver Info #0:
    XFree86 v4 Server Module: radeonhd
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #9 (PCI bridge)

    Primary display adapter: #27

    I am running OpenSUSE 11.4 on a Dell Inspiron Laptop.

    So assuming my drivers are all good, anyone have any suggestions on how to get the game running right?

  2. #2
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: PRoblem with Nexuiz

    Instaed of clicking the icon please try to run the game from the terminal and see what errors You get.

    Please post them here as well using code tags (much easier to read). A tutorial on doing this :
    Posting in Code Tags - A Guide

    Best regards,
    Greg
    Best regards,
    Greg

  3. #3
    Join Date
    May 2011
    Location
    Mt. Hood, OR
    Posts
    4

    Default Re: PRoblem with Nexuiz

    I tried to run it from a terminal but I'm not sure how, tried typing in Nexuiz and nexuiz to no avail. I then went searching the file system for the folder it installed to so I could see if maybe the program had a different name than just plain Nexuiz, but I couldnt figure out where games are installed in Linux.

  4. #4
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: PRoblem with Nexuiz

    How did You install it ? If using a package (.rpm) file You can easily find the files which the package installed.
    Code:
    rpm -ql package_name
    You could also right click on the icon -> properties and see what the icon launches.

    Best regards,
    Greg
    Best regards,
    Greg

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,317
    Blog Entries
    15

    Default Re: PRoblem with Nexuiz

    Hi
    It's either one of;
    Code:
    /usr/bin/nexuiz-glx
    /usr/bin/nexuiz-sdl
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    May 2011
    Location
    Mt. Hood, OR
    Posts
    4

    Default Re: PRoblem with Nexuiz

    So I ran it from a terminal, tried both nexuiz-glx and nexuiz-sdl, same thing, went to a black screen with a mouse pointer, but it freezes there and i cant get back to the desktop to see the terminal window and see if there were any errors, i'm having to switch to terminal, log out, log in as a different user, and sudo killall the processes, log back into my original account, get back to the gui and log in again.

    I'm starting to think more and more its a driver issue, from what I gather Linux is a lot less demanding on your system than windows, and I am noticing that on websites that will have a video and multiple other moving images my computer runs slow where it never did on windows on the same sites.

  7. #7
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: PRoblem with Nexuiz

    You could try a command like this :
    Code:
    /usr/bin/nexuiz-sdl > error_message
    this should create a text file which You will be able to view after You log back to your desktop. It could well be a graphic driver issue. Did You try to run the game with desktop effects disabled ?

    What graphics card and driver do You have ?
    Please post the output of :
    Code:
    /sbin/lspci -nnk
    Best regards,
    Greg
    Best regards,
    Greg

  8. #8
    Join Date
    May 2011
    Location
    Mt. Hood, OR
    Posts
    4

    Default Re: PRoblem with Nexuiz

    Ok, here's the result of /sbin/lspci -nnk

    Code:
    00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS880 Host Bridge [1022:9601]
            Subsystem: Dell Device [1028:0487]
    00:01.0 PCI bridge [0604]: Dell Device [1028:9602]
    00:04.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0) [1022:9604]
            Kernel driver in use: pcieport
    00:05.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1) [1022:9605]
            Kernel driver in use: pcieport
    00:11.0 SATA controller [0106]: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode] [1002:4391] (rev 40)
            Subsystem: Dell Device [1028:0487]
            Kernel driver in use: ahci
    00:12.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
            Subsystem: Dell Device [1028:0487]
            Kernel driver in use: ohci_hcd
    00:12.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
            Subsystem: Dell Device [1028:0487]
            Kernel driver in use: ehci_hcd
    00:13.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
            Subsystem: Dell Device [1028:0487]
            Kernel driver in use: ohci_hcd
    00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 42)
            Subsystem: Dell Device [1028:0487]
            Kernel driver in use: piix4_smbus
    00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383] (rev 40)
            Subsystem: Dell Device [1028:0487]
            Kernel driver in use: HDA Intel
    00:14.3 ISA bridge [0601]: ATI Technologies Inc SB700/SB800 LPC host controller [1002:439d] (rev 40)
            Subsystem: Dell Device [1028:0487]
    00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384] (rev 40)
    00:16.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
            Subsystem: Dell Device [1028:0487]
            Kernel driver in use: ohci_hcd
    00:16.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
            Subsystem: Dell Device [1028:0487]
            Kernel driver in use: ehci_hcd
    00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration [1022:1200]
    00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor Address Map [1022:1201]
    00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller [1022:1202]00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control [1022:1203]
            Kernel driver in use: k10temp
    00:18.4 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor Link Control [1022:1204]
    01:05.0 VGA compatible controller [0300]: ATI Technologies Inc M880G [Mobility Radeon HD 4200] [1002:9712]
            Subsystem: Dell Device [1028:0487]
            Kernel driver in use: radeon
    04:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
            Subsystem: Wistron NeWeb Corp. Device [185f:30af]
            Kernel driver in use: ath9k
    05:00.0 Ethernet controller [0200]: Atheros Communications AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)
            Subsystem: Dell Device [1028:0487]
            Kernel driver in use: atl1c
    And here is the result of the error_message

    Code:
    Nexuiz Linux 22:26:39 Mar  1 2011 - release
    Trying to load library... "libz.so.1" - loaded.
    Added packfile /usr/share/nexuiz/data/common-spog.pk3 (26 files)
    Added packfile /usr/share/nexuiz/data/data20091001.pk3 (9053 files)
    Trying to load library... "libcurl.so.4" - loaded.
    Failed to init SDL joystick subsystem: 
    Trying to load library... "libvorbis.so.0" - loaded.
    Trying to load library... "libvorbisfile.so.3" - loaded.
    Trying to load library... "libmodplug.so.0" - loaded.
    Trying to load library... "libogg.so.0" - loaded.
    Trying to load library... "libtheora.so.0" - loaded.
    Trying to load library... "libvorbis.so.0" - loaded.
    Trying to load library... "libvorbisenc.so.2" - loaded.
    Trying to load library... "libOffscreenGecko.so" "./libOffscreenGecko.so" - failed.
    execing quake.rc
    execing default.cfg
    execing defaultNexuiz.cfg
    execing physics26.cfg
    execing ctfscoring-div0.cfg
    execing balance.cfg
    execing effects-normal.cfg
    execing turrets.cfg
    execing unit_machinegun.cfg
    execing unit_hk.cfg
    execing unit_hellion.cfg
    execing unit_mlrs.cfg
    execing unit_flac.cfg
    execing unit_fusreac.cfg
    execing unit_plasma.cfg
    execing unit_plasma2.cfg
    execing unit_tesla.cfg
    execing unit_phaser.cfg
    execing unit_walker.cfg
    execing unit_ewheel.cfg
    couldn't exec unit_repulsor.cfg
    execing default25.cfg
    execing physics25.cfg
    execing balance25.cfg
    couldn't exec config.cfg
    couldn't exec data/campaign.cfg
    execing config_update.cfg
    couldn't exec autoexec.cfg
    Client using an automatically assigned port
    Client opened a socket on address local:2
    Client opened a socket on address 0.0.0.0:0
    Client opened a socket on address [0:0:0:0:0:0:0:0]:0
    Initializing Video Mode: fullscreen 1024x768x32x60hz
    Linked against SDL version 1.2.14
    Using SDL library version 1.2.14
    GL_VENDOR: Advanced Micro Devices, Inc.
    GL_RENDERER: Mesa DRI R600 (RS880 9712) 20090101 x86/MMX+/3DNow!+/SSE2 TCL DRI2
    GL_VERSION: 2.1 Mesa 7.10
    0 SDL joystick(s) found:
    Trying to load library... "libjpeg.so.62" - loaded.
    Trying to load library... "libpng12.so.0" - loaded.
    Draw_CachePic: failed to load gfx/complete
    Draw_CachePic: failed to load gfx/inter
    S_Startup: initializing sound output format: 48000Hz, 16 bit, 2 channels...
    Wanted audio Specification:
    	Channels  : 2
    	Format    : 0x8010
    	Frequency : 48000
    	Samples   : 2048
    Obtained audio specification:
    	Channels  : 2
    	Format    : 0x8010
    	Frequency : 48000
    	Samples   : 1024
    Sound format: 48000Hz, 2 channels, 16 bits per sample
    Found 1 cdrom drives.
    No CD in drive 0.
    CDAudio_Init: No CD in player.
    Can't get initial CD volume
    CD Audio Initialized

  9. #9
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: PRoblem with Nexuiz

    Did You try running without desktop effects ? (are You using GNOME or KDE ?)
    There is a thread that pops up in google search from ubuntu user base and basically they say that running without destkop effects fixed it for them :
    [ubuntu] Hardy and Nexuiz do not play well [Archive] - Ubuntu Forums

    You are using radeon driver, which most likely is much worse than fglrx driver. Read this carefully and install the fglrx driver :
    openSUSE Graphic Card Practical Theory Guide for Users
    You can try installing from repositories but IMHO You will get best results when installing the driver downloaded directly from ATI web site. Be prepared that if You do something wrong You will end up in runlevel 3 (no desktop environment) but don't worry all that much about it. It's usually very easy to fix.

    Best regards,
    Greg
    Best regards,
    Greg

  10. #10
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    563

    Default AW: Re: PRoblem with Nexuiz

    Hi,

    just saw this old thread. Is it solved? Would be a pity if not. Nexuiz is a brilliant (if mindless) shooter.
    I don't think it is related with desktop effects an the "usual" graphic driver issues.
    Nexuiz is platform independend using its own static(?) libraries. Even completely without 3D accelleration, it ususally starts (OS10.x through 11.3) being unbearably slow. (Sorry, didn't try in 11.4, yet.)

    Code:
    couldn't exec config.cfg
    couldn't exec data/campaign.cfg
    execing config_update.cfg
    couldn't exec autoexec.cfg
    That seems to be the problem, doesn't it?
    How actually DID you install it?
    Make sure installing it via yast from the games repo. It is using the darkplaces engine. If the dependency isn't installed automatically, choose it manually.

    cu

    kasi

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •