Results 1 to 5 of 5

Thread: Blinking cursor at boot

  1. #1

    Default Blinking cursor at boot

    Today I decided to play with my new 11.4 Opensuse dvd. It installed and booted without any problem, and I didn't face any problem until I rebooted the computer to test my newly installed nvidia graphics drivers. openSuse wouldn't boot.
    Well, the important side is: there are no kernel panics, no "hit enter to restart computer" to find the reason. Just a blinking cursor after an attempt to find the kernel. I only could get out of that by pressing the reboot button.
    I decided to press c and boot manually:
    Code:
    grub> root (hd0,4)
    Filesystem type is ext2fs, partition type 0x83
    grub> kernel /boot/vmlinuz-2.6.37.1-1.2-default
    and the computer just froze. At this stage pressing tab for autocompletion at kernel line freezes the computer, too.

    Any ideas? Maybe additional boot parameters?

    Well, considering that installation brought me to a desktop, the system seems to be up and ready to run. Nothing seems wrong with my menu.lst:
    Code:
    title openSUSE 11.4
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.37.1-1.2-default root=/dev/sda5
        initrd /boot/initrd-2.6.37.1-1.2-default
    (I did not install a bootloader with openSUSE. This is legacy grub bootloader of Debian)

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Blinking cursor at boot

    So I am somewhat confused by the minimal setup your have. Compare your entry here to mine which follows.

    Code:
    title openSUSE 11.4     
    root (hd0,4)     
    kernel /boot/vmlinuz-2.6.37.1-1.2-default root=/dev/sda5     
    initrd /boot/initrd-2.6.37.1-1.2-default
    The main point is the kernel load option nomodeset, that you will see here with other default settings.

    Code:
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 11.4 - 2.6.39-0.5
        savedefault 0
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.39-0.5-desktop root=/dev/disk/by-id/ata-INTEL_SSDSA2M080G2GC_CVPO037603KN080JGN-part1 resume=/dev/disk/by-id/ata-Hitachi_HDS721010CLA332_JP9921HD2SSJLH-part2 splash=silent nomodeset quiet showopts vga=0x34a
        initrd /boot/initrd-2.6.39-0.5-desktop
    Now much of the commands are specific to my setup such as drive names and the nomodeset was added by me to allow the nVIDIA driver to install and load. In particular I would add the following commands from my listing "splash=silent nomodeset quiet showopts".

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: Blinking cursor at boot

    Thanks for your reply. Those minimal parameters worked for me with many distros: no bootsplash and default settings.

    Anyway, I tried the settings I've found in /etc/sysconfig/bootloader and the settings you've provided for me, but no avail. I've never passed the blinking cursor.

    The installation media is good:
    Code:
    md5sum  /dev/sr0 
    5f6d6d67c3e256b2513311f4ed650515  /dev/sr0
    It's the same with this.

    Anyway, ignore this. I'll try to re-install later.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Blinking cursor at boot

    On 06/01/2011 03:06 AM, onekine wrote:
    >
    > Any ideas? Maybe additional boot parameters?
    >


    my _guess_ is you will find a smile here: http://tinyurl.com/23mgej6 (or
    below)

    but, no promises as i'm also somewhat perplexed spryness by your Debian
    grub..

    you may wanna consider these strings, they fit my system but may smoke
    yours so *read* my sig's caveat and scratch your head first..

    from /boot/grub/menu.lst normal boot:

    Code:
    title Desktop -- openSUSE 11.4 - 2.6.37.6-0.5
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.37.6-0.5-desktop
    root=/dev/disk/by-id/ata-Hitachi_HTS545025B9A300_100927PBN204CSKZB46T-part6
    resume=/dev/disk/by-id/ata-Hitachi_HTS545025B9A300_100927PBN204CSKZB46T-part5
    splash=verbose quiet showopts ipv6.disable=1 vga=0x314
    initrd /boot/initrd-2.6.37.6-0.5-desktop
    note, that string allows a many viewing of the normally hidden work
    behind the green splash, and also disables IPv6 (which speeds up
    connecting with the still mostly v4 web)

    failsafe:

    Code:
    title Failsafe -- openSUSE 11.4 - 2.6.37.6-0.5
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.37.6-0.5-desktop
    root=/dev/disk/by-id/ata-Hitachi_HTS545025B9A300_100927PBN204CSKZB46T-part6
    showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off
    nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x314
    initrd /boot/initrd-2.6.37.6-0.5-desktop
    and by the way, our grub is not the same grub used by *buntu, ours is
    also 'legacy'...try it, you might like it..


    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Blinking cursor at boot

    On 2011-06-01 03:06, onekine wrote:
    > (I did not install a bootloader with openSUSE. This is legacy grub
    > bootloader of Debian)


    I'm not sure that is wise. Better install grub in the root partition of
    openSUSE, and just add an entry on the debian grub to load openSUSE grub.
    This way, when you run updates on oS it will be happy when it updates grub
    entries. Both systems thus mantain their own grub, no interference.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •