Results 1 to 7 of 7

Thread: How Do I Enable 3D Graphics (yet another graphics question, sorry!)

  1. #1
    Join Date
    May 2011
    Location
    UK
    Posts
    109

    Default How Do I Enable 3D Graphics (yet another graphics question, sorry!)

    I have installed an ATI 5770 without any problem by downloading the driver from the ATI website and doing a manual install, everything went well, I ran configure and I have the Catalyst Control Ctr on my desktop and everything works EXCEPT 3D, I cannot get 3D enabled, what I am I missing Pls help!

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: How Do I Enable 3D Graphics (yet another graphics question, sorry!)

    You need to give us more information about your setup; KWin for example will disable 3D if it does not think you have all the necessary resources - see Martin’s Blog

  3. #3
    Join Date
    May 2011
    Location
    UK
    Posts
    109

    Default Re: How Do I Enable 3D Graphics (yet another graphics question, sorry!)

    hi, thanks for the reply, my setup is pretty straight forward, its a new install of open Suse 11.4 with Gnome desktop which has been upgraded with all the downloads via yast. my computer dual boots with windows xp.

    I installed the ATI first in windows then in linux, everything went smoothly, no error messages, configured and rebooted and i have full control of the settings through the ATI GUI on my desktop, except no 3D! although I can adjust the 3D settings there, they are not enabled in the Suse "desktop effects" menus/options.

    If you need any more info pls let me know

    thanks

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: How Do I Enable 3D Graphics (yet another graphics question, sorry!)

    On 06/01/2011 11:06 AM, jimt123 wrote:
    >
    > hi, thanks for the reply, my setup is pretty straight forward, its a new
    > install of open Suse 11.4 with Gnome desktop which has been upgraded
    > with all the downloads via yast. my computer dual boots with windows
    > xp.
    >
    > I installed the ATI first in windows then in linux, everything went
    > smoothly, no error messages, configured and rebooted and i have full
    > control of the settings through the ATI GUI on my desktop, except no 3D!
    > although I can adjust the 3D settings there, they are not enabled in the
    > Suse "desktop effects" menus/options.
    >
    > If you need any more info pls let me know
    >
    > thanks
    >
    >


    if you don't have the resources required for 3D it won't run..
    about 30 seconds after this machine _first_ started up after the initial
    install, it popped up something like: "Desktop effects is running too
    slowly and has been disabled." so, mine tried to run using 1GB total RAM
    and a little 1.66 Ghz Atom....but couldn't..

    so, tell us about how much RAM, and how much video RAM, and is the video
    'shared' (taken from) the main RAM?

    and, what is your CPU type and speed..

    finally, are you certain you have the most efficient _linux_ graphics
    installed? if you open "My Computer" on the desktop, what does it say is
    your graphic card and driver(s), mine says:

    Vendor: Intel Corporation
    Model: Pineview Integrated Graphics Controller
    2D driver: intel
    3D driver: Unknown classic (7.10.2)

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  5. #5
    Join Date
    May 2011
    Location
    UK
    Posts
    109

    Default Re: How Do I Enable 3D Graphics (yet another graphics question, sorry!)

    Hi, I'm sure I have plenty of resources, 4GB main system RAM, as I mentioned in my first post, my graphics card is ATI HD 5770 with 1GB RAM. CPU is Athlon II X2 265 3.3Ghz, this is not an issue, the graphics fly on windows.
    OS is Suse 11.4 Gnome desktop

    The driver info is as follows:
    DRIVERS
    Hwcfg Bus: pci
    Kernel Driver: fglrx
    Model: ATI VGA compatible controller
    Old Unique Key: a8Og.WxzbsjNrA0
    Parent Unique ID: Znp.+eZipjdga28
    Vendor: ATI technologies Inc

    Hope this helps. By the way I dont have "My Computer" on the desk top only "Hardware Info" from Yast.

    Thanks

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: How Do I Enable 3D Graphics (yet another graphics question, sorry!)

    On 06/01/2011 03:06 PM, jimt123 wrote:
    >
    > Hi, I'm sure I have plenty of resources, 4GB main system RAM, as I
    > mentioned in my first post, my graphics card is ATI HD 5770 with 1GB
    > RAM.


    your first post does not mention 1GB of video ram, and since "ATI HD
    5770" means nothing to me it could have been a almost no RAM
    board...and, couple that with zero idea of anything else. . . well, when
    asking for help, please tell us about your hardware (and i won't have to
    ask)

    this is more than i know about ATI and their drivers:

    http://forums.opensuse.org/forums/en...ml#post2164512

    i've not read through it (i don't have ATI, and sorry you do...they are
    not the best for supporting Linux)...but i hope there is some help for
    you while you wait for actually qualifed help to drop in (by the way,
    next time be sure your subject is more descriptive...that is, something
    like "ATI board which should, won't do 3D" would tell all the nVidia
    gurus to stay out)

    and, i guess "My Computer" is a KDE thing, which is why it is always
    important to say your desktop environment, as the answers will vary
    considerably..

    read and wait....i think we (someone) can get you rocking..

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  7. #7
    Join Date
    May 2011
    Location
    UK
    Posts
    109

    Default Re: How Do I Enable 3D Graphics (yet another graphics question, sorry!)

    OK, thanks for the advice anyway

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •