Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: zypper update gets stuck

  1. #1
    Join Date
    Nov 2010
    Location
    Helsinki, Finland
    Posts
    5

    Unhappy zypper update gets stuck

    (By way of introduction, I'm a longtime Mandriva & CentOS user looking to possibly become an OpenSuse user, so I'm not a complete Linux noob except wrt OpenSUSE, but there are some roadblocks... help me to get Borged...)
    Specifically, after installing OpenSUSE 11.4 (64-bit ed) from DVD to a partition, trying to update it gets stuck partway during loading some delta rpm. Some do get loaded, some not. I have tried changing repositories, does not help. Eg currently it is hanging at http://download.opensuse.org/update/...6_64.delta.rpm. The download looks like it starts, but then the "speed indicator" goes down to zero after 57% loaded.
    (Sorry for not posting the entire zypper log, since it is in Finnish localization). I have also tried the GUI way (although I very much like the command line), but it apparently has the same problem.
    The strange thing is that network otherwise appears to work fine, eg web pages load.
    Anyone seen something similar?
    (I hope this is not a case of not being able to apply a fix to correct a known problem, because the bug is in the program meant to apply the fix...)

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: zypper update gets stuck

    Hi, welcome here.

    If you use "su -" instead of "su", still no english output?

    If the problem's only there for delta rpms, you could (temporarily) work around it by changing this line in /etc/zypp/zypp.conf:
    Code:
    download.use_deltarpm = false
    to
    Code:
    download.use_deltarpm = true
    hey, and a warm welcome here
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: zypper update gets stuck

    If it's a new install, make sure you reboot proper - post the initial partial reboot after install.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Nov 2010
    Location
    Helsinki, Finland
    Posts
    5

    Default Re: zypper update gets stuck

    Thanks for a fast response. Apparently deltarpm is not the problem. Disabling it just caused the corresponding non-delta rpm to get stuck. You are right, "su -" gets rid of the localization. This is what zypper prints in English:
    Code:
    linux-hy6r:~ # zypper update
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
      gstreamer-0_10 gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good k3b kaffeine 
      libgstapp-0_10-0 libgstinterfaces-0_10-0 libgstreamer-0_10-0 libgstreamer-0_10-0-32bit libwavpack1 linphone 
      mjpegtools python-numpy taglib 
    
    The following NEW packages are going to be installed:
      gstreamer-0_10-plugins-good-lang ktorrent-lang libktorrent3-lang tar-lang 
    
    The following package is going to be REMOVED:
      libktcore12 
    
    The following packages are going to be upgraded:
      Mesa ModemManager MozillaFirefox MozillaFirefox-translations-common NetworkManager NetworkManager-glib 
      SuSEfirewall2 aaa_base aaa_base-extras alsa at bootsplash bootsplash-branding-openSUSE cron cronie cups cups-client 
      cups-libs cups-libs-32bit desktop-translations dhcp dhcp-client dhcpcd dosfstools flash-player 
      ghostscript-fonts-other ghostscript-fonts-std ghostscript-library ghostscript-x11 gstreamer-0_10-plugins-good 
      gtk2-data gtk2-immodule-amharic gtk2-immodule-inuktitut gtk2-immodule-thai gtk2-immodule-vietnamese gtk2-tools 
      gtk2-tools-32bit insserv kdebase4-openSUSE kdebase4-runtime-branding-openSUSE kdebase4-workspace-branding-openSUSE 
      kdelibs4 kdelibs4-branding-openSUSE kdelibs4-core kdm-branding-openSUSE kernel-desktop kio_sysinfo 
      kio_sysinfo-branding-openSUSE krb5 krb5-32bit ktorrent libasound2 libasound2-32bit libcairo2 libcairo2-32bit 
      libgimpprint libgpod-tools libgpod4 libgtk-2_0-0 libgtk-2_0-0-32bit libkde4 libkdecore4 libksuseinstall1 
      libktorrent3 libmodplug0 libpolkit0 libpulse-browse0 libpulse-mainloop-glib0 libpulse0 libpulse0-32bit 
      libpython2_7-1_0 libreoffice-libs-gui libtiff3 libtiff3-32bit libusbmuxd1 libzip1 logrotate mingetty mozilla-js20 
      mozilla-xulrunner20 mozilla-xulrunner20-gnome mozilla-xulrunner20-translations-common mtools openSUSE-release 
      openvpn perl perl-base perl-libwww-perl permissions polkit postfix preload-kmp-desktop pullin-flash-player 
      pulseaudio pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-jack pulseaudio-module-lirc 
      pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils python python-base python-xml rdesktop 
      release-notes-openSUSE rsync rsyslog sane-backends sane-backends-autoconfig smolt smolt-gui sysvinit sysvinit-tools 
      tar timezone timezone-java tk translation-update translation-update-fi udisks usbmuxd xorg-x11 xorg-x11-Xvnc 
      xorg-x11-driver-video xorg-x11-server xorg-x11-xauth yast2-bootloader yast2-control-center yast2-control-center-qt 
      yast2-ldap-client yast2-qt yast2-trans-fi 
    
    The following product is going to be reinstalled:
      openSUSE 11.4 
    
    133 packages to upgrade, 4 new, 1 to remove.
    Overall download size: 155.7 MiB. After the operation, additional 20.6 MiB will be used.
    Continue? [y/n/?] (y): y
    Do you agree with the terms of the license? [yes/no] (no): y
    Do you agree with the terms of the license? [yes/no] (no): y
    Retrieving package timezone-2011g-0.2.1.x86_64 (1/137), 325.0 KiB (1.3 MiB unpacked)
    Retrieving: timezone-2011g-0.2.1.x86_64.rpm [error (6 B/s)]
    Timeout exceeded when accessing 'http://download.opensuse.org/update/11.4/rpm/x86_64/timezone-2011g-0.2.1.x86_64.rpm'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Trying again...
    Retrieving: timezone-2011g-0.2.1.x86_64.rpm [73% (0 B/s)]
    As to rebooting which the second responder asked about, this machine has been
    rebooted many time since the install.

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: zypper update gets stuck

    Could you post output of:
    Code:
    zypper lr -d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: zypper update gets stuck

    Try booting to level 3 and login as root
    Then run

    Code:
    zypper up
    then when done reboot

    Some also solved this by booting to Failsafe mode
    or download the file in question with firefox and install manually
    timezone-2011g-0.2.1.x86_64.rpm
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Nov 2010
    Location
    Helsinki, Finland
    Posts
    5

    Unhappy The plot deepens (Re: zypper update gets stuck)

    Quote Originally Posted by caf4926 View Post
    Try booting to level 3 and login as root
    Then run

    Code:
    zypper up
    then when done reboot

    Some also solved this by booting to Failsafe mode
    or download the file in question with firefox and install manually
    timezone-2011g-0.2.1.x86_64.rpm
    Booting at runlevel 3 did not make any difference.

    This is increasingly looking like a network or driver problem of some kind, because trying to fetch
    the file in question with wget gets stuck when 108k of that 325k file has been fetched.
    As if longer file transfers fail, although I can use the web (writing this on the system in question!).
    Also, the Mandriva installation on the other partition has no such problems. The network is an
    8mbs ADSL modem, connected with cable.

    Tried to put the dmesg output below, but the forum software complains it makes the posting too long.
    here is lspci output instead
    Code:
    00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
    00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
    00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
    00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
    00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
    00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
    00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
    00:09.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)
    00:0a.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
    00:0a.1 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] (rev 05)
    00:0a.2 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
    00:0a.4 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [IR Port] (rev 05)
    00:0d.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
    00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
    00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
    00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
    00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
    00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
    00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
    01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01)
    01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (Secondary) (rev 01)
    ifconfig says
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:01:03:BE:7B:08  
              inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::201:3ff:febe:7b08/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:4198 errors:0 dropped:0 overruns:0 frame:0
              TX packets:3605 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:5014249 (4.7 Mb)  TX bytes:484640 (473.2 Kb)
              Interrupt:16 Base address:0x4000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:748 errors:0 dropped:0 overruns:0 frame:0
              TX packets:748 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:54776 (53.4 Kb)  TX bytes:54776 (53.4 Kb)

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: The plot deepens (Re: zypper update gets stuck)

    Can you download this
    http://download.opensuse.org/update/...2.1.x86_64.rpm

    And install
    ?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: zypper update gets stuck

    On 2011-05-31 21:36, ruohtula wrote:
    >
    > (By way of introduction, I'm a longtime Mandriva & CentOS user looking
    > to possibly become an OpenSuse user, so I'm not a complete Linux noob
    > except wrt OpenSUSE, but there are some roadblocks... help me to get
    > Borged...)
    > Specifically, after installing OpenSUSE 11.4 (64-bit ed) from DVD to a
    > partition, trying to update it gets stuck partway during loading some
    > delta rpm. Some do get loaded, some not. I have tried changing
    > repositories, does not help. Eg currently it is hanging at
    > http://tinyurl.com/3q2jw4o. The download looks like it starts, but then
    > the "speed indicator" goes down to zero after 57% loaded.



    Do you have a network card type 3C905CX-TX/TM Fast ethernet link (3c59x
    driver)?

    If yes, see https://bugzilla.novell.com/show_bug.cgi?id=688454

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10
    Join Date
    Nov 2010
    Location
    Helsinki, Finland
    Posts
    5

    Default That card problem must be it!

    Quote Originally Posted by robin_listas View Post
    On 2011-05-31 21:36, ruohtula wrote:[color=blue]
    Do you have a network card type 3C905CX-TX/TM Fast ethernet link (3c59x
    driver)?

    If yes, see https://bugzilla.novell.com/show_bug.cgi?id=688454
    It looks like a very similar card, although not exactly that. From "/etc/init.d/network restart" output:
    Code:
        eth0      device: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)
    After doing the
    Code:
    rmmod 3c59x ; modprobe 3c59x debug=6
    command mentioned in the bug report, and restarting networking, I could finally wget the timezone RPM.

    So it seems I have exactly the same problem,except that I have a 64-bit system, and a posting in the bug thread seem to indicate the problem was seen only on the 32-bit version. But that could be because of some small hardware difference. Since the symptoms and workaround match completely, I would say it is the same issue. I will watch that bug report, and hope someone comes up with a fix. Also must try to make the modprobe workaround part of booting.

    Thanks for everyone for replies!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •