Results 1 to 4 of 4

Thread: not able to install HAE or DRBD on SLES11sp1

  1. #1

    Default not able to install HAE or DRBD on SLES11sp1

    dear friends, I am new here, need some advice

    please.
    I am trying to setup HA for mySQL on SLES11sp1

    with DRBD and heartbeat. I found the HAE of SLES

    seems has DRBD and SLES10 also have a older

    version. But after I installed SLES11 and also

    one SLES11sp1,both don't have DRBD. I downloaded

    a DRBD RPM for opensuse,it gave me glic error

    "need glic.so.64 bit",etc. When I tried to

    install those GLBIC stuff ,also errors for

    dependencies again. I tried to use the source

    code build but system has no git and stuck there

    too. I got HAE ISO and match to my DVD drive of

    the VM, but the pattern doesn't show HAE. it only

    allow me to install the drbd tool into Yast but

    from Yast I am not able configure any DRBD

    because the error is the drbd still not found.

    where I should start please? wondering if I

    should do a full install for everything as I

    selected express install for the OS. Then it may

    include all the prerequisite ? But HA extention

    still not sure how to install. Any advice

    please?Thanks! SP

  2. #2

    Default Re: not able to install HAE or DRBD on SLES11sp1

    linux-iplx:~/bin/temp # ls
    drbd-8.3.10-25.1.x86_64(sles11sp1.rpm
    linux-iplx:~/bin/temp # rpm -i drbd-8.3.10-25.1.x86_64\(sles11sp1.rpm
    warning: drbd-8.3.10-25.1.x86_64(sles11sp1.rpm: Header V3 DSA signature: NOKEY, key ID 7b709911
    error: Failed dependencies:
    libc.so.6()(64bit) is needed by drbd-8.3.10-25.1.x86_64
    libc.so.6(GLIBC_2.11)(64bit) is needed by drbd-8.3.10-25.1.x86_64
    libc.so.6(GLIBC_2.2.5)(64bit) is needed by drbd-8.3.10-25.1.x86_64
    libc.so.6(GLIBC_2.3)(64bit) is needed by drbd-8.3.10-25.1.x86_64
    libc.so.6(GLIBC_2.3.4)(64bit) is needed by drbd-8.3.10-25.1.x86_64
    libc.so.6(GLIBC_2.4)(64bit) is needed by drbd-8.3.10-25.1.x86_64
    libc.so.6(GLIBC_2.7)(64bit) is needed by drbd-8.3.10-25.1.x86_64
    libc.so.6(GLIBC_2.8)(64bit) is needed by drbd-8.3.10-25.1.x86_64
    linux-iplx:~/bin/temp #

    linux-iplx:/usr/src/packages # ls
    BUILD drbd-8.3.10.tar.gz RPMS SPECS
    drbd-8.3.10(2).tar.gz git-0.99.9k-1.x86_64.rpm SOURCES SRPMS
    linux-iplx:/usr/src/packages # rpm -i git-0.99.9k-1.x86_64.rpm
    error: Failed dependencies:
    git-core is needed by git-0.99.9k-1.x86_64
    git-svn is needed by git-0.99.9k-1.x86_64
    git-cvs is needed by git-0.99.9k-1.x86_64
    git-arch is needed by git-0.99.9k-1.x86_64
    git-email is needed by git-0.99.9k-1.x86_64
    gitk is needed by git-0.99.9k-1.x86_64
    linux-iplx:/usr/src/packages # rpm -i http://kernel.org/pub/software/scm/g...c13.x86_64.rpm
    error: Failed dependencies:
    git = 1.7.5.3-1.fc13 is needed by git-all-1.7.5.3-1.fc13.x86_64
    git-svn = 1.7.5.3-1.fc13 is needed by git-all-1.7.5.3-1.fc13.x86_64
    git-cvs = 1.7.5.3-1.fc13 is needed by git-all-1.7.5.3-1.fc13.x86_64
    git-arch = 1.7.5.3-1.fc13 is needed by git-all-1.7.5.3-1.fc13.x86_64
    git-email = 1.7.5.3-1.fc13 is needed by git-all-1.7.5.3-1.fc13.x86_64
    gitk = 1.7.5.3-1.fc13 is needed by git-all-1.7.5.3-1.fc13.x86_64
    gitweb = 1.7.5.3-1.fc13 is needed by git-all-1.7.5.3-1.fc13.x86_64
    git-gui = 1.7.5.3-1.fc13 is needed by git-all-1.7.5.3-1.fc13.x86_64
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by git-all-1.7.5.3-1.fc13.x86_64
    linux-iplx:/usr/src/packages #

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,346
    Blog Entries
    15

    Default Re: not able to install HAE or DRBD on SLES11sp1

    Hi
    Your posting in the incorrect forum, this is for openSUSE not SLE, the SLE forums are at ATTACHMATE GROUP FORUMS.

    You need to add the iso images via YaST -> Add on products so it activates the repositories, you probably also need to add the SLE SDK.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: not able to install HAE or DRBD on SLES11sp1

    On 05/31/2011 06:36 PM, sweatpotatohead wrote:
    >
    > I am trying to setup HA for mySQL on SLES11sp1


    you are welcome to seek advice here, but BE ADVISED that many of the
    answers might be from folks who have never run SLES (or maybe never even
    heard of it before) and you are likely much better off if you seek
    assistance from the Novell forums, via:
    http://forums.novell.com/novell-prod...e-server-sles/

    you are welcome to hang out here and see if anyone has the info you
    need, but you should for sure check in with the novell folks--your
    ID/Pass here works there also..

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •