Results 1 to 8 of 8

Thread: eID - Card reader

  1. #1

    Default eID - Card reader

    Na mijn overstap van Ubuntu naar Opensuse 11.4 lukt het mij niet meer om mijn ACR38 kaartlezen aan de praat te krijgen. De pcscd geeft volgende fout :
    /etc/init.d/pcscd start retourneerde 1 (niet gespecificeerde foutmelding):

    Gezien het weer hét ogenblik is om dé brief in te vullen had ik dit graag in orde gekregen.
    De geïnstalleerde programma's zijn :
    libpcsclite1, pcscacr38, pcsc-ccid en pcsc-lite

    Kan er mij iemand verder helpen?
    Met dank bij voorbaat.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    145

    Default Re: eID - Card reader

    Ik heb geen idee wat een acr38 is, gelukkig kon google mij helpen. Ik denk dat de google-link jou ook zou kunnen helpen. Ik kom op een website van de belgische eID. Daarin wordt uitgelegd dat de eID werkt met kaartlezer en ook welke software wordt ondersteund. Welk deel van de uitleg van de website werkt voor jou niet? Dat zie ik nu niet terug.

    Een aantal tips om verder te komen met de oplossing. Weet je of de kaartlezer wordt 'gezien' ? Dat ontdek je door de uitvoer van dmesg. Bij het inprikken van de usbstekker zou dit de laatste boodschap van dmesg moeten zijn. En om Knurpht' s advies te verwerken:
    Vertel uitvoer met CODE-tags: Posting in Code Tags - A Guide
    Op de website van eID staat dat OpenSUSE wordt ondersteund, alleen bij downloads staat geen OpenSUSE-verhaal. Misschien heb je iets aan de software-bibliotheek van OpenSUSE. Ik vind daar de ACR38-software en driver terug. Is dat voldoende?

    Ik hoop dat dit je helpt, ik kom niet vaak genoeg op deze forums om jouw vraag dat dit "hét ogenblik is om dé brief in te vullen" ook vandaag op te lossen. Misschien dat een ander je verder helpt op jouw reactie. Succes!

  3. #3

    Default Re: eID - Card reader

    Bedankt Max_23 voor je reactie.
    De drivers e.d. die je aanhaalt zijn reeds geïnstalleerd. Er moet nog wat anders ontbreken (of misschien te veel zijn zodat er een conflict bestaat).

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    145

    Default Re: eID - Card reader

    Heb je de andere topics over eID ook gelezen en gekeken of daar een tip in staat? Het Nederlandstalige topic verteld ook iets over pcscd in eID ccid en het Engelstalig topic ook en zelfs uitgebreider. Daar wordt ook de installatie van de clientsoftware genoemd.
    Last edited by Max_23; 01-Jun-2011 at 00:00. Reason: foutje in pcscd

  5. #5

    Default Re: eID - Card reader

    Kan je ons op de hoogte houden van je ontwikkelingen? Mij is het immers niet gelukt om de eid client software op opensuse 11.4 te installeren (maar dat kan heel goed aan mij liggen).

  6. #6

    Default Re: eID - Card reader

    susejan, ik weet niet of ik je een oplossing kan geven, maar wil het wel eens proberen ;-) Kan je eens pcscd's debug-output geven? Best eerst firefox en eid-viewer afsluiten, je eID én kaartlezer uitpluggen (indien deze laatste een usb-dingetje is) en vervolgens volgende commando's uitvoeren:

    Code:
    # sudo /etc/init.d/pcscd stop
    # sudo pcscd -fd
    Het resultaat is een hele waslijst tekst in allerlei kleurtjes. De rode zijn het meest interessant, deze zijn namelijk vrij gedetailleerde foutmeldingen. Als je op dit ogenblik nog geen foutmelding ziet, plug dan achtereenvolgens je kaartlezer en je eID in, en probeer in te loggen op tax-on-web. Stop vanzodra je rode foutmeldingen ziet en kopiëer de hele output. Op welk punt ging het verkeerd?

    Nog een paar vraagjes:
    - geef ook eens de output van "zypper se pcsc" - ik meen me te herinneren dat ik destijds op opensuse11.1 het pakket "pcsc-openct" niet mocht geïnstalleerd zijn, anders werkte het niet
    - elke middleware heb je geïnstalleerd (versie en bron) - of zit je nog zo ver niet?

  7. #7

    Default Re: eID - Card reader

    eulaersivan, heb je al eens versie 4.0 van de middleware geprobeerd, zoals ik geschreven heb in dit topic?

  8. #8

    Default Re: eID - Card reader

    Ik ben er!
    (en mijn belastingsbrief is ingevuld en opgestuurd)

    Hartelijk dank aan allen die meegeholpen hebben om mijn probleem uit de weg te helpen.

    Met de code van zeeappel :
    Code:
    # sudo /etc/init.d/pcscd stop
    # sudo pcscd -fd
    Heb ik gemerkt dat er een bestand in de weg zat, nl /var/run/pcscd/pcscd.comm.
    Ik heb dit bestand gewist (eigenlijk hernoemd voor in geval..). Daarna starte de pcscd op zonder probleem.

    De geïnstalleerde programma die nu op mijn computer draaien zijn : lbpcsclite1, pcsc-acr38, pcsc-lite, pcsc-acr38-devel en pcsc-lite-devel.
    De eID-software is de versie Linux Fedora die te vinden is op
    "http://eid.belgium.be/nl/Hoe_installeer_je_de_eID/Linux/]Linux - Hoe installeer je de eID? - eID"
    .

    Versie 4, zoals zeeappel beschrijft is voor héél binnenkort.

    Nogmaals dank.
    Jan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •