Results 1 to 6 of 6

Thread: nvidia gt440 driver for suse14

  1. #1
    Join Date
    May 2011
    Location
    UK
    Posts
    109

    Default nvidia gt440 driver for suse14

    I am new to Linux and need help to install the drivers for the gt440 card. i have tried following the instructions on the SUSE web site but each time when my computer reboots i lose the display all together and all i get is a login prompt in the console, can someone help me please with a step by step guide. thanks

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: nvidia gt440 driver for suse14

    I am new to Linux and need help to install the drivers for the gt440 card. i have tried following the instructions on the SUSE web site but each time when my computer reboots i lose the display all together and all i get is a login prompt in the console, can someone help me please with a step by step guide. thanks
    This is the normal link to look at. Is this the one you are referring to?

    SDB:NVIDIA drivers - openSUSE

    The most common step missied is to add the kernel load option nomodeset. You can type this in at the options entry, just before you press the enter key to select the standard openSUSE startup from the grub menu. If this option works, you can edit the menu.lst file as root and add it to options already present. I normally suggest loading the nVIDIA driver the hard way. I go to nviia.com and download the correct driver for my video card 32 or 64 bit, as I have installed openSUSE. The link for installing the nVIDIA driver the hard way is located here:

    SDB:NVIDIA the hard way - openSUSE

    I even have a bash script, helpful in installing the driver the hardware located here:

    LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Page 2

    1. My normal sequence of events is to download the correct driver.
    2. Edit my /boot/grub/menu.lst file as root and add the nomodeset kernel load option.
    3. Restart openSUSE and before selecting the correct or normal opneSUSE OS, I enter the kernel option of 3.
    4. Entering a 3 in the grub menu leaves me at the terminal prompt once the kernel is loaded. Enter the user name root and the root password. I finally enter the terminal command lnvhw (using my bash script).
    5. I select the correct nVIDIA driver to load from the lnvhw menu.
    6. Move through the Video driver prompts as I desire.
    7. Once the driver is loaded and I am the terminal prompt again, I enter the command reboot.

    That is all, the proprietary nVIDIA driver is now loaded. Ever time you update or replace the kernel, you must also reload the nVIDIA driver. I normally use this opportunity to see if a newer video driver has been released from nVIDIA before I reboot and load the new kernel. Good luck...

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    May 2011
    Location
    UK
    Posts
    109

    Default Re: nvidia gt440 driver for suse14

    Thanks James, that was a great help I installed the driver the "hard way", actually it turned out pretty easy in the end, used "NVIDIA-Linux-x86-270.41.19.run" and configured it with "nvidia-settings" i console after install. A couple of questions though, is 3D enabled automatically or do I have to do something else, can I get a GUI for the on my desktop, and lastly I'm running window xp on the same computer, and when i rebooted into windows I have no video at all, is there a simple fix for that

    Thanks again

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: nvidia gt440 driver for suse14

    Thanks James, that was a great help I installed the driver the "hard way", actually it turned out pretty easy in the end, used "NVIDIA-Linux-x86-270.41.19.run" and configured it with "nvidia-settings" i console after install. A couple of questions though, is 3D enabled automatically or do I have to do something else, can I get a GUI for the on my desktop, and lastly I'm running window xp on the same computer, and when i rebooted into windows I have no video at all, is there a simple fix for that

    Thanks again
    To see your present video driver setup, you can check its status listed in the My Computer icon on the desktop where it will list the name of the 2D and 3D drivers. Once a 3D capable driver is loaded, it should be enabled by default. Now as for XP, when you say it has no graphic mode, that might just mean it did not load properly. There are a few things in your openSUSE terminal session you could list and then post here in a code field while in the advance message editor. Here is a list of commands to run (also shown in a code field). Just select all of the text output with your mouse and then right click and select copy and then paste the text into a message here in the forum, again, using a code field.

    Code:
    su -
    password:
    fdisk -l
    
    cat /boot/grub/menu.lst
    
    cat /boot/grub/device.map
    
    cat /etc/fstab
    The word password is displayed automatically for you and you just type in the root user password. The menu.lst file is the OS selection menu from grub and can show me how you are starting Windows. The device.map file shows the logical drive order, as used in the grub menu. The fstab file shows how partitions are mapped in openSUSE and finally, the first command (fdisk -l) lists all hard drives and their partitions. From all of this information I might be able to see why Windows is not starting. There is another program you might want to download and run called findgrub. Check out its usage and download the file from here:

    Looking for Grub and Windows bootloader in all partitions. - Page 8

    The actual findgrub bash script file can be found here:

    http://unixversal.com/linux/openSUSE/findgrub301.tgz

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    May 2011
    Location
    UK
    Posts
    109

    Default Re: nvidia gt440 driver for suse14

    Thanks again for the help, I was able to sort it out, the problem was that the onboard graphics chip is ATI, and when i installed the new Nvidia card and drivers in whilst in Linux I hadn't installed the windows drivers, (I also had moved the video cable from the board socket to the card socket!!) so when in windows there was no chance of any signal getting to the monitor. I removed all the drivers from SUSE and installed basic drivers in windows, I then installed the full windows drivers for the Nvidia card and and then rebooted into Suse and installed the Linux driver there, booted back and fwd a few times and every thing works great. Lesson learned, but I guess thats how you learn a new system.

    Thanks again, I'll probably need your help again in future!!!

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: nvidia gt440 driver for suse14

    Thanks again for the help, I was able to sort it out, the problem was that the onboard graphics chip is ATI, and when i installed the new Nvidia card and drivers in whilst in Linux I hadn't installed the windows drivers, (I also had moved the video cable from the board socket to the card socket!!) so when in windows there was no chance of any signal getting to the monitor. I removed all the drivers from SUSE and installed basic drivers in windows, I then installed the full windows drivers for the Nvidia card and and then rebooted into Suse and installed the Linux driver there, booted back and fwd a few times and every thing works great. Lesson learned, but I guess thats how you learn a new system.

    Thanks again, I'll probably need your help again in future!!!
    Live and learn as they say. I can't tell you how often users have an issue with changed, added or built-in video when an added video card is inserted. In general, if you buy a new video card, its best to switch to it and stop using the built-in video, dah. While I can't say I have had this issue, I have plugged in the audio to the built-in audio just after adding in a separate audio card. I guess it depends on where your mind is at, at that time. By the way, if you have any other issues, questions or requests, just fire away, we are here to help.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •