Results 1 to 7 of 7

Thread: XFCE with gdm oddity

  1. #1
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,642
    Blog Entries
    3

    Default XFCE with gdm oddity

    I have a system with 11.4 KDE, installed from the 32bit live CD. To that, I added XFCE and LXDE.

    While experimenting, I changed to using "gdm" as the display manager. With gdm, when I log into XFCE, there is no ssh-agent running. If I login to KDE or LXDE, then ssh-agent does run. And if I switch back to "kdm", then ssh-agent runs under XFCE. But not with "gdm".

    Is anybody else noticing this?
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,642
    Blog Entries
    3

    Default Re: XFCE with gdm oddity

    I'm updating this for completeness.

    The "solution" to this problem is to add the line "enable-ssh-support" to $HOME/.gnupg/gpg-agent.conf . With that line, gpg-agent also acts as an ssh-agent. And that still works under gdm.

    Note that this "solution" (or work-around) possibly depends on your having gpg keys.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: XFCE with gdm oddity

    On 2011-10-04 17:16, nrickert wrote:
    >
    > I'm updating this for completeness.
    >
    > The "solution" to this problem is to add the line "enable-ssh-support"
    > to $HOME/.gnupg/gpg-agent.conf . With that line, gpg-agent also acts as
    > an ssh-agent. And that still works under gdm.


    Interesting. But gnome uses seahorse as agent. It reads that file?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,642
    Blog Entries
    3

    Default Re: XFCE with gdm oddity

    Quote Originally Posted by robin_listas View Post
    Interesting. But gnome uses seahorse as agent. It reads that file?
    This was with XFCE, not with gnome. I did not have a problem with gnome itself.

    When I look through the script "/usr/bin/startxfce4", which presumably starts XFCE, it seems to be trying to start gpg-agent as an ssh-agent, but something goes wrong. Perhaps my prior version of "gpg-agent.conf" was telling gpg-agent to ignore the command line option for ssh-support.

    Today, I installed gnome in 12.1 Beta1, and it is not using seahorse. It is using ssh-agent and gpg-agent. That's probably because I am currently using kdm rather than gdm. After a few days, I'll try switching to gdm to see the effect.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: XFCE with gdm oddity

    On 2011-10-05 03:46, nrickert wrote:
    >
    > robin_listas;2390502 Wrote:
    >> Interesting. But gnome uses seahorse as agent. It reads that file?

    > This was with XFCE, not with gnome. I did not have a problem with
    > gnome itself.


    GDM is from gnome. You are using GDM, and as so, a part of gnome - even if
    you don't log into gnome.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,642
    Blog Entries
    3

    Default Re: XFCE with gdm oddity

    Quote Originally Posted by robin_listas View Post
    GDM is from gnome. You are using GDM, and as so, a part of gnome - even if
    you don't log into gnome.
    Yes, I am aware of that. The fact remains that in XFCE, if started under gdm, "SSH_AUTH_SOCK" was not defined in my environment until I made the changes that I indicated in gpg-agent.conf. All was fine in KDE, in gnome and in LXDE, but the normal way that I use ssh did not work in XFCE.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: XFCE with gdm oddity

    On 2011-10-05 13:06, nrickert wrote:

    > Yes, I am aware of that. The fact remains that in XFCE, if started
    > under gdm, "SSH_AUTH_SOCK" was not defined in my environment until I
    > made the changes that I indicated in gpg-agent.conf. All was fine in
    > KDE, in gnome and in LXDE, but the normal way that I use ssh did not
    > work in XFCE.


    Yes, I see. It is curious.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •