Results 1 to 7 of 7

Thread: Not getting full monitor resolution

  1. #1

    Default Not getting full monitor resolution

    Got a system that I've been using for a long time now without any problems. Now suddenly it won't use a higher resolution than 1024x768.

    Found these in /var/log/messages
    Code:
    May 27 07:20:31 linux-6kbj kernel: [ 1566.737619] [drm:drm_edid_is_valid] *ERROR* EDID checksum is invalid, remainder is 54
    May 27 07:20:31 linux-6kbj kernel: [ 1566.737621] [drm:drm_edid_is_valid] *ERROR* Raw EDID:
    May 27 21:54:51 linux-6kbj kernel: [  139.449064] radeon 0000:03:00.0: VGA-1: EDID invalid.
    Xorg.0.log lists available modes up to 1024x768 and no higher. Monitor should do 1600 x ...something and was working fine till just lately. I never added any mods to the configuration and have not added any software other than recommended updates it quite a while.

    Any ideas what happened or how to fix it? I checked and the monitor/graphics card will still do upper resolutions with windoze so I'm guessing the hardware is alright.

    Using OpenSuse 11.3, 64bit, on a dual core athalon with a Sapphire ATI x1600 graphics card and a 22 inch flat screen that is supposed to go 1600 x 1050. Any suggestions appreciated.

    Thanks
    Greyangel

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Not getting full monitor resolution

    You could upload your Xorg.0.log contents to SUSE Paste (or similar), then post the link to it here. Looks like it doesn't like the checksum; maybe it tolerated this previously.

    It might be possible to coax the radeon driver to ignore any problematic EDID if necessary, by creating a minimal xorg.conf file. (I can try to guide you through this if necessary).

    Now, one thought I had: Did you possibly change cable connection recently, or have a KVM between the display and your computer perhaps? If not, maybe a recent update caused this (updated radeon driver).

  3. #3

    Default Re: Not getting full monitor resolution

    I've made no changes to the cable or anything else for that matter. There was an automatic update notification the other night and I went through the usual routine. The more I think about it the more I think that's what went wrong. I've done nothing else. I'd rather not start doing "workarounds" when something is so obviously broken. Is there a standard method for rolling back the updates? An update history log? I notice now that VO (Game) won't run full screen anymore either so a change in the graphic driver would probably cause that.

    Thanks

  4. #4

    Default Re: Not getting full monitor resolution

    Another note: Looking at my var/log/warn file, it appears the EDID message has been logging since I installed the system, so that would not appear to be part of the new behavior. Been looking for a log to list what changed. Anybody know where the updates get logged?

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Not getting full monitor resolution

    Quote Originally Posted by greyangel View Post
    Another note: Looking at my var/log/warn file, it appears the EDID message has been logging since I installed the system, so that would not appear to be part of the new behavior. Been looking for a log to list what changed. Anybody know where the updates get logged?
    if you wish to see a chronological list of installed rpms, simply type:
    Code:
    rpm -qa --last
    and if that scrolls by your screen too fast:
    Code:
    rpm -qa --last | less

  6. #6

    Default Re: Not getting full monitor resolution

    Quote Originally Posted by greyangel View Post
    There was an automatic update notification the other night and I went through the usual routine.
    Can you remember what update you installed before the issue occured. Sometimes some updates can cause some issues.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Not getting full monitor resolution

    Quote Originally Posted by greyangel View Post
    I've made no changes to the cable or anything else for that matter. There was an automatic update notification the other night and I went through the usual routine. The more I think about it the more I think that's what went wrong. I've done nothing else
    Further to what captain1988 noted, if you wish to pursue that line of investigation, you can obtain a chronological list of your updated rpms by typing:
    Code:
    rpm -qa --last
    and if that scrolls by too fast, then re-direct the output to a text file, and examine the text file in a text editor ... ie
    Code:
    rpm -qa --last > myrpms.txt
    and open up the new file 'myrpms.txt' with a text editor and look to see what rpms were installed immediately prior to the problem occurring.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •