Results 1 to 8 of 8

Thread: Laptop Screen Slowly darkens when watching a movie

  1. #1

    Default Laptop Screen Slowly darkens when watching a movie

    Hi

    Every time I watch a movie (online or though a movie player) the screen slowly darkens. But it doesn't do this when I am watching a movie though Totem. Is there any way I can disable this. I can't open the video URL (e.g. youtube video) though totem as it requires a codec.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Laptop Screen Slowly darkens when watching a movie

    Hi

    Every time I watch a movie (online or though a movie player) the screen slowly darkens. But it doesn't do this when I am watching a movie though Totem. Is there any way I can disable this. I can't open the video URL (e.g. youtube video) though totem as it requires a codec.
    You did not say what desktop that you use. For KDE, go to menu / Personnel Settings / Hardware / Power Management / Profiles and uncheck the top three options that have to do with your display for the profile you normally use. Also, make sure that auto screen brightness is turned off in your BIOS settings. For instance, Dell laptops have such a BIOS setting with a photocell controlling brightness by default.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Laptop Screen Slowly darkens when watching a movie

    Hi,

    Are you with GNOME or KDE.

  4. #4

    Default Re: Laptop Screen Slowly darkens when watching a movie

    Sorry

    Version 11.3 using Gnome

  5. #5
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Laptop Screen Slowly darkens when watching a movie

    To prevent the screen to turn off, install this :

    Code:
    zypper in gnome-applets-inhibit-powersave
    and add the applet to the panel. You can now disable screen turning off easily when you wacth a movie.

  6. #6

    Default Re: Laptop Screen Slowly darkens when watching a movie

    I have discovered it was the screen saver. I disabled it and the video plays fine. I tried to put that command in terminal but it requires root Privileges. How do I access the console as root?

  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Laptop Screen Slowly darkens when watching a movie

    I have discovered it was the screen saver. I disabled it and the video plays fine. I tried to put that command in terminal but it requires root Privileges. How do I access the console as root?
    You can add the pre-command sudo in front of a command you wish to run as root, then enter the root password and the following command will be ran as root. Using sudo does not append the paths for commands not in your user path. For instance, to use the command fdisk with sudo, I must append the path to fdisk as in:

    Code:
    sudo /sbin/fdisk -l
    The second way is to use su - to become root with root's paths as in the command sequence:

    Code:
    su -
    password:
    fdisk -l
    exit
    The exit command then relinquishes root authority. Always be careful using root as it can allow you to do things you might not really want to do.

    Thank You,


    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  8. #8

    Default Re: Laptop Screen Slowly darkens when watching a movie

    When I went to install it it says:

    GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
    Loading repository data...
    Reading installed packages...
    'gnome-applets-inhibit-powersave' is already installed.
    No update candidate for 'gnome-applets-inhibit-powersave-2.32.0-7.10.3.i586'. The highest available version is already installed.
    Resolving package dependencies...

    But still goes to the screensaver.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •