Results 1 to 3 of 3

Thread: Adobe Air will not install on OpenSuse11.4

  1. #1
    Join Date
    Oct 2008
    Location
    Oslo, Norway
    Posts
    43

    Default Adobe Air will not install on OpenSuse11.4

    Hi All
    I'm in the unfortunate position that I have to run an app that is written in Adobe Air.

    Worked fine on opensuse11.1, but not on 11.4. It complains about kwallet or gnome-keyring, which I've installed. Anyone got an idea.

    Code:
    linux-8il4:/home/mortenb/Downloads # rpm -Uvh adobeair.i386.rpm
    warning: adobeair.i386.rpm: Header V3 DSA/SHA1 Signature, key ID f6777c67: NOKEY
    Preparing...                ########################################### [100%]
    
     Running 32-bit AIR on 64-bit systems has not been fully tested. However, 32-bit AIR is expected to run on 64-bit systems if they have the required 32-bit libraries and packages installed. 
     The following links describe how to install or update AIR 2.6 on 64-bit versions of Ubuntu 9.10, Fedora Core 12 and OpenSuse 11.2. 
     Installing Adobe AIR 2.6 on 64-bit Linux visit Install Adobe AIR 2 on 64-bit Linux distributions 
     Updating to Adobe AIR 2.6 on 64-bit Linux visit Install Adobe AIR 2 on 64-bit Linux distributions
    Adobe AIR could not be installed. Either gnome-keyring or Kwallet must be installed prior to installing Adobe AIR.
    error: %pre(adobeair-2.6.0-19140.i386) scriptlet failed, exit status 1
    error:   install: %pre scriptlet failed (2), skipping adobeair-2.6.0-19140
    linux-8il4:/home/mortenb/Downloads # rpm -qa | grep kwallet
    kwalletmanager-4.6.0-3.4.x86_64
    linux-8il4:/home/mortenb/Downloads # rpm -qa | grep gnome-keyring
    libgnome-keyring0-2.32.0-4.1.x86_64
    gnome-keyring-pam-2.32.1-8.4.x86_64
    libgnome-keyring-devel-2.32.0-4.1.x86_64
    gnome-keyring-2.32.1-8.4.x86_64
    
     
    linux-8il4:/home/mortenb/Downloads # rpm -pqi adobeair.i386.rpm
    warning: adobeair.i386.rpm: Header V3 DSA/SHA1 Signature, key ID f6777c67: NOKEY
    Name        : adobeair                     Relocations: (not relocatable)
    Version     : 2.6.0                             Vendor: Adobe Systems, Incorporated
    Release     : 19140                         Build Date: Wed Apr 13 02:33:26 2011
    Install Date: (not installed)               Build Host: localhost.localdomain
    Group       : Applications                  Source RPM: adobeair-2.6.0-19140.src.rpm
    Size        : 46265024                         License: Commercial
    Signature   : DSA/SHA1, Wed Apr 13 19:03:33 2011, Key ID 3a69bd24f6777c67
    Packager    : Adobe Systems, Incorporated
    URL         : Adobe
    Summary     : Adobe AIR
    Description :
    Adobe AIR 2
    Distribution: (none)
    Thanks

  2. #2
    Join Date
    Oct 2008
    Location
    Oslo, Norway
    Posts
    43

    Default Re: Adobe Air will not install on OpenSuse11.4

    This dirty trick solves it:

    ln -s /usr/lib64/kde4/kcm_kwallet.so /usr/lib/libkwalletclient.so.1

  3. #3
    Join Date
    Dec 2012
    Location
    Drochia, Republic of Moldova
    Posts
    2

    Thumbs up Re: Adobe Air will not install on OpenSuse11.4

    Quote Originally Posted by mortenb123 View Post
    This dirty trick solves it:

    ln -s /usr/lib64/kde4/kcm_kwallet.so /usr/lib/libkwalletclient.so.1

    Thanks a lot! It works!!!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •