Results 1 to 4 of 4

Thread: screensaver images in gnome

  1. #1

    Default screensaver images in gnome

    So I've been playing with the screensaver settings in my gnome 2.32.1 desktop in opensuse 11.4 and the default screensaver is gnome-screensaver. Many of the screensaver options have the ability to display pictures but for some reason they all show up with the red flame on a monitor image. So have done a ton of digging on the web and most of the solutions consisted of placing all my desired images in ~/Pictures folder. I did that but they still won't show up in the screensaver.

    Other suggestions was to use xscreensaver instead of gnome-screensaver so I downloaded it and ran xscreensaver-demo to configure. Under the advanced tab, there is a field for pictures location. So I put in /home/userid/Pictures and save. But the images still won't show up.

    So either I'm doing something wrong or there is a bug in gnome that affects both screensaver packages. Is it former (probable) or latter (possible)????

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: screensaver images in gnome

    On 2011-05-27 21:36, jgosney wrote:
    > So either I'm doing something wrong or there is a bug in gnome that
    > affects both screensaver packages. Is it former (probable) or latter
    > (possible)????


    Permissions of that folder are correct?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3

    Default Re: screensaver images in gnome

    Permissions of my ~/Pictures folder is set to 755.

  4. #4

    Default Re: screensaver images in gnome

    I found it!!!! After doing a lot of googling and following a link to a link to a link, I found this tidbit.

    Go to your ~/.gconf/apps/gnome-screensaver directory. In there will be a single file: %gconf.xml. Within that file, about halfway down, is a line that says:

    <stringvalue>screensavers-personal-slideshow</stringvalue>

    Change that line to say

    <stringvalue>screensavers-personal-slideshow --location=/home/userid/Pictures/</stringvalue> (where the path is obviously the path to your Pictures folder.

    I tried this on two different OpenSuSE 11.4 machines and it worked on both.

    However, note that this file is rewritten every time you change a setting on your gnome-screensaver so if you tweak the settings through the gui, you'll need to re-edit this file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •