Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: national characters displaying..?

  1. #1

    Default national characters displaying..?

    I'm using OpenSuse 11.3, and I installed oracle into it..
    I've read previously that linux uses UTF-8, but..

    'locale' gives me result:
    LANG=en_GB.UTF-8
    LC_CTYPE="en_GB.UTF-8"
    LC_NUMERIC="en_GB.UTF-8"
    LC_TIME="en_GB.UTF-8"
    LC_COLLATE="en_GB.UTF-8"
    LC_MONETARY="en_GB.UTF-8"
    LC_MESSAGES="en_GB.UTF-8"
    LC_PAPER="en_GB.UTF-8"
    LC_NAME="en_GB.UTF-8"
    LC_ADDRESS="en_GB.UTF-8"
    LC_TELEPHONE="en_GB.UTF-8"
    LC_MEASUREMENT="en_GB.UTF-8"
    LC_IDENTIFICATION="en_GB.UTF-8"
    LC_ALL=


    when I'm in kde, using XTerm (or anything else), I can see my national characters..
    but, when I'm connecting through shell console, there no national characters..

    why?

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: national characters displaying..?

    On 2011-05-27 21:06, bongo zg wrote:
    > but, when I'm connecting through shell console, there no national
    > characters..


    What "shell console"? What operating system and version?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3

    Default Re: national characters displaying..?

    OpenSuse 11.3

    shell console - like when you press ctrl+alt+f3

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: national characters displaying..?

    On 2011-05-27 22:06, bongo zg wrote:
    >
    > OpenSuse 11.3
    >
    > shell console - like when you press ctrl+alt+f3


    Ah, the virtual terminal in the same machine. That's different.

    What is the 'locale' output there?

    Can you type and and/or read the special characters?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: national characters displaying..?

    And what is a "national character"? can you give an example?
    Henk van Velden

  6. #6

    Default Re: national characters displaying..?

    the locale output is the same like the one from xterm/kde

    special characters? not in the console (ctrl+alt+f3)

  7. #7

    Default Re: national characters displaying..?

    đ or Đ (croatian characters)..
    ž or Ž

    actually, the only character that I see correct in shell is Đ (if you see them on screen)

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: national characters displaying..?

    bongo zg wrote:

    >
    > đ or Đ (croatian characters)..
    > ž or Ž
    >
    > actually, the only character that I see correct in shell is Đ (if you
    > see them on screen)
    >

    I think what you need to do is to adjust the settings for the console font.
    The config file is /etc/sysconfig/console, it has an entry (in my case,
    yours may be different)
    CONSOLE_FONT="lat9w-16.psfu"
    Which fonts you can use you will see by inspecting the folder
    /usr/share/kbd/consolefonts
    check which font supports the special characterset for your locale.
    You need to run
    Code:
    /etc/init.d/kbd reload
    as root afterwards (or reboot).

    You can also use yast -> /etc/sysconfig editor -> hardware -> console for
    the settings

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: national characters displaying..?

    I want to add that, when you are on a virtual terminal (not in X) you can
    show the characters of the font with the command
    Code:
    showconsolefont
    so that you have feedback what it contains.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: national characters displaying..?

    On 2011-05-28 00:06, bongo zg wrote:
    > special characters? not in the console (ctrl+alt+f3)


    Neither read nor write?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •