It appears that I am the first idiot to at least ask how to undo making the clock transparent to the point you can no longer see it.
I can not even see the settings menu to fix it. any command line options to reconfigure the task-bar clock?

KDE 4 Opensuse 11.4