Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: openSUSE 11.1 XDM/KDM and pam_ssh bug?

  1. #1
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    280

    Exclamation openSUSE 11.1 XDM/KDM and pam_ssh bug?

    Hallo,
    I cannot fill a bug report on that, so, I will post it here.
    Environment:
    openSUSE 11.1 Evergreen, 64bit
    KDE 3.5.10
    pam_ssh.
    Users log on the system either with their passphrase (if they have one) or their Linux password.

    Issue: When a user log-on with their Linux password, when he exits KDE, XDM crashes.
    Users using passphrase for log-on have no problem.

    pam_ssh configuration:
    /etc/pam.d/login:
    Code:
    /etc/pam.d/login
    #%PAM-1.0
    auth     requisite      pam_nologin.so
    auth     [user_unknown=ignore success=ok ignore=ignore auth_err=die default=bad]        pam_securetty.so
    auth     include        common-auth
    account  include        common-account
    password include        common-password
    session  required       pam_loginuid.so
    session  include        common-session
    session  required       pam_lastlog.so  nowtmp
    session  optional       pam_mail.so standard
    /etc/pam.d/xdm:
    Code:
    #%PAM-1.0
    auth     sufficient     pam_ssh.so
    auth     include        common-auth
    account  include        common-account
    password include        common-password
    session  required       pam_loginuid.so
    session  include        common-session
    session  sufficient     pam_ssh.so
    Error reported in /var/log messages:
    Code:
    May 27 08:37:20 peter kdm[2318]: Unknown session exit code 0 (sig 11) from manager process
    May 27 08:37:20 peter kernel: kdm[2875]: segfault at 18 ip 00007f52d6ed6708 sp 00007fffdca3de10 error 4 in libc-2.9.so[7f52d6e61000+14f000]

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: openSUSE 11.1 XDM/KDM and pam_ssh bug?

    On 2011-05-27 08:36, tpe wrote:
    > Hallo,
    > I cannot fill a bug report on that, so, I will post it here.


    You can not report Bugs here, they will be ignored. There are no devs here,
    only users.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    280

    Default Απ: Re: openSUSE 11.1 XDM/KDM and pam_ssh bug?

    Yes, I know. Since the bugzilla is closed, I cannot post a bug. BUT, since the issue seems to be known (Fedora and Ubuntu forums had a lot of entries for KDM and PAM (not for pam_ssh though) with the same behavior. So, I was hoping that some one could see it and post a possible solution.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: openSUSE 11.1 XDM/KDM and pam_ssh bug?

    On 2011-05-29 18:06, tpe wrote:
    >
    > Yes, I know. Since the bugzilla is closed, I cannot post a bug.


    Sure you can. If the problem is still happening you can open a bug about it.

    Although I don't know if evergreen is a proper target. You would have to
    test and report it against 11.4 or factory.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  5. #5
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    280

    Default Απ: Re: openSUSE 11.1 XDM/KDM and pam_ssh bug?

    Sorry for the late answer.
    I don't have 11.4 and actually I don't plan to do so for some more time. I still miss dear a lot of functionality and applications from KDE 3.5...

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: openSUSE 11.1 XDM/KDM and pam_ssh bug?

    On 2011-06-06 19:36, tpe wrote:
    > I still miss dear a lot of functionality and applications from KDE
    > 3.5...


    There is KDE3 for 11.4 in a repo. I still use some KDE3 apps.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #7
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    280

    Default Απ: Re: openSUSE 11.1 XDM/KDM and pam_ssh bug?

    Quote Originally Posted by robin_listas View Post
    On 2011-06-06 19:36, tpe wrote:
    > I still miss dear a lot of functionality and applications from KDE
    > 3.5...


    There is KDE3 for 11.4 in a repo. I still use some KDE3 apps.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)
    --Offtopic---
    I want the whole 3.5... For example It is a real pain to install 3.5 with 11.4. I tried it in a VM and I had huge issues. Anyway.
    --End offtopic---

  8. #8
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    280

    Default Απ: Re: openSUSE 11.1 XDM/KDM and pam_ssh bug? - SOLVED

    After the latest upgrade from Evergreen (sorry, it was automatic, I don't know what packages changed), everything is fine now.

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: openSUSE 11.1 XDM/KDM and pam_ssh bug?

    On 2011-06-17 20:06, tpe wrote:
    >
    > After the latest upgrade from Evergreen (sorry, it was automatic, I
    > don't know what packages changed), everything is fine now.


    Automatic is a bad idea. But there are logs.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  10. #10
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    280

    Default Απ: Re: openSUSE 11.1 XDM/KDM and pam_ssh bug?

    Good idea. Where are the logs?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •