Results 1 to 5 of 5

Thread: Synaptic SynPs/2 tapping gets disabled automatically

  1. #1

    Default Synaptic SynPs/2 tapping gets disabled automatically

    Hi, I am using openSUSE 11.4 with KDE4.6. I have enabled the touchpad tapping, and have assigned it to left button click. When I login, the tapping takes effect, but gets disabled very soon. If i write the value using synclient tapbutton=1, the tapping starts to function again, but this also gets disabled. I get a feeling, the synaptics config file is getting reloaded to default values regularly.
    How to permanently add the settings to the config file, it seems the kde destop config utility is not helping.


    Thanks in advance
    Krishna

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Synaptic SynPs/2 tapping gets disabled automatically

    On 05/27/2011 07:36 AM, contactbkb wrote:
    >
    > When I login, the tapping takes effect, but gets disabled very soon.


    look at Personal Settings - Configure Desktop > Input Devices > Touchpad

    now first i wanna tell you that the options shown there vary from
    machine to machine based on hardware and driver capability...so, you may
    not have (like i do) a section named "Automatic touchpad control"..

    if you have click there and maybe you will also have controls for
    "Automatically switch off touchpad on keyboard activity" and a slider to
    set how long the touchpad cannot be used after the last key press...mine
    can be set for no touchpad use for TEN seconds after the last key press,
    which would certainly feel like it was off, forever..

    so, you could turn off the automatic switch off and see if that
    helps...or, you could decrease the time to something under one second
    and have the ability to type without accidentally touching the keypad
    and messing things up..

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  3. #3

    Default Re: Synaptic SynPs/2 tapping gets disabled automatically

    Hi denver,
    I guess what you mention is automatic touchpad disable when typing. My trouble is that suddenly "TapButton1" field in synaptics gets disabled. I am confused as to what is the actualt config file. there is one in /etc/X11/xorg.conf.d/50-synatics and other in .kde4/share/config/synaptics-default. which one is the config file.

    krishna

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Synaptic SynPs/2 tapping gets disabled automatically

    On 05/28/2011 07:06 AM, contactbkb wrote:

    > actualt config file. there is
    > one in /etc/X11/xorg.conf.d/50-synatics and other in
    > .kde4/share/config/synaptics-default. which one is the config file.


    take my thoughts as 'advice' only after reading the sig in my caveat
    (because i am guessing, and maybe a real guru will come along later on
    this weekend and give you some good advice)

    personally, i almost always use the GUI tools to do such
    configs...however, i've looked in both of those files here and decided i
    leave the one in /etc alone and fiddle with the one in ~/.kde

    if if were me i'd make a backup of the orginal before editing...or use a
    tool like kwrite which will do that automatically...but, if you edit and
    save twice the original is gone!

    do you know how to recover original config files from a run level three
    command line? if not, learn before you lock yourself out.

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  5. #5

    Default Re: Synaptic SynPs/2 tapping gets disabled automatically

    okay. I will do that. I see that even though the gui settings are correct, the actual values seen by the synaptics program is different. I shall take backups and try out.
    Thanks for the info..
    ciao

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •