Results 1 to 5 of 5

Thread: Error when installing RPM package

  1. #1
    Join Date
    May 2011
    Location
    Austria
    Posts
    9

    Default Error when installing RPM package

    Hello,

    when I am trying to install a RPM package I get the following error:

    failed to install file: [PK_TMP_DIR|dir:///var/tmp/TmpDir.w29lVZ] Repository already exists

    It tried to install DBVisualizer and Adobe Reader 9 and get the same error. Just the directory is different. How do I solve this? I tried to delete the mentioned directories but I can't find them on the file system.

    Thanks for your time =)

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Error when installing RPM package

    On 2011-05-26 22:36, urbaindepuce wrote:
    >
    > Hello,
    >
    > when I am trying to install a RPM package I get the following error:
    >
    > failed to install file: [PK_TMP_DIR|dir:///var/tmp/TmpDir.w29lVZ]
    > Repository already exists


    Post the output of "zypper lr --details" between code tags (very
    important!). Advanced editor, #.

    My guess is you installed something by the "one click" method, and that is
    a remnant. You have to remove the extra repo.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: Error when installing RPM package

    Code:
    sudo rpm --rebuilddb
    and/or open Yast >Software Repositories and remove
    PK_TMP_DIR entry.
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  4. #4
    Join Date
    May 2011
    Location
    Austria
    Posts
    9

    Default Re: Error when installing RPM package

    Thank you. Removing the repository solved the problem.

  5. #5
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: Error when installing RPM package

    a "Thank You" goes a long way.

    You are Very Welcome.
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •