Results 1 to 6 of 6

Thread: Canon i560 inkjet Printer..Drivers

  1. #1

    Default Canon i560 inkjet Printer..Drivers

    Hi I wonder if someone can help?I am new to this group and to Open Suse but not new to Linux as I am using Ubuntu & Kubuntu.and have also trialed Fedora 14.
    I am trying to install the Linux RPM Drivers& The CUPS Driver for this Printer which I have found on the Canon Asia site .The Printer has been reccognised by the Os but when I try to install them I get a message that the installation has failed because libgdk-1.12.so.0 is not installed?[I understand that this software is part of the GIMP Toolbox]These Drivers installed without difficulty in Fedora??
    Any help appreciated Michael

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Canon i560 inkjet Printer..Drivers

    Do you have the package gtk (not gtk2 or gtk3 which you most probably
    already have but just gtk which contains this old library) installed?

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Canon i560 inkjet Printer..Drivers

    martin_helm wrote:

    > Do you have the package gtk (not gtk2 or gtk3 which you most probably
    > already have but just gtk which contains this old library) installed?
    >

    Since you did not provide the info if you are on 32 or 64bit and if the
    driver is only 32 bit but needs to run on a 64 bit system or whatever I want
    to add:
    It can also be that you need the package gtk-32bit

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  4. #4

    Default Re: Canon i560 inkjet Printer..Drivers

    Martin Hi the o /s is 32bit,I have gtk2 installed but not gtk,do I need gtk as well?

    Hope that helps

    michael

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Canon i560 inkjet Printer..Drivers

    thomastt37 wrote:

    >
    > Martin Hi the o /s is 32bit,I have gtk2 installed but not gtk,do I need
    > gtk as well?
    >
    > Hope that helps
    >
    > michael
    >

    Yes that is what I said install gtk. gtk2 is for other apps which use newer
    libraries DO NOT uninstall it. Just install gtk in addition.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  6. #6
    Join Date
    Oct 2008
    Location
    Brisbane
    Posts
    310

    Default Re: Canon i560 inkjet Printer..Drivers

    I have an ip3300 which replaced a i550. Since I have had the printer I have been able to install the drivers to make it work under openSuse. Unfortunately the drivers were developed for 10.3 and Canon do not seem to want to update them and so there has been a divergence between drivers and OS. With 11.4 I thought I was totally stuffed as nothing would load. After a fair bit of messing around, including using 'similar' CUPS drivers which were, to be honest, rubbish, I hit on the following which allowed me to install the ip3300 drivers.

    Install in order:


    libxml-1.8.17-11
    bundle-lang-gnome-ar-11.2-20.21.2
    glib-1.2.10-740.2
    gtk-1.2.10-1089.2
    libpng3-1.2.39-2.2
    cnijfilter-common-2.70-1
    cnijfilter-ip3300-2.70-1



    Your final file will be cnijfilter-i560-2.70.* or which ever the printer specific driver is.


    I then went into Yast and locked the versions of all those files, There is a whinge at the moment aboutbundle-lang-gnome-ar-11.2-20.21.2 when I go to do an upgrade, to which I click 'do not install bundle-lang-gnome-ar-11.4-5.13.1.noarch' and all is well.
    I'm just happy the printer works
    It is dangerous to be right when the government is wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •