Results 1 to 5 of 5

Thread: No Login Screen with openSUSE 11.4(Suse Studio Build) with ATi Mobility Radeon HD 4250

  1. #1
    Join Date
    Apr 2011
    Location
    Nairobi, Kenya
    Posts
    45

    Question No Login Screen with openSUSE 11.4(Suse Studio Build) with ATi Mobility Radeon HD 4250

    Hello, I finished making a custom build OS of openSUSE 11.4 using suse studio but when I tried running the LIVE DVD in a laptop with an ATi Mobility Radeon HD 4250, I got a black screen. Everything from the word go seemed fine showing everything from the loading Kernel message, but the screen that is supposed to show the user accounts is surprisingly absent and only a black screen in its place.

    I have only seen this problem with ATi graphics, Intel graphics work just fine. I haven't tested it on a laptop with nvidia.

    I'm using the default openSUSE 11.4 Kernel (Kernel-Desktop 2.6.37.6-0.5.1), Xorg-X11-driver-video-radeonhd 1.3.0_20100512_80ba041-2.1, Mesa 7.10.2-7.3.1, Xorg-X11 7.6-43.44.1.

    I have listed these few packages contained in the build, but I'm not sure where to look or what I may be missing.

    I would be extremely grateful for any suggestions.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No Login Screen with openSUSE 11.4(Suse Studio Build) with ATi Mobility Radeon HD 4250

    I don't know the 1st thing about an openSUSE studio build.

    But for a nominal openSUSE-11.4 when booting from a liveCD (which is different from your liveDVD you created) openSUSE when encountering AMD radeon hardware will try and boot to the open source 'radeon' video driver. That driver is located in the rpm xorg-x11-driver-video. That should nominally boot/configure X automatically thanks to modesetting in the kernel.

    If that kernel modesetting (KMS) fails, then one can try and change the driver used when booting to the 'radeonhd' open source video driver by specifying the boot code (in the initial grub splash boot menu):
    Code:
    nomodeset
    The radeonhd driver is on the rpm xorg-x11-driver-video-radeonhd rpm.

    If that also fails, then one can instead try to boot to the 'fbdev' graphic driver by specifying the boot code:
    Code:
    x11failsafe
    where the fbdev driver comes in the xorg-x11-driver-video rpm.

    Not sure if that helps, but your statement that you 'don't know where to look' makes me wonder if you understand this basic graphical driver boot setup in openSUSE-11.4.

  3. #3
    Join Date
    Apr 2011
    Location
    Nairobi, Kenya
    Posts
    45

    Default Re: No Login Screen with openSUSE 11.4(Suse Studio Build) with ATi Mobility Radeon HD 4250

    Quote Originally Posted by oldcpu View Post

    Not sure if that helps, but your statement that you 'don't know where to look' makes me wonder if you understand this basic graphical driver boot setup in openSUSE-11.4.
    You are right oldcpu, and thank you for the suggestions. I will try them as soon as possible and post back the results.

    I am a 3rd year Bsc Computer Technology student at the Jomo Kenyatta University of Agriculture and Technology (JKUAT) in Kenya. I started making respins and custom builds with Fedora 11 all the way to 13 but I had to change and start using suse studio build service because the bandwidth requirements for making a Fedora respin were too high. Here in campus many students would like to run like but due to limited access to the Internet, most of them shy off this great OS. I also found it very challenging to install all the necessary non-free multimedia packages etc, normally needed every time my friends or my fellow students asked that I install Linux for them. For these reasons, I started making custom builds, and so far I have been quite successful. By downloading a copy of the finished build and distributing it by giving it out and have it duplicated for free, most of the students get to run Linux without worrying about Internet access and long hours downloading the OS and other extra packages.

    I have tried and have been reading various articles to improve my scope of understanding. I hope to one day master Linux like you and others.

    Thanks again oldcpu.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No Login Screen with openSUSE 11.4(Suse Studio Build) with ATi Mobility Radeon HD 4250

    Quote Originally Posted by Mwanafunzi View Post
    Here in campus many students would like to run like but due to limited access to the Internet, most of them shy off this great OS. I also found it very challenging to install all the necessary non-free multimedia packages etc, normally needed every time my friends or my fellow students asked that I install Linux for them. For these reasons, I started making custom builds, and so far I have been quite successful. By downloading a copy of the finished build and distributing it by giving it out and have it duplicated for free, most of the students get to run Linux without worrying about Internet access and long hours downloading the OS and other extra packages.
    Wow! Great work.

    Reference multimedia (for those with limited internet) don't forget this package: Multimedia Pack Portable for openSUSE 11.4 put together by user Easgs.

    Quote Originally Posted by Mwanafunzi View Post
    I have tried and have been reading various articles to improve my scope of understanding. I hope to one day master Linux like you and others.
    I also hope to some day master Linux !

  5. #5
    Join Date
    Apr 2011
    Location
    Nairobi, Kenya
    Posts
    45

    Default Re: No Login Screen with openSUSE 11.4(Suse Studio Build) with ATi Mobility Radeon HD 4250

    Thank you oldcpu. I have already started to look at the "Multimedia Pack Portable for openSUSE" reference you gave me. Its really great, thank you.

    Thanks Again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •