Results 1 to 6 of 6

Thread: Configuring Caching Proxy Server ||||||| openSUSE 11.4

  1. #1
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Default Configuring Caching Proxy Server ||||||| openSUSE 11.4

    Hi,

    I want to configure proxy caching on my openSUSE box

    Yast >>> Proxy >>> I need help from here on .....

    Please guide me.
    openSUSE Leap 15
    You aren't rich until you have something that money can't buy.

  2. #2
    Join Date
    Dec 2009
    Location
    Moldova
    Posts
    130

    Default Re: Configuring Caching Proxy Server ||||||| openSUSE 11.4

    1. if you want to set up proxy settings on your openSUSE desktop then on Yast/Proxy/Enable proxy http proxy URL enter the url with port for example http://192.168.1.1:3128. This is for yast, then go Configure Desktop/Network Settings/Proxy set Manually specify the proxy settings push setup and set them in the same way (the port must be indicate in separate field).Check Use the same proxy for all protocols (unless you have different proxy for each protocol) for both Yast and KDE Desktop settings.

    2. If you want to configure a proxy server then a standard package is squid + yast2-squid for yast module. Do not install squid3 if you want to setup it with Yast. After installation of these packages fo in Yast/Squid, set service start on boot (if you need it permanently to work), open ports on firewall and the rest of settings like access control if you want. After saving the settings you can use the proxy server from other machines from you local network by indicating in their proxy settings ip address of your proxy server and port 3128.

  3. #3
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Default Re: Configuring Caching Proxy Server ||||||| openSUSE 11.4

    If you want to configure a proxy server then a standard package is squid + yast2-squid for yast module.
    Done !!!

    Thank you.
    openSUSE Leap 15
    You aren't rich until you have something that money can't buy.

  4. #4
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Default Re: Configuring Caching Proxy Server ||||||| openSUSE 11.4

    The proxy is working fine .......I have applied it system wide vis yast.

    The problem is with the game called second life.

    The game starts fine but I cant instant message anybody.

    So, I was thinking of using the proxy for specific apps rather than system wide.

    Setting proxy for Firefox / Google Chrome & Opera is quite easy.

    How do I configure the package management system of openSUSE to use proxy ?
    openSUSE Leap 15
    You aren't rich until you have something that money can't buy.

  5. #5
    Join Date
    Dec 2009
    Location
    Moldova
    Posts
    130

    Default Re: Configuring Caching Proxy Server ||||||| openSUSE 11.4

    The problem is with the game called second life.
    The game starts fine but I cant instant message anybody.
    the application should be able to work with proxy and to have respective settings. If it was not designed to do this then you can't, just using NAT.
    How do I configure the package management system of openSUSE to use proxy ?
    Yast/Proxy/Enable proxy http proxy URL, enter the url with port for example http://192.168.1.1:3128.

  6. #6
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Default Re: Configuring Caching Proxy Server ||||||| openSUSE 11.4

    the application should be able to work with proxy
    Yes, you are right there. It is actually some bug in the viewer of the game which is causing the issue. Because it started to trouble me right after I configured proxy caching I got confused. Sorry about that.

    Yast/Proxy/Enable proxy http proxy URL, enter the url with port for example http://192.168.1.1:3128.
    Thanks for that info ....Surely an addition in my knowledge base.
    openSUSE Leap 15
    You aren't rich until you have something that money can't buy.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •