Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: knetworkmanager is not starting automatically on start up

  1. #1
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default knetworkmanager is not starting automatically on start up

    hi kde knetworkmanager is not starting on startup.i am starting this manually every time on login to connect to network..how to make it start automatically?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: knetworkmanager is not starting automatically on start up

    Did you turn it off?

    Try: Personal Settings -->Startup and Shutdown --> Service Manager

    Make sure that "Network Manager User Settings Service" is checked.

    The above is for opensuse 11.4, KDE 4.6.0 . The wording might be different in other versions.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: knetworkmanager is not starting automatically on start up

    there is no network manager user settings service in servicemanager.what should i do next?

  4. #4
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: knetworkmanager is not starting automatically on start up

    I would recommend installing "plasmoid-networkmanagent" packages using Yast. This will replace the old network manager.

    Then you will see it show up in Personal Settings -->Startup and Shutdown.


    Cheers!

    Romanator
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  5. #5
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: knetworkmanager is not starting automatically on start up

    In addition, I would recommend updating the plasmoid-networkmanagement using UpdatedApps repo provided below:

    http://download.opensuse.org/reposit...openSUSE_11.4/

    There is a better version.
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: knetworkmanager is not starting automatically on start up

    Quote Originally Posted by vike4 View Post
    there is no network manager user settings service in servicemanager.what should i do next?
    Yes, you are correct. My mistake. As others have suggested, you should install the plasmoid networkmanager applet. That will replace knetworkmanager. And it is the plasmoid that shows up in service manager.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: knetworkmanager is not starting automatically on start up

    Good to hear. You should see an improvement with the newer plasmoid-networkmanagement applet.

    Also, I would recommend updating to 4.6.3. There are a lot of bug fixes and improvements.
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  8. #8
    Join Date
    Mar 2011
    Location
    India
    Posts
    318

    Default Re: knetworkmanager is not starting automatically on start up

    i can't use plasmoid.because i am using mobile broadband to connect with network.if i connect mobile broadband using knetwork it will ask me contry,service provider to connect.my work will be simple and it has the correct firmware for my mobile device.plasmoid has the above?

  9. #9
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: knetworkmanager is not starting automatically on start up

    If using mobile broadband you need to navigate to:


    • Configure Desktop --> Network Settings --> Select the Mobile Broadband tab
    • Click on the Add button and fill out the empty fields.


    It should work every time. You may have to reboot your system to see the changes.
    Please ensure that you add the UpdatedApps repository and update the plasmoid-networkmanagement applet.
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: knetworkmanager is not starting automatically on start up

    What contains your file
    ~/.kde4/share/config/networkmanagementrc
    It should have an entry

    [General]
    Autostart=true

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •