Results 1 to 2 of 2

Thread: No keyboard-input on X

  1. #1

    Default No keyboard-input on X

    I have 2 servers connected to 1 monitor and 1 keyboard. Both servers where running on openSUSE 11.3. Everything worked fine until i upgraded 1 server to openSUSE 11.4.

    Now my keyboard doesn't work anymore. When I boot-up I can hit enter to boot into desktop but after SUSE begins to load, the keyboard doesn't work anymore.

    A usb-keyboard works fine and the hardware list shows the keyboard.

    What have caused this problem ? anybody experienced the same problem ?

    /etc/X11/xorg.conf.d/90-keytable.conf
    Section "InputClass"
    Identifier "LocalKeyboard"
    MatchIsKeyboard "on"
    Option "XkbLayout" "be"
    Option "XkbOptions" "caps:capslock"
    EndSection

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: No keyboard-input on X

    Normally I blame the BIOS if the keyboard does not work in Grub menu and I blame the kernel if it does not work in openSUSE. If I find swiching the keyboard out from PS/2 to USB and it works, I just keep using the USB keyboard I suppose. If you have a PS/2 KVM switch, it might even be time to get a USB based model. Be that as it may, I would try a new kernel such as 2.6.39 from Kernel/Head. You can get it from this repository:

    Index of /repositories/Kernel:/HEAD/openSUSE_11.4/x86_64

    Second, I would enable the ability to maintain multiple kernels using this example:

    edit the file /etc/zypp/zypp.conf to say:

    Code:
       ##
        ## Packages which can be installed in different versions at the same time.
        ##
        ## Packages are selected either by name, or by provides. In the later case
        ## the string must start with "provides:" immediately followed by the capability.
        ##
        ## Example:
        ##    kernel                - just packages whith name 'kernel'
        ##    provides:multiversion(kernel)   - all packages providing 'multiversion(kernel)'
        ##                      (kenel and kmp packages should do this)
        ## Valid values:
        ##    Comma separated list of packages.
        ##
        ## Default value:
        ##    empty
        ##
        # multiversion = provides:multiversion(kernel)
    
        multiversion = kernel-desktop
    If you use KDE, you can use the menu Run Command:

    Code:
        kdesu kwrite /etc/zypp/zypp.conf
    The file zypp.conf has a whole lot more in it than the small portion shown above. You are adding only the line shown in bold (and it will not be in bold in your file after being added). So be careful not to mess anything else up.

    If you would prefer to compile your own kernel, I have a script file that can do that. You can download kernel 2.6.39 from here: http://www.kernel.org/pub/linux/kern...2.6.39.tar.bz2

    My bash script is located here in message #62:

    S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.00 - Page 7

    The sakc script leaves your default kernel unchanged and you have the option to go through the kernel settings to see if something you your keyboard there might even be helpful.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •