Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: wxmaxima cannot connect to maxima

  1. #1

    Default wxmaxima cannot connect to maxima

    Hello
    Recently i installed:
    maxima-5.17.0-1.2.x86_64
    wxMaxima-11.04.0-16.1.x86_64

    After wxMaxima start, I can see on status bar(bottom right)
    "Maxima process terminated"
    when I try manually restart maxima, menu: Maxima->Restart Maxima
    I see "Maxima started, waiting for connection..." and waiting waiting and nothing happens.
    but Maxima called from command line works fine.
    what could be wrong ?
    - connection port (default 4010)
    - locallhost entry in /etc/hosts (I have one)
    - firewall (standard suse setting without any extra settings) I tryed temporarily switch off

    Thanks for any advices.

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: wxmaxima cannot connect to maxima

    Works here but my maxima is maxima-5.24.0-22.1.x86_64 from the education
    repository.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  3. #3

    Default Re: wxmaxima cannot connect to maxima

    Hello martin_helm

    I have just added education repo:
    Index of /repositories/Education/openSUSE_11.4
    but here the most recent version of maxima is 5.23.2-1.2
    Your version is available on science repo:
    Index of /repositories/science/openSUSE_11.4
    but here is another problem, if I try to instal wxmaxima from
    this repo, I get dependencies error:
    Code:
    zypper in -D -r 14( it is my science repo number) wxmaxima
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides gnuplot needed by wxMaxima-11.04.0-16.1.x86_64
     Solution 1: do not install wxMaxima-11.04.0-16.1.x86_64
     Solution 2: break wxMaxima by ignoring some of its dependencies
    I'm a little bit confused

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: wxmaxima cannot connect to maxima

    Oops, sorry, checked again, you are right it is the science repo, I seem to
    be blind today - both maxima and wxMaxima from science not education.
    Your error message about gnuplot is weird.
    I have the following:
    Code:
    martinh@ganymed:~> rpm -q wxMaxima
    wxMaxima-11.04.0-16.1.x86_64
    martinh@ganymed:~> rpm -q maxima
    maxima-5.24.0-22.1.x86_64
    martinh@ganymed:~> rpm -q gnuplot
    gnuplot-4.4.2-4.8.x86_64
    gnuplot is simply from the standard repository.
    What shows "rpm -q gnuplot" on your machine?

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  5. #5

    Default Re: wxmaxima cannot connect to maxima

    Shows nothing because I have removed previous instalation of wxmaxima with all dependencies.
    "zypper rm -u package"

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: wxmaxima cannot connect to maxima

    tangram1 wrote:

    >
    > Shows nothing because I have removed previous instalation of wxmaxima
    > with all dependencies.
    > "zypper rm -u package"
    >

    I would simply try to install gnuplot first and then the maxima, wxmaxima
    from science.
    Can you post the output from
    Code:
    zypper lr -d
    to see which repositories you have enabled now?

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  7. #7

    Default Re: wxmaxima cannot connect to maxima

    Hm, I can do as you advice, but if wxmaxima needs gnuplot it should install it via dependencies and not manually by user action - or ?
    Currently I'm at work but in the evening I will send you my repos detail information.
    Till evening.

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: wxmaxima cannot connect to maxima

    tangram1 wrote:

    >
    > Hm, I can do as you advice, but if wxmaxima needs gnuplot it should
    > install it via dependencies and not manually by user action - or ?
    > Currently I'm at work but in the evening I will send you my repos
    > detail information.
    > Till evening.
    >

    Of course it SHOULD. But it does it not for you due to an unknown reason, so
    the question is, if you install it first, will it recognize that it is
    already there? First of all it is a workaround which may work and if it does
    it should be reported to the package maintainer, if not you need to look
    further what else in your system can create this behaviour. As you correctly
    recognise - this is not normal behaviour.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  9. #9

    Default Re: wxmaxima cannot connect to maxima

    I installed gnuplot(4.4.2-4.8) from standard repo and then I tried to install maxima in latest version 5.24.0-22.1, but it did not work, due to lack right gnuplot version for maxima 5.24.0-22.1.
    Code:
    zypper in -r14 maxima
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides plotutils needed by maxima-5.24.0-22.1.x86_64
     Solution 1: do not install maxima-5.24.0-22.1.x86_64
     Solution 2: break maxima by ignoring some of its dependencies
    I checked the available versions of the maxima
    Code:
    zypper se -us --match-exact --sort-by-repo maxima
    S | Name   | Type       | Version     | Arch   | Repository
    --+--------+------------+-------------+--------+-----------
      | maxima | package    | 5.17.0-1.2  | x86_64 | contrib
      | maxima | package    | 5.17.0-1.2  | i586   | contrib
      | maxima | srcpackage | 5.17.0-1.2  | noarch | contrib
      | maxima | package    | 5.23.2-1.2  | x86_64 | education
      | maxima | package    | 5.23.2-1.2  | i586   | education
      | maxima | srcpackage | 5.23.2-1.2  | noarch | education
      | maxima | package    | 5.24.0-22.1 | x86_64 | science
      | maxima | package    | 5.24.0-22.1 | i586   | science
      | maxima | srcpackage | 5.24.0-22.1 | noarch | science
    and tried with maxima-5.23.2-1.2.x86_64 - the same as above.

    I can install only maxima 5.17.0-1.2 which does not work with wxMaxima-11.04.0-16.1.x86_64
    and we are at the start point.

    Here are my repos:
    Code:
    #  | Alias                                 | Name                                  | Enabled | Refresh | Priority | Type   | URI                                                                         | Service
    ---+---------------------------------------+---------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------+--------
     1 | Aktualizacja-dla-openSUSE-11.4-11.4-0 | Aktualizacja dla openSUSE 11.4 11.4-0 | Yes     | Yes     |   99     | rpm-md | Index of /update/11.4                                   |        
     2 | contrib                               | contrib                               | Yes     | No      |   98     | rpm-md | Index of /repositories/openSUSE:/11.4:/Contrib/standard |        
     3 | education                             | education                             | Yes     | No      |   99     | rpm-md | Index of /repositories/Education/openSUSE_11.4           |        
     4 | game                                  | game                                  | Yes     | No      |   99     | rpm-md | Index of /repositories/games/openSUSE_11.4               |        
     5 | java                                  | java                                  | Yes     | No      |   98     | rpm-md | Index of /repositories/Java:/packages/openSUSE_11.4     |        
     6 | kde-update                            | kde-update                            | Yes     | No      |   99     | rpm-md | Index of /repositories/KDE:/UpdatedApps/openSUSE_11.4   |        
     7 | multimedia                            | multimedia                            | Yes     | No      |   98     | rpm-md | Index of /repositories/multimedia:/apps/openSUSE_11.4   |        
     8 | openSUSE-11.4-11.4-0                  | openSUSE-11.4-11.4-0                  | Yes     | Yes     |   99     | yast2  | Index of /distribution/11.4/repo/oss                    |        
     9 | packman                               | packman                               | Yes     | No      |   98     | rpm-md | Index of /suse/openSUSE_11.4/                                  |        
    10 | repo-debug                            | openSUSE-11.4-Debug                   | No      | Yes     |   99     | NONE   | Index of /debug/distribution/11.4/repo/oss              |        
    11 | repo-debug-update                     | openSUSE-11.4-Update-Debug            | No      | Yes     |   99     | NONE   | Index of /debug/update/11.4                             |        
    12 | repo-non-oss                          | openSUSE-11.4-Non-Oss                 | Yes     | Yes     |   99     | yast2  | Index of /distribution/11.4/repo/non-oss                |        
    13 | repo-source                           | openSUSE-11.4-Source                  | Yes     | Yes     |   98     | yast2  | Index of /source/distribution/11.4/repo/oss             |        
    14 | science                               | science                               | Yes     | No      |   99     | rpm-md | Index of /repositories/science/openSUSE_11.4             |
    Martin do not look on priority column, I usually use "-r" switch.

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: wxmaxima cannot connect to maxima

    tangram1 wrote:

    > zypper in -r14 maxima

    plotutils is in the standard repository, with your command you only accept
    additional dependencies to be satisfied from the one and only repository #14
    which you accept by this command and which does not contain plotutils.
    That explains also what happened with you gnuplot problem.
    As man zypper tells us
    Work only with the repository specified by the alias, name, number or URI.
    This option can be used multiple times.
    So the easiest solution is here to first install plotutils and then maxima.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •