Results 1 to 7 of 7

Thread: Resolution 1920x1080 don't max in all monitor area

  1. #1
    Join Date
    Jul 2008
    Location
    Brazil-So Paulo (S.B.Campo)
    Posts
    50

    Default Resolution 1920x1080 don't max in all monitor area

    I've instaled 11.4 and in personal configurations the resolution is set fine (1920x1080), but it's don't maximizes all monitor area.
    I'm using Radeon 5670 with a TV/Monitor HDMI connection 1080p.
    In Win7 running fine.

    how to solve this?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: Resolution 1920x1080 don't max in all monitor area

    1. Which graphics driver are you using?

    Code:
    /usr/sbin/hwinfo --gfxcard
    2. If the correct display resolution is set correctly, then this is really a monitor issue. You're effectively reporting that it is underscanning. Is there a setting on your monitor to correct this?

    A similar Ubuntu thread.

    3. What does this command report?

    Code:
    xrandr --prop
    Post the output here.

    4. If using the open source radeon driver, it may be possible to disable the underscan with

    Code:
    xrandr --output <outputname> --set underscan off
    using the appropriate 'output name' from the first 'xrandr --prop' command.
    Last edited by deano_ferrari; 21-May-2011 at 21:16.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: Resolution 1920x1080 don't max in all monitor area

    A bug report I found while searching around:

    https://bugs.freedesktop.org/show_bug.cgi?id=32450

  4. #4
    Join Date
    Jul 2008
    Location
    Brazil-So Paulo (S.B.Campo)
    Posts
    50

    Default Re: Resolution 1920x1080 don't max in all monitor area

    Quote Originally Posted by deano_ferrari View Post
    1. Which graphics driver are you using?

    Code:
    /usr/sbin/hwinfo --gfxcard
    2. If the correct display resolution is set correctly, then this is really a monitor issue. You're effectively reporting that it is underscanning. Is there a setting on your monitor to correct this?

    A similar Ubuntu thread.
    29: PCI 100.0: 0300 VGA compatible controller (VGA)
    [Created at pci.318]
    Unique ID: VCu0.I2ropVMqdC8
    Parent ID: _Znp.PirvQqgBhx1
    SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
    SysFS BusID: 0000:01:00.0
    Hardware Class: graphics card
    Model: "ATI VGA compatible controller"
    Vendor: pci 0x1002 "ATI Technologies Inc"
    Device: pci 0x68d8
    SubVendor: pci 0x1682 "XFX Pine Group Inc."
    SubDevice: pci 0x3061
    Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
    Memory Range: 0xfe9e0000-0xfe9fffff (rw,non-prefetchable)
    I/O Ports: 0xd000-0xdfff (rw)
    Memory Range: 0xfe9c0000-0xfe9dffff (ro,non-prefetchable,disabled)
    IRQ: 10 (no events)
    I/O Ports: 0x3c0-0x3df (rw)
    Module Alias: "pci:v00001002d000068D8sv00001682sd00003061bc03sc00i00"
    Driver Info #0:
    Driver Status: radeon is not active
    Driver Activation Cmd: "modprobe radeon"
    Config Status: cfg=new, avail=yes, need=no, active=unknown
    Attached to: #9 (PCI bridge)

    Primary display adapter: #29

    3. What does this command report?

    Code:
    xrandr --prop
    Post the output here.
    Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 1920 x 1920
    DFP1 disconnected (normal left inverted right x axis y axis)
    SignalFormat: DisplayPort
    ConnectorType: DisplayPort
    DFP2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
    EDID_DATA:
    9099ce0300000000d82f10908c7f0000
    2d130103801009780aee91a3544c9926
    0f5054bdef80714f8100814081809500
    950fb300a940023a801871382d40582c
    4500a05a0000001e662150b051001b30
    40703600a05a0000001e000000fd0018
    4b1a5117000a202020202020000000fc
    0053414d53554e470a2020202020013a
    SignalFormat: TMDS
    ConnectorType: HDMI
    1920x1080 60.0*+ 50.0 59.9 30.0 25.0 30.0 25.0 24.0 30.0 30.0 24.0
    1600x1200 60.0
    1776x1000 50.0 59.9 25.0 25.0 24.0 30.0 30.0
    1680x1050 50.0 59.9 25.0 30.0 24.0
    1400x1050 60.0 50.0 25.0 30.0 24.0
    1600x900 60.0 50.0 25.0 30.0 24.0
    1360x1024 60.0 50.0 25.0 30.0 24.0
    1280x1024 50.0 75.0 60.0 25.0 30.0 24.0
    1440x900 50.0 75.0 59.9 25.0 30.0 24.0
    1280x960 50.0 60.0 25.0 30.0 24.0
    1360x768 50.0 60.0 25.0 30.0 24.0
    1280x800 50.0 25.0 30.0 24.0 59.9
    1152x864 50.0 59.9 75.0 25.0 30.0 24.0
    1280x768 50.0 25.0 30.0 24.0 59.9
    1280x720 60.0 50.0 25.0 59.9 30.0 24.0
    1024x768 50.0 75.0 70.1 25.0 30.0 24.0 60.0
    1152x648 50.0 59.9
    800x600 50.0 25.0 30.0 24.0 72.2 75.0 60.3
    720x480 50.0 25.0 30.0 24.0 60.0 59.9
    640x480 50.0 25.0 30.0 24.0 75.0 72.8 66.8 59.9
    DFP3 disconnected (normal left inverted right x axis y axis)
    SignalFormat: TMDS
    ConnectorType: DVI-I
    CRT1 disconnected (normal left inverted right x axis y axis)
    SignalFormat: VGA
    ConnectorType: DVI-I

    4. If using the open source radeon driver, it may be possible to disable the underscan with

    Code:
    xrandr --output <outputname> --set underscan off
    using the appropriate 'output name' from the first 'xrandr --prop' command.
    I'm solve this problem installing a proprietary drivers, so, now I get this error on running glxgears:
    glxgears
    X Error of failed request: BadRequest (invalid request code or no such operation)
    Major opcode of failed request: 137 (GLX)
    Minor opcode of failed request: 19 (X_GLXQueryServerString)
    Serial number of failed request: 15
    Current serial number in output stream: 15
    Tks

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: Resolution 1920x1080 don't max in all monitor area

    The 'xrandr' commands were for the open source driver. I'm not sure that I can help if your switching to the proprietary driver. Maybe you can try using 'aticonfig' as explained in this post, (using dfp2 name instead).

    This Ubuntu thread uses the same approach. (The commands can be added in a script at X startup, once you have it working manually).

    You may also be able to configure your display via the Catalyst Control Center (proprietary driver utility via 'sudo amdcccle'). I don't have hardware capable of using the proprietary driver, so can't advise further here.

    There are lots of discussions on this topic concerning underscan with recent ATI cards and TV/monitors if you search. An interesting Mint thread.
    Last edited by deano_ferrari; 22-May-2011 at 12:42.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Resolution 1920x1080 don't max in all monitor area

    Quote Originally Posted by deano_ferrari View Post
    The 'xrandr' commands were for the open source driver. I'm not sure that I can help if your switching to the proprietary driver. Maybe you can try using 'aticonfig' as explained in this post, (using dfp2 name instead).

    This Ubuntu thread uses the same approach. (The commands can be added in a script at X startup, once you have it working manually).

    You may also be able to configure your display via the Catalyst Control Center (proprietary driver utility via 'sudo amdcccle'). I don't have hardware capable of using the proprietary driver, so can't advise further here.

    There are lots of discussions on this topic concerning underscan with recent ATI cards and TV/monitors if you search. An interesting Mint thread.
    My AMD graphics (and HD3450) typically 'just work' on my Dell Studio 1537 laptop.

    The command:
    Code:
    su -c 'amdcccle'
    works for me for running the catalyst control center.

    Having typed that, I normally do not use that command when I plug in a second monitor (for presentations at the office) but rather I use the 'xrandr' command which does work with the proprietary AMD catalyst (fglrx) driver.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: Resolution 1920x1080 don't max in all monitor area

    My AMD graphics (and HD3450) typically 'just work' on my Dell Studio 1537 laptop.
    I think this underscan issue only affects particular display devices, partcularly combined tv/monitors, when using certain display modes (interlaced at 50Hz/60Hz refresh rate perhaps?).

    I'm not sure how xrandr complient the proprietary driver is. Can one exectue the 'xrandr --output <outputname> --set....' form of the command ok?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •