Results 1 to 7 of 7

Thread: "Online updates" might not work for me in YaST2 and openSUSE 11.4 weeks after an openSUSE upgrade.

  1. #1

    Default "Online updates" might not work for me in YaST2 and openSUSE 11.4 weeks after an openSUSE upgrade.

    Hello. For the first time for me I upgraded an openSUSE Linux operating system while online. First my version 11.3 of openSUSE was updated. Then using a command which I think included "zypper" and "dup" in it I upgraded openSUSE from version 11.3 to 11.4; I think there may have been other steps involved in the upgrading which I am not mentioning here. I think the total size of the download for the upgrade would have been close to 2.3 Windows gigabytes (GiB) or so. Anyhow, it required many hours using an Internet connection at a friend's home with an Internet connection speed of sometimes very, very roughly 150 kilobytes/second, a speed which was highly variable.

    Some weeks of time have passed since that upgrade in April or early May of 2011. Today I could not obtain any updates to openSUSE 11.4 using YaST2 (Yet another Software Tool?); and I hadn't seen any updates mentioned for my openSUSE-11.4 installation over a period of weeks. For an operating system which was released on probably March 10, 2011 I would guess that there would have been some updates for it over the past two or more weeks. So I am suspicious that the updating of openSUSE 11.4 has not been working properly on my computer. Three openSUSE-11.4 repositories are shown as enabled on my computer: OSS (Operating System Software?), non-OSS, and Updates. The package liblzma0 is shown within YaST2's Software Management as installed on my computer (I read that someone reported trouble back in early March of 2011 with that package I think being removed associated with an openSUSE-11.3 to 11.4 upgrade.).

    In YaST2 after checking for updates no packages were listed as "Needed Packages." I instead chose "All Packages, All Packages" and then checked two uninstalled packages to be installed, then clicked on an "Accept" button. Immediately afterward no downloading was performed for me from the Internet. And later neither of those packages was shown as installed in the "All Packages" listing.

    1. How may I "diagnose" problems with YaST2's "Online Updates" on my computer?

    2. What should I do to fix "Online Updates" on my computer in openSUSE 11.4, assuming it needs to be fixed on my computer?

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: "Online updates" might not work for me in YaST2 and openSUSE11.4 weeks after an openSUSE upgrade.

    On 2011-05-21 23:06, 2009Newbie wrote:
    >
    > Hello. For the first time for me I upgraded an openSUSE Linux operating
    > system while online. First my version 11.3 of openSUSE was updated.
    > Then using a command which I think included "zypper" and "dup" in it I
    > upgraded openSUSE from version 11.3 to 11.4; I think there may have been
    > other steps involved in the upgrading which I am not mentioning here.


    Precision is important. I hope you read somewhere the needed steps. Where?

    > I
    > think the total size of the download for the upgrade would have been
    > close to 2.3 Windows gigabytes (GiB) or so.


    Windows gigabytes? What's that?

    If you mean GiB, that's Gibibytes, binary-giga bytes. Nothing to do with
    Windows.


    > So I am suspicious that the updating of openSUSE
    > 11.4 has not been working properly on my computer. Three openSUSE-11.4
    > repositories are shown as enabled on my computer: OSS (Operating System
    > Software?), non-OSS, and Updates.


    No, I will not take your word on it - show us proof >:-)

    Show us the output of "zypper lr --details" and paste it here inside code
    tags (advanced editor, '#'). Not as quotes.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3

    Default Re: "Online updates" might not work for me in YaST2 and openSUSE 11.4 weeks after an openSUSE upgrad

    Thanks, Carlos E. R., for kindly taking the time to write to me. Gratefully my problem of failing to obtain updates to software installed in an openSUSE-11.4, Linux operating system has been solved. But I'm not certain precisely why it has been solved or what the exact problem was; nevertheless I am happy that it has been solved. Basically I started another session using my computer in my friend's mobile home with a fresh connection of an ethernet cable from an ethernet card to her modem, a fresh start of openSUSE 11.4, etc. And this time gratfully I could obtain the openSUSE-11.4 updates. Earlier yesterday or today when I was having the failure I wish I had tried some simple things like trying to visit a Web page in a browser, checking an ethernet cable connection, and looking for the Network Manager panel icon. But early I think I did a poor job in not checking and/or paying attention to those simple things; sorry about that.

    In answer to some questions and comments of yours below is the output corresponding to the command "zypper lr --details" obtained while online in my installation of the openSUSE-11.4, Linux operating system.

    Code:
    linux-iy6k:~ # zypper lr --details
    #  | Alias                                                    | Name                                                     | Enabled | Refresh | Priority | Type   | URI                                                             | Service
    ---+----------------------------------------------------------+----------------------------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
     1 | Updates for openSUSE 11.3 11.3-1.82                      | Updates for openSUSE 11.3 11.3-1.82                      | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.3/                       |        
     2 | http://download.videolan.org/pub/videolan/vlc/SuSE/11.4/ | http://download.videolan.org/pub/videolan/vlc/SuSE/11.4/ | No      | Yes     |   99     | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/11.4/        |        
     3 | openSUSE-11.3 11.3-1.82                                  | openSUSE-11.3 11.3-1.82                                  | No      | No      |   99     | yast2  | cd:///?devices=/dev/sr0,/dev/sr1                                |        
     4 | repo-11.4-non-oss                                        | openSUSE-11.4 Non-OSS                                    | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss     |        
     5 | repo-11.4-oss                                            | openSUSE-11.4 OSS                                        | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss         |        
     6 | repo-11.4-update                                         | openSUSE-11.4 Updates                                    | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/update/11.4                        |        
     7 | repo-debug                                               | openSUSE-11.3-Debug                                      | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.3/repo/oss/  |        
     8 | repo-non-oss                                             | openSUSE-11.3-Non-Oss                                    | No      | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss/    |        
     9 | repo-oss                                                 | openSUSE-11.3-Oss                                        | No      | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/        |        
    10 | repo-source                                              | openSUSE-11.3-Source                                     | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.3/repo/oss/ |        
    linux-iy6k:~ #
    Sorry, I did not include the explanation of YaST2 in my previous posting here, namely Yet another Setup Tool 2. I think one reason I may have referred to Windows gigabytes as GiB could be because I may have read quite some time ago that Windows used GiB, of course in the case of hard-disk drives that have at least a GiB of capacity. But sorry, I realize that referring to Windows gigabytes as GiB is wrong or could lead to a mixup. I was aware that a GiB is a number of bytes which is some power of two resulting in 2**(that power) or 2^(that power) close, but not exactly equal to one billion (I saw from the Internet that that power of two is 30. And I see that 2**30=1,073,741,824). The new thing I learned from you is that GiB stands for gibibytes. So thanks for teaching me that. Also I see that openSUSE-11.3 also referred to a size in GiB. So I think it is better for me to refer to a GiB as 2^30 or 2**30 binary bytes, or else a gibibyte.

    I found my notes written while making the online upgrade of openSUSE from version 11.3 to 11.4 during April 27-28, 2011. The steps I followed had a great overlap with the steps outlined at http://en.wikipedia.org/Upgrade on the Internet. I set up one third-party repository for downloading, namely Index of /pub/videolan/vlc/SuSE/11.4/ after changing 11.3 to 11.4 in that URL (Uniform Resource Locator). And I used this URL for the both the "Name" and "URL" fields for this repository. However, I think one of the zypper commands I used might have resulted in overruling that third-party repository with an openSUSE repository for VideoLAN software, which, if so, is okay with me, as long as that works.

    During the downloading and/or installing of the upgrade software an early problem was that I had error number 30987, which I suppose was likely a result of my RedHat Package Manager (RPM) database being corrupt, based on someone else's similar experience posted at Crash during update. Will not update. on the Internet. From that Internet reference I learned that I could enter the command "rpmdb --rebuilddb" to probably rebuild my openSUSE rpm database. Evidently and fortunately that gratefully worked for me to afterward avoid the error number 30987.

    To reduce the risk of a possible non-working or partially non-working or so-called "broken" installation of openSUSE during an openSUSE upgrading process, other people could perform an online upgrade in an ideal way and in a way somewhat different than the way I did; but due to limited free disk space on the root partition of a hard-disk drive this way I am about to discuss may not be practical for everyone. I recommend that an openSUSE online upgrader (person): 1) backup his hard-disk drive. 2) Perform the online upgrade somewhere where he can have access to an Internet connection for many preferably, but I guess not essentially, non-stop hours, unless his Internet connection speed is extremely high. That could be in someone's home, perhaps the upgrader's own home. 2) Somehow find out how many GiB of downloading his upgrading is going to require. For me the answer was at least 2.35 GiB. I am not certain if it is possible to know the size of the download an upgrader will need before starting the downloading for his upgrade. But if that is possible, then an upgrader could perhaps prepare enough free space on his openSUSE root partition for the big download before he starts the downloading. If it is not possible to know that number of GiB before the downloading starts, then at least by shortly after the time an upgrader finishes typing "zypper ref" and "zypper dup," he should be informed of the number of GiB of downloading an upgrade will require for him, at least for an openSUSE-11.3-to-11.4 upgrade. Then I would expect that the upgrader should be able to very quickly interrupt the downloading by briefly and simultaneously holding his computer keyboard's "ctrl" and "C" keys to interrupt the downloading. Anyhow, before doing much, if any downloading I recommend that the upgrader prepare enough GiB of free space on his old version of openSUSE's root partition for the entire download needed to make the upgrade of openSUSE. 3) With enough free space on the root partition of the hard-disk drive, instead of typing 'zypper dup', I recommend that the upgrader type 'zypper dup --download "in-advance" ' using the double, but not the single quotation marks. I have not done that and have no experience with it. But I think the purpose of such a command is to first download all of the required software to make the openSUSE upgrade. Then after that the new software for the newer version of openSUSE is to be installed on the computer.

    The advantage of using the 'zypper dup --download "in-advance" ' command is that if there is a power failure, an Internet connection is lost, or for any reason the downloading has to be interrupted or the computer is or has to be powered off, he will still have a working openSUSE operating system, the lower version of it, of course not the newer version of it yet. Then after that I presume that the time to install the upgrade version of openSUSE would take less time than the downloading of the new software. If there is a problem of some kind during the installation of the new version of the openSUSE operating system, then the upgrader could restore his hard-disk drive's software using his hard-disk drive backup that he hopefully made prior to starting the upgrade process and then try the upgrade procedure again.

    However, in my case I used the "zypper dup" command which I think downloaded a software package, installed it, downloaded another package, installed it, etc. Doing things that way did not require a large volume of free disk space on my openSUSE-11.3 root partition. I probably could have arranged such free space using the program GParted [(Gnu Not Unix) GNU Partition Editor]; but you could say I took the easy route of typing the command "zypper dup," which included the risk of having a "broken" operating system, if something were to have gone badly wrong during the downloading and upgrading process. But I am grateful that fortunately after I completed the online upgrade using the "zypper dup" command, I was able to use a program I used quite often in the new, openSUSE-11.4 operating system. But as I think about things now, making the hard-drive backup and using "zypper dup" command may not be a bad way to do things, relying on the hard-disk-drive backup to, if necessary, restore the old, openSUSE operating system before the new one is in place and ready to use. Then in that case regarding the importance of making the hard-disk drive backup the saying, "Don't throw away your old shoes until you get your new ones" seems appropriate here where the old shoes would be analogous to the old version of openSUSE and the new shoes would be analogous to the new version of openSUSE in the upgrade process.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: "Online updates" might not work for me in YaST2 and openSUSE 11.4 weeks after an openSUSE upgrad

    Quote Originally Posted by 2009Newbie View Post

    Code:
    linux-iy6k:~ # zypper lr --details
    #  | Alias                                                    | Name                                                     | Enabled | Refresh | Priority | Type   | URI                                                             | Service
    ---+----------------------------------------------------------+----------------------------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
     4 | repo-11.4-non-oss                                        | openSUSE-11.4 Non-OSS                                    | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss     |        
     5 | repo-11.4-oss                                            | openSUSE-11.4 OSS                                        | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss         |        
     6 | repo-11.4-update                                         | openSUSE-11.4 Updates                                    | Yes     | Yes      |   99     | rpm-md | http://download.opensuse.org/update/11.4                        |        
     
    linux-iy6k:~ #
    From what I see here it's a mess
    VideoLan is Taboo as far as I'm concerned

    I made some changes including switching refresh on to Updates

    Then run
    Multimedia in One Click
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: "Online updates" might not work for me in YaST2 and openSUSE11.4 weeks after an openSUSE upgrade.

    On 2011-05-23 07:06, 2009Newbie wrote:

    > Code:
    > --------------------
    > linux-iy6k:~ # zypper lr --details
    > # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    > ---+----------------------------------------------------------+----------------------------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    > 1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | No | Yes | 99 | rpm-md | http://download.opensuse.org/update/11.3/ |


    Remove.

    > 2 | http://download.videolan.org/pub/vid...vlc/SuSE/11.4/ | http://download.videolan.org/pub/vid...vlc/SuSE/11.4/ | No | Yes | 99 | rpm-md | http://download.videolan.org/pub/vid...vlc/SuSE/11.4/ |


    Probably remove.

    > 3 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | No | No | 99 | yast2 | cd:///?devices=/dev/sr0,/dev/sr1 |


    Remove. Add if necessary again for 11.4

    > 4 | repo-11.4-non-oss | openSUSE-11.4 Non-OSS | Yes | No | 99 | yast2 | http://download.opensuse.org/distrib...4/repo/non-oss |
    > 5 | repo-11.4-oss | openSUSE-11.4 OSS | Yes | No | 99 | yast2 | http://download.opensuse.org/distribution/11.4/repo/oss |
    > 6 | repo-11.4-update | openSUSE-11.4 Updates | Yes | No | 99 | rpm-md | http://download.opensuse.org/update/11.4 |


    Activate refresh for updates, or there will be no updates.

    > 7 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/d...11.3/repo/oss/ |


    Remove.

    > 8 | repo-non-oss | openSUSE-11.3-Non-Oss | No | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |


    Remove.

    > 9 | repo-oss | openSUSE-11.3-Oss | No | Yes | 99 | yast2 | http://download.opensuse.org/distrib...11.3/repo/oss/ |


    Remove.

    > 10 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/...11.3/repo/oss/ |


    Remove.

    > linux-iy6k:~ #
    >
    > --------------------




    > So I think it is better for me to refer to a GiB as 2^30 or
    > 2**30 binary bytes, or else a gibibyte.


    If you search gibibyte in the wikipedia you will see the full explanation.
    It is an international standard :-)


    >
    > I found my notes written while making the online upgrade of openSUSE
    > from version 11.3 to 11.4 during April 27-28, 2011. The steps I
    > followed had a great overlap with the steps outlined at
    > http://en.wikipedia.org/Upgrade on the Internet.


    Use the upgrade notes in our wiki, not those of the wikipedia.



    > upgrader finishes typing "zypper ref" and "zypper dup," he should be
    > informed of the number of GiB of downloading an upgrade will require for
    > him, at least for an openSUSE-11.3-to-11.4 upgrade.


    You can run the dup in download only mode. It the space is not sufficient
    it will crash, but nothing will be installed and the system will still work.

    And I think it does tell you of the intended download size.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  6. #6

    Default Re: "Online updates" might not work for me in YaST2 and openSUSE 11.4 weeks after an openSUSE upgrad

    Thanks to each of you who kindly posted some helpful comments here. My main error was apparently in not selecting "Automatically refresh" or something similar for the openSUSE-11.4 updates repository; but after selecting "Automatically refresh" for it, I gratefully could obtain updates from the openSUSE-11.4 updates repository. My openSUSE-11.3 repositories were disabled, therefore inactive and not a factor once I started upgrading to openSUSE 11.4. But, as one of you suggested, I did delete them. I added one more repository called "openSUSE-11.4-Source" for kernel source code with the Uniform Resource Locator (URL) Index of /source/distribution/11.4/repo/oss. The software packages "kernel source code" and "kernel development" or "kernel devel" were on June 2, 2011 found to already be installed on my computer, I suppose for openSUSE 11.4. A test of my computer being updated from the "openSUSE-11.4-Source" repository could be to see if I obtain new kernel source code as an update when a Linux kernel newer than version 2.6.37.6-0.5 becomes available for openSUSE 11.4 and my computer is somewhere that I can connect to the Internet in openSUSE 11.4 via a fast Internet connection.

    I appreciate the comments about the detailed design for online upgrading of openSUSE. Based on them it appears that the online upgrading of openSUSE has been fairly intelligently designed regarding probably informing a user of how much free disk space will be required before an upgrade really begins to take place and concerning the available free disk space on a user's computer.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: "Online updates" might not work for me in YaST2 and openSUSE11.4 weeks after an openSUSE upgrade.

    On 2011-06-08 00:36, 2009Newbie wrote:

    > I added one more repository called "openSUSE-11.4-Source"
    > for kernel source code with the Uniform Resource Locator (URL) 'Index of
    > /source/distribution/11.4/repo/oss'


    Notice that we don't normally use this package. We use the package
    "kernel-source" from the OSS repository.

    The package obtained from the -source repo is for something quite
    different, that I doubt you need.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •