Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: sshd not starting on boot

  1. #1
    Will Honea NNTP User

    Default sshd not starting on boot

    Running 11.4 x64, I've tried everything I can think of (which is not saying
    a lot) but I can't get sshd started on boot. Running /etc/init.d/sshd
    starts the service manually with no problem but I really need it started on
    boot.

    I can't find anything different when comparing this instance with other
    similar instances where sshd does start but this instance is an update from
    11.3 where sshd was not enabled and the others are all clean installs where
    sshd was enabled during installation, if that makes any difference.

    --
    Will Honea

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: sshd not starting on boot

    Have you set it to start in the System Services (Runlevel)?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: sshd not starting on boot

    What does
    Code:
    /sbin/chkconfig -l sshd
    show?
    Did you enable it with yast -> runlevels to start in runlevel 3 and 5?

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  4. #4
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: sshd not starting on boot

    Maybe You have the daemon set up to listen on a specific IP and the ip is different now. What have You got configured in "/etc/ssh/sshd_config" ?

    Best regards,
    Greg
    Best regards,
    Greg

  5. #5
    Will Honea NNTP User

    Default Re: sshd not starting on boot

    caf4926 wrote:

    > Have you set it to start in the System Services (Runlevel)?


    Set to runlevels 3 and 5. On reboot, this shows the correct runlevels but
    the "running" entry is "yes*" - not started. No mention of sshd in any logs
    except for those shown for when I manually start the service and when a
    login is attempted.

    This is getting frustrating! I'm about ready to start inserting debug
    messages into the start-up scripts in /etc/init.d just see if they are even
    being run.

    --
    Will Honea

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: sshd not starting on boot

    On 2011-05-21 23:43, Will Honea wrote:

    > This is getting frustrating! I'm about ready to start inserting debug
    > messages into the start-up scripts in /etc/init.d just see if they are even
    > being run.


    Disable run parallel for the scripts. If it works, known bug.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7
    Will Honea NNTP User

    Default Re: sshd not starting on boot

    Carlos E. R. wrote:

    > On 2011-05-21 23:43, Will Honea wrote:
    >
    >> This is getting frustrating! I'm about ready to start inserting debug
    >> messages into the start-up scripts in /etc/init.d just see if they are
    >> even being run.

    >
    > Disable run parallel for the scripts. If it works, known bug.


    Give the man a cigar! That worked. Where do you see these little gems you
    keep coming up with?

    Funny that a clone installation on another drive doesn't have the problem...

    --
    Will Honea

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: sshd not starting on boot

    On 2011-05-22 02:17, Will Honea wrote:
    > Carlos E. R. wrote:


    >> Disable run parallel for the scripts. If it works, known bug.

    >
    > Give the man a cigar! That worked. Where do you see these little gems you
    > keep coming up with?


    X'-)

    It happens to be a bug in which I am interested. There are many posts here
    and in the mail lists, it took many people and many tests to find that trick.

    However, using that trick makes boot/halt much slower.


    It is Bug 642289 - System does not boot correctly with
    sysvinit-tools-2.88-15.1.x86_64.rpm or newer (blogd issue), which is
    listed as solved.

    Are you sure you installed all the updates?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  9. #9
    Will Honea NNTP User

    Default Re: sshd not starting on boot

    Carlos E. R. wrote:

    > On 2011-05-22 02:17, Will Honea wrote:
    >> Carlos E. R. wrote:

    >
    >>> Disable run parallel for the scripts. If it works, known bug.

    >>
    >> Give the man a cigar! That worked. Where do you see these little gems
    >> you keep coming up with?

    >
    > X'-)
    >
    > It happens to be a bug in which I am interested. There are many posts here
    > and in the mail lists, it took many people and many tests to find that
    > trick.
    >
    > However, using that trick makes boot/halt much slower.
    >
    >
    > It is “Bug 642289 - System does not boot correctly with
    > sysvinit-tools-2.88-15.1.x86_64.rpm or newer (blogd issue)”, which is
    > listed as solved.
    >
    > Are you sure you installed all the updates?


    Yep. I think I remember seeing sysvinit update come in. I'll keep playing
    and see if I may have skipped it or just not gotten it yet...

    Hmmmmm I show sysvinit-tools-2.88.37.45.1 installed from the update repo.
    Wonder if there was a regression? If I can confirm the behavior I'll re-
    open the bug.

    --
    Will Honea

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: sshd not starting on boot

    On 2011-05-22 04:02, Will Honea wrote:
    > Hmmmmm I show sysvinit-tools-2.88.37.45.1 installed from the update repo.
    > Wonder if there was a regression? If I can confirm the behavior I'll re-
    > open the bug.


    Keep us informed...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •